Advertisement:

Author Topic: ssi_recentPoll problems  (Read 4110 times)

Offline Aquilo

  • The Black Llama
  • SMF Hero
  • ******
  • Posts: 1,518
  • Gender: Male
  • ‹^^› ‹(-_-)› ‹^^›
    • The Arencibia's
ssi_recentPoll problems
« on: April 02, 2004, 07:46:40 AM »
is it me or is ssi_recentPoll() not working?

I'm trying to put together a home page on localhost too be uploaded to xtram and was just playing with the functions and ssi_recentPoll(), ssi_recentPoll('echo') what ever is simply printing array

also if I don't use the domain or I guess $boardurl in the address bar I get dup. header error for ssi_recentPoll()

example it works here
http://localhost/smf_forum/test.php
and localhost/smf_forum is the $boardurl

but if I try accessing it from
http://aquilo.homeip.net/smf_forum/test.php

I get the headers error.


here is test.php
Code: [Select]
<?php
$ssi_gzip 
1;
$ssi_ban 1;
//$ssi_theme = &#39;vBulletin&#39;;
$ssi_layers = array(&#39;main&#39;);

include_once &#39;SSI.php&#39;;

echo &#39;<br />
<table border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse" width="100%">
<tr>
<td width="20%">&#39;,
ssi_logOnline(),
&#39;<br />&#39;,
ssi_boardStats(),
&#39;<br />&#39;,
ssi_recentPoll(), &#39;</td>
<td width="80%">
<div style="float: left;">&#39;, ssi_recentTopics(), &#39;</div>
<div style="float: right;">&#39;, ssi_topBoards(), &#39;</div></td>
</tr>
</
table>
&
#39;;

ssi_shutdown();
?>

is this a bug or desired?

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: ssi_recentPoll problems
« Reply #1 on: April 02, 2004, 09:20:08 PM »
The ssi_ functions don't return anything - you should echo them.

It will return an empty array if there are no polls.

-[Unknown]

Offline Aquilo

  • The Black Llama
  • SMF Hero
  • ******
  • Posts: 1,518
  • Gender: Male
  • ‹^^› ‹(-_-)› ‹^^›
    • The Arencibia's
Re: ssi_recentPoll problems
« Reply #2 on: April 02, 2004, 10:00:28 PM »
I have a poll on localhost for testing, and now on xtram, and it messing up once you have voted, pluse you can't vote from it.

http://www.xtram.net/smf/test.php

is it supposed to show the results if the poll has been voted in? or empty array?

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: ssi_recentPoll problems
« Reply #3 on: April 02, 2004, 11:24:01 PM »
It will return an empty array if, for any reason, there are no polls you can vote in.  Whether this is because of permissions, or because you've voted in all of them doesn't matter.

-[Unknown]