Advertisement:

Author Topic: [Theme] SMFone  (Read 403437 times)

Offline peterstannard

  • Full Member
  • ***
  • Posts: 536
Re: [Theme] SMFone
« Reply #540 on: December 23, 2005, 12:52:01 PM »
very nice design and i would really like to use it for my smf but there is an error since i installed the theme. i cant access the package manager anymore, so i cant install the update, because i use smf 1.1 rc1

Just download the updater, uppack it on your desktop, upload all the files to the correct Themes directory and delete the files FSL specified above and the theme will be updated.

Offline DucTX

  • Newbie
  • *
  • Posts: 5
Re: [Theme] SMFone
« Reply #541 on: December 23, 2005, 01:57:09 PM »
still doesnt work. i dont know why. its ERROR 500.

Offline fugiFox

  • Jr. Member
  • **
  • Posts: 342
Re: [Theme] SMFone
« Reply #542 on: December 23, 2005, 07:25:47 PM »
http://www.thmmy.gr/smf/index.php?action=forum

What's the purpose of the buttons at the right up corner and how will I get rid of them if they aren't useful?

Thnx

I guess my msg was burried under the next posts? :(

Offline peterstannard

  • Full Member
  • ***
  • Posts: 536
Re: [Theme] SMFone
« Reply #543 on: December 24, 2005, 07:31:33 AM »
http://www.thmmy.gr/smf/index.php?action=forum

What's the purpose of the buttons at the right up corner and how will I get rid of them if they aren't useful?

Thnx

I guess my msg was burried under the next posts? :(

They look like they are from the Tinyportal mod, to shrink it.

Offline Eren Yaşarkurt

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,134
  • Gender: Male
  • aka forsakenlad
    • erenyasarkurt on Facebook
    • erenyasarkurt on LinkedIn
    • @erenyasarkurt on Twitter
    • yekolay
Re: [Theme] SMFone
« Reply #544 on: December 24, 2005, 07:37:45 AM »
still doesnt work. i dont know why. its ERROR 500.

You might have mod_secuirty on. Please search the forum for the fix ;)
Eren "forsakenlad" Yaşarkurt
SMF Friend & Former Team Member

yemek siparişi - order your food quick and easy

Offline loldaolda

  • Semi-Newbie
  • *
  • Posts: 90
  • Gender: Male
    • Unique (not only) schemes for Sony Ericsson W800i | K750i | D750i | K700i
Re: [Theme] SMFone
« Reply #545 on: December 25, 2005, 06:59:32 AM »
does this theme for MKPORTAL exist?
Now, I would love that too!!! But i fear, it does not exist :(


Actarus Actually made what we were looking for!!! YAY lookie here http://www.mkportal.it/support/showthread.php?p=58261

Offline Eren Yaşarkurt

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,134
  • Gender: Male
  • aka forsakenlad
    • erenyasarkurt on Facebook
    • erenyasarkurt on LinkedIn
    • @erenyasarkurt on Twitter
    • yekolay
Re: [Theme] SMFone
« Reply #546 on: December 25, 2005, 07:43:16 AM »
He probably hasn't got permission from A.M.A, so it can be illegal using it ;)
Eren "forsakenlad" Yaşarkurt
SMF Friend & Former Team Member

yemek siparişi - order your food quick and easy

Offline loldaolda

  • Semi-Newbie
  • *
  • Posts: 90
  • Gender: Male
    • Unique (not only) schemes for Sony Ericsson W800i | K750i | D750i | K700i
Re: [Theme] SMFone
« Reply #547 on: December 25, 2005, 04:23:48 PM »
well im sure ama doesnt mind as the skin at mkportal is free.
 I suposse... And aside from it - AMA let the SMFone DIE! If it wasnt you forsakenlad, this theme would be forgotten for good!

Offline peterstannard

  • Full Member
  • ***
  • Posts: 536
Re: [Theme] SMFone
« Reply #548 on: December 31, 2005, 09:07:06 PM »
Smfone Theme CSS Updates For SMF 1.1 RC2

Intro
If you have upgraded your SMF forum to the latest release (RC2)
then you will probably have noticed that borders have been added
around your images. The included CSS files fix this.

Installation
1. Rename the appropriate colour .css file to style.css
2. Upload to your Smfone directory (typically: www.yourdomain.com/forum/Themes/smfone/)
[You will need to overwrite the current .css file]
3. Thats it. Your Smfone theme will now work with SMF RC2.

Download Link
http://peterstannard.com/site/smf/smfone-1.1rc2-css-update.zip [Red, Green, Blue and Grey CSS included]

Offline shen brood

  • Semi-Newbie
  • *
  • Posts: 49
Re: [Theme] SMFone
« Reply #549 on: January 01, 2006, 08:03:18 AM »
Thanks for this update I was really puzzled as to what happened... you rock!

Offline peterstannard

  • Full Member
  • ***
  • Posts: 536
Re: [Theme] SMFone
« Reply #550 on: January 01, 2006, 08:43:34 AM »
Smfone Theme index.template.php Updates For SMF 1.1 RC2

Installation
1. Remove "smfone-1.1rc2-update-" from the filename leaving index.template.php
2. Upload to your Smfone directory (typically: www.yourdomain.com/forum/Themes/smfone/)
[You will need to overwrite the current index.template.php file]
3. Thats it. Your Smfone theme will now work with SMF RC2.

Download Link
http://peterstannard.com/site/smf/smfone-1.1rc2-update-index.template.zip

[Only use this update if you have not modified the index.template.php. If you have modified it manually or installed mods which may have modified this file it will be best to manually update the index.template. Take a look @ this topic: here]

Offline dustrho

  • Jr. Member
  • **
  • Posts: 132
  • Gender: Male
Re: [Theme] SMFone
« Reply #551 on: January 02, 2006, 10:47:59 AM »
I have a couple of questions about this theme, and I'm sure they're easy fixes but I've tried messing with the code with no luck.  Here goes...

- How do I get rid of the forum title on the upper left-hand side of the screen?  I'd rather not have that there when I have my own logo saying the same thing.

- My personal logo is located on the right side of the screen.  How do I change the placement of it, so that it's on the left or centered?

- If I want to add some of my own text links say under the banner, where in the code (index template) can I put those in?

- Thumbnail images aren't showing... just a link of it.  I've checked the Attachments section and all seems to be in working order.  Any idea on how to fix that?

Thanks all for a great theme!
« Last Edit: January 02, 2006, 05:04:44 PM by dustrho »

Offline dustrho

  • Jr. Member
  • **
  • Posts: 132
  • Gender: Male
Re: [Theme] SMFone
« Reply #552 on: January 03, 2006, 10:36:26 PM »
^^^^^^^^^^ Anyone?

Offline Jelte

  • Semi-Newbie
  • *
  • Posts: 17
Re: [Theme] SMFone
« Reply #553 on: January 04, 2006, 08:50:13 AM »
I've have seen a solution for my problem in this topic, only that was for the older index.template.php file (rc 1).

- I would also like to delete the newsbox.
- Also i would like to delete the forum name and logo in top.
- I also have the background of the forum white. Now the roudings have still grey in it, do you have a set of transparant roundings?

Is this possible? And what do I need to change?

Thanks in advance.
« Last Edit: January 04, 2006, 09:21:23 AM by Jelte »

Offline peterstannard

  • Full Member
  • ***
  • Posts: 536
Re: [Theme] SMFone
« Reply #554 on: January 04, 2006, 10:32:16 AM »
- I would also like to delete the newsbox.
You can disable the newsbox. Better than removing the coding IMO. This can be done in the Themes part of the admin centre.

- I also have the background of the forum white. Now the roudings have still grey in it, do you have a set of transparant roundings?
Edit the .css. Use the hex code #FFFFFF

- Also i would like to delete the forum name and logo in top.
This can be done in the Theme area in the admin centre. Click current theme >> edit index.template.php and take a look @ this part of the code in the "from Line 50" section, third box down.

Code: [Select]
   // This part is the logo and forum name.  You should be able to change this to whatever you want...
    if (empty($settings['your_logo']))
   {
   echo '
       <div style="float: right;">
         <a href="http://lfcgoals.com/forum/index.php" target="_self"><img src="', $settings['images_url'], '/lfcgoals_logo_1.jpg" alt="" width="338" border="0" /></a>       </div>';
   }
    else
   {
   echo '
       <div style="float: right;">
         <img src="', $settings['your_logo'], '" style="float: right;" alt="" />
       </div>';
   }

   echo '
<script type="text/javascript"><!--
google_ad_client = "pub-1164140133612851";
google_ad_width = 468;
google_ad_height = 60;
google_ad_format = "468x60_as";
google_ad_type = "text";
google_ad_channel ="5747888358";
google_color_border = "E2E2E2";
google_color_bg = "E2E2E2";
google_color_link = "000000";
google_color_url = "666666";
google_color_text = "333333";
//--></script>
<script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
   </div>

<br />
<table border="0" cellpadding="0" cellspacing="0" width="100%" id="upshrinkHeader"', empty($options['collapse_header']) ? '' : ' style="display: none;"', '>
  <tr>
    <td width="67%" valign="top">

<table border="0" cellpadding="0" cellspacing="0" width="100%">
  <tr>
    <td width="0%"><img src="', $settings['images_url'], '/re_b_top1.gif" alt="" /></td>
    <td width="100%" style="background-image: url(', $settings['images_url'], '/re_b_top2.gif);"><img src="', $settings['images_url'], '/', $context['user']['language'], '/userinfo.gif" alt="" /></td>
    <td width="0%"><img src="', $settings['images_url'], '/re_b_top3.gif" alt="" /></td>
  </tr>
  <tr>
    <td width="0%" style="background-image: url(', $settings['images_url'], '/re_b_mid1.gif);"></td>
    <td width="100%" style="background-color: #D5D5D5;">
                  <table width="100%" cellpadding="0" cellspacing="2" border="0"><tr>';

   if (!empty($context['user']['avatar']))
      echo '<td valign="middle">', $context['user']['avatar']['image'], '</td>';

   echo '<td width="100%" valign="top" class="smalltext" style="font-family: verdana, arial, sans-serif;">';

This is the code from the top of my forum: www.lfcgoals.com
« Last Edit: January 04, 2006, 10:42:23 AM by peterstannard »

Offline peterstannard

  • Full Member
  • ***
  • Posts: 536
Re: [Theme] SMFone
« Reply #555 on: January 04, 2006, 10:39:41 AM »
- How do I get rid of the forum title on the upper left-hand side of the screen?  I'd rather not have that there when I have my own logo saying the same thing.
Take a look @ this code.
Code: [Select]
// This part is the logo and forum name.  You should be able to change this to whatever you want...
    if (empty($settings['your_logo']))
   {
   echo '
       <div style="float: right;">
         <a href="http://lfcgoals.com/forum/index.php" target="_self"><img src="', $settings['images_url'], '/lfcgoals_logo_1.jpg" alt="" width="338" border="0" /></a>       </div>';

This is the bit you will need to edit/remove.
Code: [Select]
         <a href="http://lfcgoals.com/forum/index.php" target="_self"><img src="', $settings['images_url'], '/lfcgoals_logo_1.jpg" alt="" width="338" border="0" /></a>

- My personal logo is located on the right side of the screen.  How do I change the placement of it, so that it's on the left or centered?
See the code I posted in the post above this one. Where you see float right, instead float it left/centre.

- If I want to add some of my own text links say under the banner, where in the code (index template) can I put those in?
Again see the code posted in the above post. That handles the top of the theme. You will need to put the HTML code for the links somewhere in there.

- Thumbnail images aren't showing... just a link of it.  I've checked the Attachments section and all seems to be in working order.  Any idea on how to fix that?
Look in the attachments and avatars part of the admin centre, tick "Display image attachments as pictures under post"
« Last Edit: January 04, 2006, 10:41:29 AM by peterstannard »

Offline dustrho

  • Jr. Member
  • **
  • Posts: 132
  • Gender: Male
Re: [Theme] SMFone
« Reply #556 on: January 04, 2006, 08:46:51 PM »
- Thumbnail images aren't showing... just a link of it.  I've checked the Attachments section and all seems to be in working order.  Any idea on how to fix that?
Look in the attachments and avatars part of the admin centre, tick "Display image attachments as pictures under post"

That box is already checked off.  Under all the other themes I have installed (there's about 5 other themese people can choose from) people can view the attachments just fine, but no one can see the attachments under this particular theme.  Is there a specific file that I need to check or something?

As far as the other suggestions go I'll have to try those later.

Thanks for the suggestions!

Offline Tiramisu

  • Jr. Member
  • **
  • Posts: 110
  • Gender: Female
    • Malaysians Abroad Community Forum
Re: [Theme] SMFone
« Reply #557 on: January 05, 2006, 03:59:51 AM »
Hi!

I really love this theme ... but one issue:

When topic is locked and sticky ... the icon doesnt appear ... just the box with red cross ... why? How can I rectify this?

Offline Jelte

  • Semi-Newbie
  • *
  • Posts: 17
Re: [Theme] SMFone
« Reply #558 on: January 05, 2006, 07:53:55 AM »
Quote
You can disable the newsbox. Better than removing the coding IMO. This can be done in the Themes part of the admin centre.

Done this, but then the profile info isn't over the hole width. Would like to see that.

Quote
Edit the .css. Use the hex code #FFFFFF

I had already done that, but then there are still some images with grey in it... that's why I was asking for a transparant set of images.

Quote
This can be done in the Theme area in the admin centre. Click current theme >> edit index.template.php and take a look @ this part of the code in the "from Line 50" section, third box down.

* codes *

This is the code from the top of my forum: www.lfcgoals.com [nofollow]

This isn't what I mean... I want to just delete the whole top of it, not replacing it by google ads for example. No logo, no forum text... just nothing.

I hope you can help me :)

Offline peterstannard

  • Full Member
  • ***
  • Posts: 536
Re: [Theme] SMFone
« Reply #559 on: January 05, 2006, 08:09:14 AM »
Quote
I had already done that, but then there are still some images with grey in it... that's why I was asking for a transparant set of images.

The PSD's are in the original post.