• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 08:01:33 PM

News:

Follow SMF on Twitter.


SMF 1.0.8 Released

Started by Thantos, August 19, 2006, 06:19:38 PM

Previous topic - Next topic

Thantos

August 19, 2006, 06:19:38 PM Last Edit: August 21, 2006, 10:31:48 PM by Compuart
Simple Machines is happy to release a new update to Simple Machines 1.0.  This update will fix a vulnerability that was recently discovered in PHP (malfunctioning zend_hash_del_key_or_index() function). Also included are a small number of bug fixes found since 1.0.7. The vulnerability exists in PHP versions below 4.4.3 and 5.1.4.

We encourage everyone to upgrade their forum to 1.0.8 and all server administrators to upgrade their PHP to at least 4.4.3 or 5.1.4.

As this is a critical release, you can easily upgrade by one of the following ways:

  • Use the package manager in your administration center - one click, and you're done.
  • Download the update archive file, and upload all of the files from it.
  • Download the modification file attached to this message, and manually modify the files according to it.

SMF 1.1 Users
This security update is included in the public release of SMF 1.1 RC3.  Please see SMF 1.1 Release Candidate 3 is available! for further details.

Mods
We believe this update may cause some mods to stop working.  As always please use caution when using any mods.

Harzem

There are 4 pages of comments in RC3 release announcement, but not a single one here :) Don't worry development team, we are also proud of you for releasing 1.0.8 :) (Although I don't use 1.0 series.)

DomDom Skye

Hi!

I try to install the package and I receive this message:
Install Actions for archive smf_1-0-8_package.tar.gz:
The package you are trying to download or install is either corrupt or not compatible with this version of SMF. 

do you have install it without problem?

Regards, DOm

Remaker

Remaker - My blog - Actualitate.net

thisforumrocks

Whats new in version 1.0.8 compared to version 1.1rc2?
I love this forum software so much!

N3lson

Quote from: djavet on August 22, 2006, 02:46:33 AM
Hi!

I try to install the package and I receive this message:
Install Actions for archive smf_1-0-8_package.tar.gz:
The package you are trying to download or install is either corrupt or not compatible with this version of SMF. 

do you have install it without problem?

Regards, DOm

Give this error to you because this is not a package !
The SMF 1.0.8 is the main files of a newest version (update)
I´m Portuguese Yeah

ante

how to install this new update > i did not get it as always !
always i was seeing an update and simply click on it ,, but this how i can install it .

Puc conDoin

Quote from: thisforumrocks on August 22, 2006, 02:56:32 AM
Whats new in version 1.0.8 compared to version 1.1rc2?

1.0.8 is not to be compared with 1.1 RC2, because 1.0.8 is the latest stable and final version of SMF. 1.1 is a newer SMF version that is still in development, but expected to be released as final soon.

Jorin

Great news to see the two (!) new versions! Thanks to the team!  :)

ante

thank you . the update from .7 to .8 take 7 seconds !!!!!!!!!!!!
easy and very flexible  .

b0x

Thanks guys! Fantastic job! I just updated my forum and the update was painless. :D

Stuart

Thanks, I just updated my forum without any problems. All my mods still work too  :D

klumy


Compuart

Quote from: HarzeM on August 22, 2006, 02:25:13 AM
There are 4 pages of comments in RC3 release announcement, but not a single one here :) Don't worry development team, we are also proud of you for releasing 1.0.8 :) (Although I don't use 1.0 series.)
Heh, I think we've never released three versions (1.0.8, 1.1 RC2-2, and 1.1 RC3) as well as a Charter Member update package at the same time before. So it's kinda hard for users too to spread their attention. Anyways, I'm glad they respond to the 1.1 RC3 topic more. After all, that's sort of our flagship ;)
Hendrik Jan Visser
Former Lead Developer & Co-founder www.simplemachines.org
Personal Signature:
Realitynet.nl -> ExpeditieRobinson.net / PekingExpress.org / WieIsDeMol.Com

luxsat

Same problem over here is there a solution 

QuoteThe package you are trying to download or install is either corrupt or not compatible with this version of SMF.
Groetjes van Jef 

Compuart

Quote from: luxsat on August 22, 2006, 02:37:32 PM
Same problem over here is there a solution 

QuoteThe package you are trying to download or install is either corrupt or not compatible with this version of SMF.
Try downloading the package from the first message and uploading it to the Packages directory of your SMF installation. Also it might sometimes help to create a sub directory /Packages/temp/ and chmod that to 777.
Hendrik Jan Visser
Former Lead Developer & Co-founder www.simplemachines.org
Personal Signature:
Realitynet.nl -> ExpeditieRobinson.net / PekingExpress.org / WieIsDeMol.Com

luxsat

Thanks , problem solved downloaded package and installed from directory
;)
Groetjes van Jef 

doug@atd

August 22, 2006, 10:32:21 PM #17 Last Edit: August 23, 2006, 01:36:38 AM by doug@atd
I get the same corrupt error message when trying to use the simple upgrade link in the Package Manager.  I have 1.0.7.  Tried uninstalling the packages in reverse order (only 2 mods, User Email System and Ad Management), but the Ad Management uninstall fails on Modifications.english.php and index.template.php.  Restored my backup forum files and tried downloading the 1.0.8 update and then uploading it in Package Manager, but got the corrupt file error.

I did some minor cosmetics tweaking of the default theme files, mainly index.template.php to add include files at header and footer for my own ads (ad management not what I'd hoped for) and additional row under forum title, changed the default button set, etc.  Does the 1.0.8 update only work with an untouched default theme?

Thanks!

***************

Nevermind - I figured it out.  I'll spell it out, in case it helps others...

I followed the SMF Upgrade instructions in the Online Manual and sucessfully upgraded to 1.0.8. I backed-up the folder, then downloaded the upgrade zip, copied the extracted files to my forum folder, ran upgrade.php from the browser, deleted upgrade.php.  no errors, no worries!  This worked out well with the mods issue, afterall.  It actually left the mods in the Package Manager like they were uninstalled, so I was able to delete them and add the mods I wanted.

Fyi: The old User Email System mod gives an error if you try to reinstall it after the upgrade.  You need to delete it and download and install the newly updated mod, for 1.0.8.

Other than that, I just had to readd the code to the few pages where I tweaked the look-and-feel, my modified stylesheet, and replaced the button set I chose.  I hope the upgrade later-on to the gold version of 1.1 goes that well!

KyleKai

I'm new at this, and not having much success upgrading.  When I go to the Package Manager, I am told
"A security issue has been identified in SMF 1.0.6. You can install this patch (click here to install) to easily update yourself to the latest version."
So I click, and the next page states:
"Installing this package will perform the following actions:"

But I always get this error:

      Type                     Action                             Description
1.   Execute Modification   ./Sources/QueryString.php Failure

How can I solve this Failure error?  Any help is appreciated.
Thanks.

coolguy949

Anyone else having buggy login/logout after upgrading to 1.0.8?

Advertisement: