Advertisement:

Author Topic: Attachments on SafeMode PHP  (Read 6353 times)

Offline Hurky

  • Semi-Newbie
  • *
  • Posts: 11
  • Gender: Male
Attachments on SafeMode PHP
« on: March 15, 2004, 10:13:11 PM »
I am running the forum at a free webspace that have safemode enabled, I remember from yabse editing some files to omitt chmod, I have added comments to this in post.php and profile.php...

// Attempt to chmod it.
// @chmod($destName, 0644);

... but no success, the avatars still get not uploaded and the attachments apears in text form saying things like: ?PNG 

Regards.

Offline Villesa

  • Full Member
  • ***
  • Posts: 494
  • Gender: Male
  • Yes it's me indeed
    • Finnish erotic forum -- no porn --
Re: Attachments on SafeMode PHP
« Reply #1 on: March 15, 2004, 10:39:16 PM »
I too have SAFE_MODE enabled by my host, attachment seams to work just fine without any modification. And avatars also, no problems
You'll get the idea

I'm all ok.

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: Attachments on SafeMode PHP
« Reply #2 on: March 16, 2004, 12:40:28 AM »
Lycos even does attachments perfectly.  If your host is so crappy that they can't have things work properly, I hope you're not paying them.

-[Unknown]

Offline Hurky

  • Semi-Newbie
  • *
  • Posts: 11
  • Gender: Male
Re: Attachments on SafeMode PHP
« Reply #3 on: March 16, 2004, 01:19:57 PM »
No, I don't want to pay for this bad server :) it's a free one..  But with YabSE I could put attachments adding comments to the chmod things, but in SMF this seems not to work anymore :(

Offline Grudge

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,742
  • Gender: Male
  • Unofficial nuisance
Re: Attachments on SafeMode PHP
« Reply #4 on: March 16, 2004, 01:22:45 PM »
You have chmod'd the attachments directory, yes? Nothing gets put in there at all? Maybe they have disabled a function used by SMF?
I'm only a half geek really...

Offline Hurky

  • Semi-Newbie
  • *
  • Posts: 11
  • Gender: Male
Re: Attachments on SafeMode PHP
« Reply #5 on: March 16, 2004, 01:39:48 PM »
Hi Grudge, thx for respond; I've chmod attachments folder to 777, in there are some files ( 8_Prueba_png0ac41bef4f3c7dbd0256dc99b711f999 ) originaly named Prueba.png and fullo functional (downloaded it and renamed and they are ok) .. The problem is something with the permissions, SMF is trying to change something and the host is denying...

Offline Grudge

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,742
  • Gender: Male
  • Unofficial nuisance
Re: Attachments on SafeMode PHP
« Reply #6 on: March 16, 2004, 02:33:16 PM »
Is this the same for both images and text type attachments? I mean do non-image attachments work?
I'm only a half geek really...

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: Attachments on SafeMode PHP
« Reply #7 on: March 16, 2004, 02:55:46 PM »
If it uploaded it fine, that's not the problem.  Can you give a link?

-[Unknown]

Offline Hurky

  • Semi-Newbie
  • *
  • Posts: 11
  • Gender: Male
Re: Attachments on SafeMode PHP
« Reply #8 on: March 16, 2004, 05:22:59 PM »
Here you get the link. [nofollow]

Text files will be shown but without formating..

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: Attachments on SafeMode PHP
« Reply #9 on: March 16, 2004, 07:30:49 PM »
Everything is having ads added to the end, which is why it's not working properly.

-[Unknown]

Offline Hurky

  • Semi-Newbie
  • *
  • Posts: 11
  • Gender: Male
Re: Attachments on SafeMode PHP
« Reply #10 on: March 16, 2004, 09:34:11 PM »
It works! .. I've disabled encrypting attachments and now the files apears correctly :D

Thanks !

Offline Darnok

  • Newbie
  • *
  • Posts: 5
Re: Attachments on SafeMode PHP
« Reply #11 on: October 21, 2004, 08:34:35 AM »
I have the same problem. I can't upload avatars on a server wirth Safemode=on.
But disabling the decryption didn't help. What else can I do?

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: Attachments on SafeMode PHP
« Reply #12 on: October 21, 2004, 09:41:44 PM »
I have the same problem. I can't upload avatars on a server wirth Safemode=on.
But disabling the decryption didn't help. What else can I do?

What error message do you get?  Can we have a test account with permissions to post attachments?  A phpinfo? (What is phpinfo.php?)

Please start a new topic for a new support request.

-[Unknown]