• Welcome to Simple Machines Community Forum. Please login or sign up.
September 21, 2021, 09:41:17 PM

News:

Follow SMF on Twitter.


SimplePortal

Started by SimplePortal Team, March 10, 2008, 11:16:07 PM

Previous topic - Next topic

Sakacoco

Yeah ! It works ! Thx !

But now, another question how can i put a module in the other side ?

Thanks for your usefull help !

[SiNaN]

Quote from: Kender on March 22, 2008, 06:56:09 AM
I mean, if a visitor cannot access an action or feature, than do not let them click a link to go there, instead tell them to login to view

Hımmm, okay. I think I've understand.

Quote from: Sakacoco on March 22, 2008, 07:09:02 AM
Yeah ! It works ! Thx !

But now, another question how can i put a module in the other side ?

Thanks for your usefull help !

What do you want to add for example?
Former SMF Core Developer | My Mods | SimplePortal

Sakacoco

For exemple i would like to switch the search module and stats in the other side, is it possible ?

[SiNaN]

Yes of course. Just you should edit the SPortal.template.php file.

This is the start of the block:

if($modSettings['showboardstats'])
{
echo '
<!-- Board Stats Block -->
<div class="tborder">
..................


And this is the end:

...................
<td><img src="' . $settings['images_url'] . '/dot.gif" alt="Dot" /></td>
<td>', $txt['sp-statboard'], '</td>
<td>:</td>
<td>', $totals['boards'], '</td>
</tr>
</table>
</td>
</tr>
</table>
</div>

<br />';
}


Take the block, and paste it where do you like be displayed. :)
Former SMF Core Developer | My Mods | SimplePortal

Sakacoco

Marvelous ! It's super ! Thx a lot !

†д∩αỷ ĎάПα

I can't install it, I see a message saying "modification Error". What do I have to modify to install it?

Please tell me the steps.

[SiNaN]

Quote from: Sakacoco on March 22, 2008, 01:48:15 PM
Marvelous ! It's super ! Thx a lot !

Not at all. :)

Quote from: ssdt on March 22, 2008, 07:30:15 PM
I can't install it, I see a message saying "modification Error". What do I have to modify to install it?

Please tell me the steps.

Here is how to install manually: http://www.simplemachines.org/community/index.php?topic=227599.msg1476528#msg1476528
Former SMF Core Developer | My Mods | SimplePortal

Apllicmz

March 23, 2008, 08:46:11 AM #107 Last Edit: March 23, 2008, 09:40:05 AM by joomlamz
Thank you
i translate for potuguese

download  attach





Mr Blah Man

March 25, 2008, 04:01:04 AM #108 Last Edit: March 25, 2008, 04:19:47 PM by Mr Blah Man
Very Nice, but I'd like to ask... My Link tree is:

The Shadowed Legion Forums  »  Forum  »  Main Category  »  Rules & Announcements
^ Links to Portal ^                 ^Links^ 
                                           to Forum

How do I get rid of the The Shadowed Legion Forums Part?

denzil69

i used the manual install parser, getting more error messages than an install via the admin panel.

QuoteWarning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: Entity: line 50: parser error : Input is not proper UTF-8, indicate encoding ! Bytes: 0xFD 0x20 0x65 0x74 in /home/sleepy1/public_html/PackageParser/index.php on line 472

Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: <search position="before"><![CDATA[$txt['who_enabled'] = 'Kimler Online\'� et in /home/sleepy1/public_html/PackageParser/index.php on line 472

Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: ^ in /home/sleepy1/public_html/PackageParser/index.php on line 472

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /home/sleepy1/public_html/PackageParser/index.php:472 Stack trace: #0 /home/sleepy1/public_html/PackageParser/index.php(472): SimpleXMLElement->__construct('<?xml version="...') #1 /home/sleepy1/public_html/PackageParser/index.php(441): parseModificationXML('/home/sleepy1/b...', Object(SimpleXMLElement), 'all') #2 /home/sleepy1/public_html/PackageParser/index.php(96): parsePackageInfoXML('/home/sleepy1/b...', 'install', 'all') #3 /home/sleepy1/public_html/PackageParser/index.php(784): parseArchive('/tmp/phpu1qPl6', 'install', 'all') #4 {main} thrown in /home/sleepy1/public_html/PackageParser/index.php on line 472

im running 1.1.4
using default set up.

any ideas please?

[SiNaN]

Quote from: Mr Blah Man on March 25, 2008, 04:01:04 AM
Very Nice, but I'd like to ask... My Link tree is:

The Shadowed Legion Forums  »  Forum  »  Main Category  »  Rules & Announcements
^ Links to Portal ^                      ^Links^ 
                                                    to Forum

How do I get rid of the The Shadowed Legion Forums Part?

I'll give the codes.

Quote from: denzil69 on March 25, 2008, 06:49:25 AM
i used the manual install parser, getting more error messages than an install via the admin panel.
im running 1.1.4
using default set up.

any ideas please?

Do not use the original package with the mod parser. It includes non-utf8 Turkish characters. Use the package linked below with the mod parser:

http://www.simplemachines.org/community/index.php?action=dlattach;topic=227599.0;attach=52053
Former SMF Core Developer | My Mods | SimplePortal

Mr Blah Man

Quote from: [SiNaN] on March 25, 2008, 09:18:49 AM
Quote from: Mr Blah Man on March 25, 2008, 04:01:04 AM
Very Nice, but I'd like to ask... My Link tree is:

The Shadowed Legion Forums  »  Forum  »  Main Category  »  Rules & Announcements
^ Links to Portal ^                      ^Links^ 
                                                    to Forum

How do I get rid of the The Shadowed Legion Forums Part?

I'll give the codes.

What are they, or where should I look? :O

TosTos

It is very nice mod. Are you going to update it to work with smf2.0?

[SiNaN]

Quote from: Mr Blah Man on March 26, 2008, 02:48:51 AM
What are they, or where should I look? :O

I don't have the file with me now. It's in the Load.php. But I'll write them, when I'll have time.

Quote from: TosTos on March 26, 2008, 05:43:35 AM
It is very nice mod. Are you going to update it to work with smf2.0?


I even didn't install the 2.0 Beta 3. Now having lack of time. Keep it secret; that's in my plan. :P
Former SMF Core Developer | My Mods | SimplePortal

cumcatano

Hi!

Nice portal man!

I need to place a new block on the right side to show Google AdSense block.

Can you help me, please?


Thks!

spoontosser

March 26, 2008, 03:58:40 PM #115 Last Edit: March 26, 2008, 04:02:37 PM by spoontosser
Great Mod and I got it installed and working fine on my SMF forum at http://steelheadnotebook.net/forum/index.php, however I am getting the following  errors on the forum error log.

Quote
Apply Filter: Only show the errors with the same message
8: Undefined index: showtoppoll
File: /home/bdm721/public_html/forum/Themes/default/SPortal.template.php (main sub template - eval?)
Line: 428

Quote
Apply Filter: Only show the errors with the same message
8: Undefined index: showboardnews
File: /home/bdm721/public_html/forum/Themes/default/SPortal.template.php (main sub template - eval?)
Line: 291

Here is the code on those lines:
Line 291    if($modSettings['showboardnews'])
Line 428    if($modSettings['showtoppoll'])

Any ideas what could be causing these errors?

I am using version 1.1.4 and have the following mods installed:

QuoteMod Name     Version     
1.    Users Online Today Mod    1.4.0    [ Uninstall ]
2.    AutoSig    1.2    [ Uninstall ]
3.    Board Viewers Mod    1.1    [ Uninstall ]
4.    MessagePreviewOnHover    1.4    [ Uninstall ]
5.    SMF 1.1.1 Update Package    1.1.1    [ Uninstall ]
6.    URL Popup    1.0    [ Uninstall ]
7.    View Single Post    1.1    [ Uninstall ]
8.    MySpace Field    2.4    [ Uninstall ]
9.    Automatically Remove Inbox Label Mod    1.0    [ Uninstall ]
10.    Profile User Action    1.0    [ Uninstall ]
11.    Who Voted What?    1.1.1    [ Uninstall ]
12.    Line Numbers Mod    1.01    [ Uninstall ]
13.    SMF 1.1.2 Update Package    1.1.2    [ Uninstall ]
14.    Wrap Text Around Image    1.0    [ Uninstall ]
15.    FontandSizeDropdown1.1    1.1    [ Uninstall ]
16.    Streaming 3    4.2.2b    [ Uninstall ]
17.    SMF Gallery Lite    1.8    [ Uninstall ]
18.    Ad Managment    2.3    [ Uninstall ]
19.    Signature Dropdown Choices    1.0    [ Uninstall ]
20.    RSS Feed Icon    1.1    [ Uninstall ]
21.    SMF 1.0.11 / 1.1.3 Update    1.1    [ Uninstall ]
22.    Buy Me A Beer    1.1    [ Uninstall ]
23.    SMF 1.0.12 / 1.1.4 / 2.0 b1.1 Update    1.0    [ Uninstall ]
24.    Auto Embed Video Clips    1.2    [ Uninstall ]
25.    Spiders Don't Increase Topic Views    1.1    [ Uninstall ]
26.    Sorted Package Manager Listing    0.1    [ Uninstall ]
27.    Electric Guitar Avatars    1.0    [ Uninstall ]
28.    Show all edits in messages    1.0    [ Uninstall ]
29.    Favicon    1.0    [ Uninstall ]
30.    FlashChat Integration    1.0    [ Uninstall ]
31.    Internal Links Use Same Window    1.1    [ Uninstall ]
32.    Ellow yellow christmas edition smiley set    1.1    [ Uninstall ]
33.    Advanced Recent-Posts    1.1    [ Uninstall ]
34.    Admin member list registration date    1.0    [ Uninstall ]
35.    delete inactive users    1.0.3    [ Uninstall ]
36.    Add Sitepreviews    1.31    [ Uninstall ]
37.    Top 10 Posters Today And This Week Stats    1.1

denzil69

March 26, 2008, 06:27:13 PM #116 Last Edit: March 26, 2008, 06:48:36 PM by denzil69
okays... we have it installed, running, but generating many errors in the log.

(this may be due to not setting parameters in the various boxes on the settings page?)
are there instructions that i have missed as to what to put in them?

EDIT: some errors,if i sort them one at a time it will be much clearer.

8: Undefined index: aspecificannounce
File: .....\Themes\default\SPortal.template.php (eval?)
Line: 277

"announcement is unchecked"
(line 277:) if($modSettings['aspecificannounce'])

TosTos

Quote from: [SiNaN] on March 26, 2008, 09:47:58 AM
Quote from: Mr Blah Man on March 26, 2008, 02:48:51 AM
What are they, or where should I look? :O

I don't have the file with me now. It's in the Load.php. But I'll write them, when I'll have time.

Quote from: TosTos on March 26, 2008, 05:43:35 AM
It is very nice mod. Are you going to update it to work with smf2.0?


I even didn't install the 2.0 Beta 3. Now having lack of time. Keep it secret; that's in my plan. :P
Very Good. I think it might be a strong competitor for tp.

spoontosser

After making my earlier post I went back and checked the Show Board News Block and the Show Top Poll Block, saved the settings and viewed the new settings in the portal. I then went back and unchecked them and now the error massages no longer seem to show up. Not sure why, but since they are no longer showing I guess I don't have anything to worry about.

[SiNaN]

To the users, who got undefined index erros in the error log; it is because the database query included is not ran. The solution is, just set all the settings in the Portal Settings and then Save them. Then, the database query will be ran by the SMF automatically. After that, you can turn off the setting you want.

TosTos, for now, it can't. This is so so simple for TP. And I'm not good enough to race with Mr. Bloc. :)
Former SMF Core Developer | My Mods | SimplePortal

Advertisement: