• Welcome to Simple Machines Community Forum. Please login or sign up.
September 20, 2021, 05:04:55 AM

News:

Join the Facebook Fan Page.


Attachments causing a problem with upgrade.

Started by JMV290, March 18, 2008, 02:59:01 PM

Previous topic - Next topic

JMV290

I'm not sure if the problem lies with attachments themselves or the fact that I used a fresh install of SMF with the database from my forum. 

Basically I downloaded my database from the actual forum and used it on a test installation on my hard drive(other than broken images, it works fine).  Today when I ran the update I got an error and when I went to index.php I got some error about attachments. Reinstalled SMF, tried again, same problem.

I deleted everything, reinstalled 1.1.4, switched databases again, and deleted all attachments and uploaded avatars.  I ran the update again and everything worked.


Was the problem a global issue with attachments or was it related to the fact that the attachments existed in the database, but couldn't be found on the forum itself?   I just thought I'd point this out just in case it is the former.

JayBachatero

Well it could have been that you had outdated files left.  With out the actual error it would he hard to tell really.  Is everything working fine now?   Was the error that you were getting a database error?
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

JMV290

Quote from: JayBachatero on March 18, 2008, 11:51:43 PM
Well it could have been that you had outdated files left.  With out the actual error it would he hard to tell really.  Is everything working fine now?   Was the error that you were getting a database error?
I really wish I had paid more attention.  I think it was something like "error in a.attachments" along those lines.

Yes, I believe it was a database error.  It showed up when I tried to view index.php

Once again, I'm sorry for not paying closer attention.  I can try to replicate the error tomorrow.

JayBachatero

Yea that attachment error is most likely due to a) old Source files that weren't replaced b) upgrade error.  But I suspect that it was a.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

JMV290

March 20, 2008, 10:37:11 PM #4 Last Edit: March 20, 2008, 10:44:23 PM by JMV290
I forgot to do it yesterday, but I'm doing it now.   I'll edit this post with some screenshots in 10-20 minutes.

Alright:

Forum Working on 1.1.4:



The previously mentioned error:

I get the error as soon as I swap the files for the 2.0 upgrade and it still stays there after I run the upgrade.

And this error happens when trying to run the upgrade:



If I manually clear out the attachments before upgrading everything works fine though.

JayBachatero

Make sure that you got the right upgrade-x-x.sql files.  Seems like the upgrade is failing.  That column should be there.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

JMV290

Quote from: JayBachatero on March 20, 2008, 11:47:47 PM
Make sure that you got the right upgrade-x-x.sql files.  Seems like the upgrade is failing.  That column should be there.
I am.  It was the large upgrade to the beta.   It works fine once I delete the things from the database.

metallica48423

that particular error (a.attachmentType) tells me that some files did not get overwritten properly.

It seems to me, to be the opposite.  As if the upgrade was successful, but the files are now referencing old db columns.

2.0 has no attachmentType.
it has attachment_type instead, i believe.

Ensure that all of your theme and source files were properly overwritten.
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

Advertisement: