• Welcome to Simple Machines Community Forum. Please login or sign up.

Message for your guests

Started by babjusi, September 29, 2008, 08:33:00 PM

Previous topic - Next topic

Sudhakar Arjunan

Hi Babjusi,

Every time i get a error recored on my smf 2.0.4.

Apply Filter: Only show the errors of this type  Type of error: Undefined
Apply Filter: Only show the error messages of this URL http://discuss.itacumens.com/index.php?action=admin;area=logs;sesc
Apply Filter: Only show the errors with the same message
8: Undefined variable: scripturl
Apply Filter: Only show the errors from this file
File: /home/itacumen/public_html/discuss/Themes/default/languages/Modifications.english.php
Line: 414

- Line 414 in my forum language/ Modifications.english.php page ,

Please consider <a href="' . $scripturl . '?action=register">registering</a> to gain full access!
Working on New Mods & Themes for SMF... Will update soon... My Blog page
My Smf forum : Discuss ITAcumens :: My SMF Forum

thenepalgallery

well i read this post from start to end but i didn;t find the solution to my problem

yes this customize is shown in the by default theme of SMF 1.1.6 , but since i am using the theme "OUTLINE", it is not shown

can u tell me which file to edit so as to get this feature shown for guest, for my using forum

http://www.thenepalgallery.com/forum/index.php

i am quiet new to this, plz help me out
a site of nepal, its places, religion, fetes, festivals

babjusi

Quote from: thenepalgallery on November 04, 2008, 04:16:12 AM
well i read this post from start to end but i didn;t find the solution to my problem

yes this customize is shown in the by default theme of SMF 1.1.6 , but since i am using the theme "OUTLINE", it is not shown

can u tell me which file to edit so as to get this feature shown for guest, for my using forum

http://www.thenepalgallery.com/forum/index.php

i am quiet new to this, plz help me out

Can you attach here the index.template.php file of your custom theme and I will make the edits for you :)

Pspuser007

Hello my friend.

Thank you for the mod!!
I have used it but now i cannot cause i changed theme and i cannot get this to work.
At my index.template.php file i cannot find <body>'; i find only <body>.
So i replaced the <body> with this :
<body>';

//Hopefully this message will encourage the guests to register
if ($context['user']['is_guest'] && !empty($modSettings['enable_mfg_mod']))
        echo '
               <div class="windowbg2" style="margin:0 auto;text-align:center">',!empty($modSettings['mf_guests']) ? $modSettings['mf_guests'] : $txt['default_message'],'</div>';



And i am getting this error:


Template Parse Error!
There was a problem loading the /Themes/DSv3/index.template.php template or language file. Please check the syntax and try again - remember, single quotes (') often have to be escaped with a slash (\). To see more specific error information from PHP, try accessing the file directly.

You may want to try to refresh this page or use the default theme.

Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in .../Themes/DSv3/index.template.php on line 225

216:    vbphrase[\'ncode_imageresizer_warning_small\'] = \'', $txt['ncode_imageresizer_warning_small'], '\';
217:    vbphrase[\'ncode_imageresizer_warning_filesize\'] = \'', $txt['ncode_imageresizer_warning_filesize'], '\';
218:    vbphrase[\'ncode_imageresizer_warning_no_filesize\'] = \'', $txt['ncode_imageresizer_warning_no_filesize'], '\';
219:    vbphrase[\'ncode_imageresizer_warning_fullsize\'] = \'', $txt['ncode_imageresizer_warning_fullsize'], '\';
220:    // ]]></script>
221: </head>
222: <body>
223:          
224:    //Hopefully this message will encourage the guests to register

225:    if ($context['user']['is_guest'] && !empty($modSettings['enable_mfg_mod']))

226:            echo '
227:                   <div class="windowbg2" style="margin:0 auto;text-align:center">',!empty($modSettings['mf_guests']) ? $modSettings['mf_guests'] : $txt['default_message'],'</div>';
228:    <div id="wrapper">
229:       <div id="header">

What can i do???

I have attached my index template too!!

Thank you for your time!!

babjusi

November 05, 2008, 10:36:11 AM #44 Last Edit: November 06, 2008, 10:55:45 AM by babjusi
Can you try the attached file and let me know?

thenepalgallery

a site of nepal, its places, religion, fetes, festivals

babjusi

November 05, 2008, 10:54:48 AM #46 Last Edit: November 06, 2008, 10:55:33 AM by babjusi
Quote from: thenepalgallery on November 05, 2008, 10:42:27 AM
here is my file



Here you go. And let me know if it will work.

Pspuser007

Thank you for your time my friend.

Well with this index file there was a conflict between my LOGO and the Home,Help,etc. buttons.
The one was on top of the other...
:(

babjusi

Quote from: Pspuser007 on November 05, 2008, 12:47:38 PM
Thank you for your time my friend.

Well with this index file there was a conflict between my LOGO and the Home,Help,etc. buttons.
The one was on top of the other...
:(

Can you link me to your custom theme please?

Pspuser007


thenepalgallery

Quote from: babjusi on November 05, 2008, 10:54:48 AM
Quote from: thenepalgallery on November 05, 2008, 10:42:27 AM
here is my file



Here you go. And let me know if it will work.


thank you for ur help man, but

but

it works for guests

but when a users login, everthing is changed .. logos, my add @ buttom

total forum size ( initially it is center with 90% of screen is shown, now it is 100%)

a site of nepal, its places, religion, fetes, festivals

babjusi

@thenepalgallery, I don''t know why you get that as my mod doesn''t affect the buttons or the width of the forum. If you want me to have a look, pm this week-end the ftp info and I will take a closer look.

The same thing goes for you as well Pspuser007 :)

Pspuser007

Buddy do you have time to check it??

zijO

how to activate mod in smf 2.0, there is no basic features?

zijO

Oh , ok, it is in modifications

jvo

Does this run on smf 1.1.7 without problems?

fiveflat

Quote from: zijO on November 14, 2008, 05:08:44 PM
how to activate mod in smf 2.0, there is no basic features?
yeah, I installed this on 2.0b4 and I can't find where it turn it on now...

victornj

jvo,

I just installed it on 1.1.7 and it's working fine (you can see it here: http://argville.com/forum. You can't miss the big, bad, bright yellow box on top).

Because I'm not using the default theme I had to manually apply the chances to index.template.php in my custom theme. But other than that, piece of cake.

effex

Great mod, very easy to place where ever you want and modify, thanks!

edi67

will be very useful have options for select the member groups to show the message ;) thx for mod
CrazyZone - My SMF Forum


From the difficult the hardening of the man you can see

Advertisement: