Advertisement:

Author Topic: Highslide Image Viewer  (Read 272063 times)

Offline henry74

  • Semi-Newbie
  • *
  • Posts: 30
Re: Highslide Image Viewer
« Reply #420 on: November 10, 2009, 05:39:12 PM »
I had this mod installed in previous versions, i have desintalled and installed 1.6 and all was fine, but seems not working...  in RC2

Offline Kmarion

  • Newbie
  • *
  • Posts: 6
Re: Highslide Image Viewer
« Reply #421 on: November 11, 2009, 05:13:59 AM »
Just to add to the confusion, some images are working whilst others are not???
Same going on here. It's very odd. Actually the same image is working, but only in certain threads.

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #422 on: November 11, 2009, 05:24:08 AM »
Just to add to the confusion, some images are working whilst others are not???
Same going on here. It's very odd. Actually the same image is working, but only in certain threads.

Links to the examples?

Offline clothahump

  • Jr. Member
  • **
  • Posts: 393
  • Gender: Male
Re: Highslide Image Viewer
« Reply #423 on: November 11, 2009, 09:50:48 AM »
http://www.tropicalfishforums.co.uk/index.php?topic=11990.0

First image of the fish works, snail and marigolds fail.

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #424 on: November 11, 2009, 11:00:35 AM »
http://www.tropicalfishforums.co.uk/index.php?topic=11990.0

First image of the fish works, snail and marigolds fail.

You are use SMG.
SMG have own highslide script which settings interfere with my mod.

Offline clothahump

  • Jr. Member
  • **
  • Posts: 393
  • Gender: Male
Re: Highslide Image Viewer
« Reply #425 on: November 11, 2009, 11:05:11 AM »
Ah, so can I still use yours in the Forums?

Offline Eddy Matthews

  • Jr. Member
  • **
  • Posts: 121
Re: Highslide Image Viewer
« Reply #426 on: November 15, 2009, 01:26:01 PM »
I just had to say that this mod works superbly, the best integration of highslide I've seen yet!

Many thanks
Eddy

Offline toma

  • Semi-Newbie
  • *
  • Posts: 26
Re: Highslide Image Viewer
« Reply #427 on: November 16, 2009, 02:21:48 PM »
HI,

I tried to get Highslide image viewer to work with my SMF forum which is run using the Joomla-SMF Bridge and what happens is that the images are opened in a new window. without any nice highslide effects.
If I run the forum (1.1.10) without Joomla integration it works nicely.
Probably some lightbox plug-ins that interfere, any idea on how to debug it?

Attached Finnish translations to a very nicely done mod.

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #428 on: November 16, 2009, 02:54:41 PM »
HI,

I tried to get Highslide image viewer to work with my SMF forum which is run using the Joomla-SMF Bridge and what happens is that the images are opened in a new window. without any nice highslide effects.
If I run the forum (1.1.10) without Joomla integration it works nicely.
Probably some lightbox plug-ins that interfere, any idea on how to debug it?

Can I see examples?

Offline toma

  • Semi-Newbie
  • *
  • Posts: 26
Re: Highslide Image Viewer
« Reply #429 on: November 16, 2009, 03:51:45 PM »
Yes of course, sorry that i didn't post them straight away.

Here are two links link to an sales ad on my site with pictures attached

The first one is through Joomla, which opens the image in a blank window:
http://www.ilmailu.org/index.php?option=com_smf&Itemid=26&topic=3207.0

And this one is without is to the same place without Joomla interfering, working nicely:
http://www.ilmailu.org/forum/index.php?topic=3207.msg17218#new

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #430 on: November 16, 2009, 04:31:11 PM »
Yes of course, sorry that i didn't post them straight away.

Here are two links link to an sales ad on my site with pictures attached

The first one is through Joomla, which opens the image in a blank window:
http://www.ilmailu.org/index.php?option=com_smf&Itemid=26&topic=3207.0

And this one is without is to the same place without Joomla interfering, working nicely:
http://www.ilmailu.org/forum/index.php?topic=3207.msg17218#new

You need to insert into your Joomla template this code

Code: [Select]
<script language="JavaScript" type="text/javascript" src="http://www.ilmailu.org/forum/Themes/default/Highslide/highslide.js"></script>
<script language="JavaScript" type="text/javascript" src="http://www.ilmailu.org/forum/Themes/default/Highslide/highslide.finnish.js"></script>
<script type="text/javascript">
    hs.graphicsDir = "http://www.ilmailu.org/forum/Themes/default/Highslide/";
    hs.outlineType = "rounded-white";
    hs.captionEval = "this.thumb.alt";
    hs.transitions = ["expand", "crossfade"];
    hs.numberOfImagesToPreload = 5;
    hs.dimmingOpacity = 0;
    hs.fadeInOut = false;
    hs.align = "center";
    hs.showCredits = false;
    hs.creditsText = "";
    hs.creditsHref = "";
    hs.creditsTitle = "";
    if (hs.addSlideshow) hs.addSlideshow({
        interval: 5000,
        repeat: false,
        useControls: true,
fixedControls: false,
        overlayOptions: {
        opacity: 1,
        position: "top right",
        hideOnMouseOut: false
}
    });
  </script>

Offline clothahump

  • Jr. Member
  • **
  • Posts: 393
  • Gender: Male
Re: Highslide Image Viewer
« Reply #431 on: November 16, 2009, 04:34:16 PM »
http://www.tropicalfishforums.co.uk/index.php?topic=11990.0

First image of the fish works, snail and marigolds fail.

Any way to get mine working properly Digger?

You are use SMG.
SMG have own highslide script which settings interfere with my mod.

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #432 on: November 16, 2009, 04:46:33 PM »
http://www.tropicalfishforums.co.uk/index.php?topic=11990.0

First image of the fish works, snail and marigolds fail.

Any way to get mine working properly Digger?

You are use SMG.
SMG have own highslide script which settings interfere with my mod.

Disable highslide in SMG or wait for Highslide Image Viewer 2.0

Offline clothahump

  • Jr. Member
  • **
  • Posts: 393
  • Gender: Male
Re: Highslide Image Viewer
« Reply #433 on: November 16, 2009, 04:54:48 PM »
Disabled and now the images linked from Gallery open in a new page. :(

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #434 on: November 16, 2009, 04:59:43 PM »
Disabled and now the images linked from Gallery open in a new page. :(
Yes, because you disable it.

Offline clothahump

  • Jr. Member
  • **
  • Posts: 393
  • Gender: Male
Re: Highslide Image Viewer
« Reply #435 on: November 16, 2009, 05:03:21 PM »
I will just have to wait for Highslide Image Viewer 2.0, thanks anyway.

Offline toma

  • Semi-Newbie
  • *
  • Posts: 26
Re: Highslide Image Viewer
« Reply #436 on: November 16, 2009, 05:48:43 PM »
Yes of course, sorry that i didn't post them straight away.

Here are two links link to an sales ad on my site with pictures attached

The first one is through Joomla, which opens the image in a blank window:
http://www.ilmailu.org/index.php?option=com_smf&Itemid=26&topic=3207.0

And this one is without is to the same place without Joomla interfering, working nicely:
http://www.ilmailu.org/forum/index.php?topic=3207.msg17218#new

You need to insert into your Joomla template this code

Code: [Select]
<script language="JavaScript" type="text/javascript" src="http://www.ilmailu.org/forum/Themes/default/Highslide/highslide.js"></script>
<script language="JavaScript" type="text/javascript" src="http://www.ilmailu.org/forum/Themes/default/Highslide/highslide.finnish.js"></script>
<script type="text/javascript">
    hs.graphicsDir = "http://www.ilmailu.org/forum/Themes/default/Highslide/";
    hs.outlineType = "rounded-white";
    hs.captionEval = "this.thumb.alt";
    hs.transitions = ["expand", "crossfade"];
    hs.numberOfImagesToPreload = 5;
    hs.dimmingOpacity = 0;
    hs.fadeInOut = false;
    hs.align = "center";
    hs.showCredits = false;
    hs.creditsText = "";
    hs.creditsHref = "";
    hs.creditsTitle = "";
    if (hs.addSlideshow) hs.addSlideshow({
        interval: 5000,
        repeat: false,
        useControls: true,
fixedControls: false,
        overlayOptions: {
        opacity: 1,
        position: "top right",
        hideOnMouseOut: false
}
    });
  </script>

Many thanks for this  Digger it works like a charm!

Sorry to bother you again but, you mentioned somewhere that it should show pictures that have a thumbnail also in the middle of the text. I'm using the Inline Attachments by mouser and currently those are not shown with Highslide Image viewer e.g. these:

http://www.ilmailu.org/index.php?option=com_smf&Itemid=26&topic=2477.0

Can you recommend some other inline image mod that would work or is there a way to get this to work?

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #437 on: November 16, 2009, 06:49:38 PM »
Many thanks for this  Digger it works like a charm!

Sorry to bother you again but, you mentioned somewhere that it should show pictures that have a thumbnail also in the middle of the text. I'm using the Inline Attachments by mouser and currently those are not shown with Highslide Image viewer e.g. these:

http://www.ilmailu.org/index.php?option=com_smf&Itemid=26&topic=2477.0

Can you recommend some other inline image mod that would work or is there a way to get this to work?

Highslide Image Viewer works with Attachments Positioning (Attachments Positioning 1.2 tested) and Attachments In Message (Attachments In Message 1.3 tested) mods. But you need to install inline image mod firstly and then install Highslide Image Viewer mod.

Offline realnc

  • Semi-Newbie
  • *
  • Posts: 55
Re: Highslide Image Viewer
« Reply #438 on: November 28, 2009, 06:48:58 PM »
I just installed this on RC2 (it installed perfectly without any errors) but it doesn't seem to work. Also, I get a LOT of these errors in the logs:

Code: [Select]
/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=1;time=1259451970;xml
2: preg_match_all() [<a href='function.preg-match-all'>function.preg-match-all</a>]: Unknown modifier 'r'
File: /forum/Sources/Subs.php
Line: 4279

I have SimplePortal 2.3.1 installed.

Offline JayKae

  • Semi-Newbie
  • *
  • Posts: 19
Re: Highslide Image Viewer
« Reply #439 on: December 04, 2009, 01:56:21 AM »
Ok, it installed fine but I cannot find where to set it up in SMF 2.0 RC2 ?