Wondering if this will always be free?  See why free is better.

Main Menu Shoutbox

Started by Nibogo, October 19, 2008, 11:41:06 AM

Previous topic - Next topic


i just tested 2 links to a facebook post and my gmail inbox and they work fine for me.

are you seeing any errors ANYWHERE ?
The configuration of my Linux VPS (SMF 2.0 with 160+ mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here


Having problems with it not sending messages as well. Tried going through Shoutbox.php and replacing preg_replace with preg_replace_callback. Didn't work. Disabled compression. Didn't work.

Funnily enough, I got the old version for 2.0.8/9 to work as long as you didn't change the text color from the theme default text color.


Just installed, it shows just fine, set all the permissions for members and staff.

But will not send message. Yet if you open the Open Popup and shout it works that way, but not on the forum board itself..



Quote from: nickdodd25 on September 01, 2014, 09:53:18 PM
Anyone ever have a weird issue with the buttons on the right side of the text box where they overflow to the right of the shoutbox? I attached a screen shot of it...

Also only occurs when using chrome. I'm thinking it has something to do with the Reseller theme using bootstrap because i don't have this issue on other themes.

Any Suggestions on what to do on how to fix it?

Has anyone posted a solution to this? If yes please do link me to the post.




Any Suggestions on what to do on how to fix it?

I have the same problem....there must be a simple solution to it, I guess...
Has anyone posted a solution to this? If yes please do link me to the post.



For some reason Ban user doesn't work anymore, not sure is that problem came since 2.0.15 or appeared after installing some mod. Lite version. Any idea about how to fix?



Suddenly shoutbox disappeared from my forum

I have checked every code in required files and they seems to be ok-ish
All the required files has correct write permission.

I'm on 2.0.15

Any suggestions please.


Are you using a custom theme? If so, do you see the shoutbox when using the SMF default thee?


Just checked default and also shoutbox not available


Hi guys,

I just installed your shout box on my 3.0.15 forum and now im getting this error:

   Apply Filter: Only show the error messages of this member Florida Playboy
Apply Filter: Only show the error messages of this IP address   
   Reverse chronological order of list Today at 07:52:32 PM
Apply Filter: Only show the error messages of this session 0322b994de727ffce5a11a31e573acf5
Apply Filter: Only show the errors of this type Type of error: General
Apply Filter: Only show the error messages of this URL;sa=send;sesc;xml;row=20Apply Filter: Only show the errors with the same message2: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback insteadApply Filter: Only show the errors from this file File: /home/s7x1c79cv7ls/public_html/Sources/Shoutbox.php
Line: 316

The shout box seems to be working ok, but i keep getting this error.


-Rock Lee-

What version of PHP are you using?

¡Regresando como cual Fenix! ~ Bomber Code
Ayudas - Aportes - Tutoriales - Y mucho mas!!!


I was using 7.1, I rolled it back to 7.0 earlier. Just got same error just now.


296:      // verifying word isn't too long... same SMF function ;)
297:      if ($shoutbox['fixLongWords'] > 5 && $shoutbox['fixLongWords'] < $shoutbox['maxMsgLenght'])
298:      {
299:         $non_breaking_space = $context['utf8'] ? ($context['server']['complex_preg_chars'] ? '\x{A0}' : "\xC2\xA0") : '\xA0';
301:         if ($context['browser']['is_gecko'] || $context['browser']['is_konqueror'])
302:            $breaker = '<span style="margin:0 -0.5ex 0 0"> </span>';
303:         elseif ($context['browser']['is_opera'])
304:            $breaker = '<span style="margin:0 -0.65ex 0 -1px"> </span>';
305:         else
306:            $breaker = '<span style="width:0;margin:0 -0.6ex 0 -1px"> </span>';
308:         $shoutbox['fixLongWords'] = (int) min(1024, $shoutbox['fixLongWords']);
310:         if (strlen($msg) > $shoutbox['fixLongWords'])
311:         {
312:            $msg = strtr($msg, array($breaker => '< >', '&nbsp;' => $context['utf8'] ? "\xC2\xA0" : "\xA0"));
313:            $msg = preg_replace(
314:               '~(?<=[>;:!? ' . $non_breaking_space . '\]()]|^)([\w\.]{' . $shoutbox['fixLongWords'] . ',})~e' . ($context['utf8'] ? 'u' : ''),
315:               'preg_replace(\'/(.{' . ($shoutbox['fixLongWords'] - 1) . '})/' . ($context['utf8'] ? 'u' : '') . '\', \'\\$1< >\', \'$1\')',
==>316:               $msg);
317:            $msg = strtr($msg, array('< >' => $breaker, $context['utf8'] ? "\xC2\xA0" : "\xA0" => '&nbsp;'));
318:         }
319:      }
321:      // style
322:      $disabled = array();
323:      if (isset($shoutbox['disableTags']))
324:         foreach (explode(',', $shoutbox['disableTags']) as $tag)
325:            $disabled[$tag] = 1;
326:      $style = '';
328:      // bold
329:      if (isset($_POST['bold']) && !isset($disabled['b']))
330:         $style .= 'font-weight:bold;';
331:      // italic
332:      if (isset($_POST['italic']) && !isset($disabled['i']))
333:         $style .= 'font-style:italic;';
334:      // underline
335:      if (isset($_POST['underline']) && !isset($disabled['u']))


Could this be caused by me trying to lengthen the limit on posts in the box? You cant even get a full sentence in with the stock settings.


No, it's the regex used to split up long words, originally borrowed from SMF's code but not updated to fix things when they changed in PHP 5.5.

SMF fixes this in 2014, but the mod author didn't update. Unfortunately I'm on mobile right now and rewriting the regex on mobile is super painful. If I remember I'll post the corrected version tonight when I'm back on my regular machine.


Ok great! My members really like it. Can you let me know here when it is fixed?


Quote from: Nibogo on September 26, 2018, 10:47:28 AM
Your best bet would be to uninstall the mod and then install it again, something probably broke it.

Done that, reinstalled now but got another problem.
Shoutbox settings are blank. Can't even change any settings, seems to be permission issue?

Can anyone please point me into right direction?


Are the settings blank or is the text not visible due to the background color of that theme? (text same color maybe?)

Can you see the settings when using another theme?


Quote from: delta5 on October 01, 2018, 11:44:14 AM
Ok great! My members really like it. Can you let me know here when it is fixed?

I don't have the power to fix the mod, only to suggest what the code change would be (to actually fix the mod itself you need to bug the author, who isn't me), but I just realised, you have the site whose domain is that you're fed up with people like me, so... yeah. Sorry to get your hopes up, maybe you'll get better luck with the plugin's author.