Advertisement:

Author Topic: TinyPortal  (Read 753491 times)

Offline Sweetwater

  • Semi-Newbie
  • *
  • Posts: 90
  • Gender: Male
    • SWFishing on Facebook
    • @SweetWaterFish on Twitter
    • Sweetwater Fishing Australia
Re: TinyPortal
« Reply #780 on: September 25, 2010, 10:19:19 AM »
I've recently upgraded my forum to SMF 2.0 RC3

Was running TP on the old 1.1.11 & it worked great.  8)

On RC3 I cannot get the right panel to work at all & the TPShout leaves an empty header with no shoutbox under it.
Also added SSI for Store & Gallery, these wont work either.

Can anyone offer any tips for sorting this out?

Kind Regards,

Sweetwater

Offline ZarPrime

  • Jr. Member
  • **
  • Posts: 135
Re: TinyPortal
« Reply #781 on: September 25, 2010, 10:45:56 AM »

Sweetwater,


Well, on the right panel not showing, a couple of things that you can check ...
1.  Go to YourSite.com/index.php?action=tpadmin;sa=panels and make sure that "Use right panel?" is "On"
2.  Make sure that you have at least one block in the right panel and that is set to show somewhere.  In other words, go to the edit screen for that block and make sure that "Choose where the block should appear" has something selected, like "Display on all pages and sections".


On the Shoutbox issue, go to YourSite.com/index.php?action=tpadmin;sa=modules and make sure that the "TP Simple Shout" is turned "On".


If this doesn't solve your issues, more help is available at the TP Support Site by posting in the Support Board there.  The link is here --> http://www.tinyportal.co.uk/index.php


ZarPrime

Offline Sweetwater

  • Semi-Newbie
  • *
  • Posts: 90
  • Gender: Male
    • SWFishing on Facebook
    • @SweetWaterFish on Twitter
    • Sweetwater Fishing Australia
Re: TinyPortal
« Reply #782 on: September 25, 2010, 10:58:07 AM »
Thankyou ZarPrime for your helpful reply.

I've been through all of that numerous times & double checked. I just ran through the permissions & found a couple of files that didn't upload properly. This has fixed the shoutbox & hopefully may fix the right panel issues.

Fingers crossed I can come back & tick this as solved.

Thanks again.

Sweetwater

Offline Sweetwater

  • Semi-Newbie
  • *
  • Posts: 90
  • Gender: Male
    • SWFishing on Facebook
    • @SweetWaterFish on Twitter
    • Sweetwater Fishing Australia
Re: TinyPortal
« Reply #783 on: September 25, 2010, 01:47:10 PM »
Unfortunately no luck on getting any panel other than the left one to work....

Am out of ideas. Any more tips out there?

Sweetwater

Offline agridoc

  • SMF Hero
  • ******
  • Posts: 3,274
  • Gender: Male
    • Aeromodelling GR - Aeromodelling in Greece
Re: TinyPortal
« Reply #784 on: September 25, 2010, 02:47:09 PM »
Sweetwater I had a look at your site, you have no SMF, neither TP copyright, also added main menu item. You probably have done quite some changes yourself.

I don't know what changes you have made but it's quite probable that your editing might have caused some problems, TP not properly functioning included. I will also remind that copyright removal of either SMF or TP is not legal. It may be a mistake but it has to be fixed too.
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

Offline ZarPrime

  • Jr. Member
  • **
  • Posts: 135
Re: TinyPortal
« Reply #785 on: September 25, 2010, 07:14:47 PM »


Yeah, I noticed the copyrights missing earlier but they were on there before he started working on it.  Sweetwater, I suspect that you might have some block enabled that is causing this.  Do you have any blocks enabled in the left panel that aren't showing up?


The copyrights aren't showing up on other pages as well.  The problem could be your Gallery Mod.  Can you turn off the Recent Pictures at the top and see if your copyrights come back on the bottom of the page.


If that doesn't do it, I might have to have Admin access to your site (I am a Support Team Member over at the TP Support Site) so that I can try to see what's going on.  It would be better if you registered over there and posted to the Support board.  I am probably going to be offline for the rest of the evening so I will check back tomorrow.  However any of the other Team Members over there can help you as well.


ZarPrime

Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,723
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #786 on: September 25, 2010, 08:47:23 PM »
Well, the Recent block uses the ssi_recentTopics function and the Unread posts uses the unread action (action=unread).  Those 2 functions work quite differently from each other.  the ssi_recentTopics function actually shows the most recent posted to topics so it makes sense that, when you click that, you should be taken to the last post of the recent topic.


However, I will leave this for you and Bloc to hash out because, IMHO, it's working the way it should be working.  Even though you can click the "new" icon, as far as I'm concerned, it should take you to the most recent post in the topic, and that's what it does.  The other consideration is that you can make the "new" icon show up again after you've read a topic just by marking a topic unread.  That doesn't necessarily mean that that topic is going to show up again if you go to action=unread, at least not until someone makes another post in the topic.


ZarPrime
I see what your saying but for my personal preference if possible, I'd like the "recent block" to work like the unread since last visit. Most people when replying don't generally modify the subject line so that should almost always remain / read the same i nthe recent block regardless of the latest reply. That saud I could even renamed the block to unread since last visit or just leave it as is name wise.

Anyway, the below code that  Igot from TP 1.0 seems to work on 098 as well so I can use it on my live site and my test site so I ask to anyone willing to help.

How can the below code be modified so that when links or the "new" image is clicked in the recent block it takes you to the first unread reply in a given topic and not the last ?

Code: [Select]
global $context, $modSettings;
$context['TPortal']['recentboxnum']='10';

if(isset($modSettings['recycle_board']))
$bb=$modSettings['recycle_board'];

$what=ssi_recentTopics($context['TPortal']['recentboxnum'], NULL, NULL, 'array');
$counter=1; $cmax=count($what);
echo '
<div>';
foreach($what as $w)
{
echo '
<div class="smalltext"><a href="'.$w['href'].'">'.$w['short_subject'].'</a></div>
<div class="smalltext">By: <b>', $w['poster']['link'], '</b></div>
<div class="smalltext">';
if(!$w['new'])
echo '<a href="'.$w['href'].'"><img border="0" src="'.$settings['images_url'].'/'.$context['user']['language'].'/new.gif" alt="new" /></a> ';

echo '['.$w['time'].']
</div>';

if($counter != $cmax)
echo '<hr />';
$counter++;
}
echo '
</div>';
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline Rafferty

  • Jr. Member
  • **
  • Posts: 318
  • Gender: Male
    • 16 Air Defence Regiment Members
Re: TinyPortal
« Reply #787 on: September 26, 2010, 08:40:52 AM »
On recent upgrade to TP 1.0 RC1 on smf 2.0 RC3, articles/download function - selection= Articles: Recently Written,  does not work. on turning on block, I have the title, a blank block and no other blocks displaying after this one.
Don't Follow me I got No Idea what I'm Doing

bloc

  • Guest
Re: TinyPortal
« Reply #788 on: September 26, 2010, 08:51:28 AM »
On recent upgrade to TP 1.0 RC1 on smf 2.0 RC3, articles/download function - selection= Articles: Recently Written,  does not work. on turning on block, I have the title, a blank block and no other blocks displaying after this one.
Thanks for the heads-up, I will check that.

bloc

  • Guest
Re: TinyPortal
« Reply #789 on: September 26, 2010, 09:01:05 AM »
On recent upgrade to TP 1.0 RC1 on smf 2.0 RC3, articles/download function - selection= Articles: Recently Written,  does not work. on turning on block, I have the title, a blank block and no other blocks displaying after this one.
Thanks for the heads-up, I will check that.

Indeed, there is a missing line in TPSubs.php. You need to find
Code: [Select]
function art_recentitems($max='5' , $type='date' ){

    global $context, $settings, $db_prefix, $txt, $settings;

    $tp_prefix = $db_prefix.'tp_';

and add the line below after it:
Code: [Select]
$now= time();


Offline Crip

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,139
  • Gender: Male
  • C-4 QUAD
    • Cripzone
Re: TinyPortal
« Reply #790 on: September 26, 2010, 09:04:36 AM »
thanks Bloc!
I have become comfortably numb!


I remember my mother's prayers and they have always followed me.
   - Abraham Lincoln -


TOTM Winner. | Demo Site1on1 Theme Support

Offline Rafferty

  • Jr. Member
  • **
  • Posts: 318
  • Gender: Male
    • 16 Air Defence Regiment Members
Re: TinyPortal
« Reply #791 on: September 26, 2010, 09:13:29 AM »
That works, cool!
Don't Follow me I got No Idea what I'm Doing

Offline SN

  • Jr. Member
  • **
  • Posts: 398
  • Gender: Male
  • » To Dare is To Do
    • SpursNetwork - Tottenham Hotspurs Fansite
Re: TinyPortal
« Reply #792 on: September 26, 2010, 09:51:17 AM »
Bloc is what i said before about blocks not showing for admin a bug or am i doing something wrong?

bloc

  • Guest
Re: TinyPortal
« Reply #793 on: September 26, 2010, 10:02:40 AM »
Bloc is what i said before about blocks not showing for admin a bug or am i doing something wrong?
So far I haven't found anything wrong - but I need to test more.

Offline Nyls

  • Semi-Newbie
  • *
  • Posts: 12
Re: TinyPortal
« Reply #794 on: September 28, 2010, 07:08:44 AM »
hello all

if i uninstall tinyportal on a smf 2.0 RC3, all content in data base will be safe or not, if i réinstall tinyportal in the futur ?

thx for response  ;)

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #795 on: September 28, 2010, 10:29:38 AM »
No tables are removed. Data should still be there.
IchBin™        TinyPortal
Coding Guidelines       

Offline ormuz

  • Full Member
  • ***
  • Posts: 689
Re: TinyPortal
« Reply #796 on: September 28, 2010, 10:55:35 AM »
Is the "themegallery" included by default in tinyportal?

If not, is it possible to have it, bloc?

Offline Ken.

  • Full Member
  • ***
  • Posts: 496
  • Gender: Male
  • TinyPortal Rocks!
    • Our FamilyForum
Re: TinyPortal
« Reply #797 on: September 28, 2010, 11:54:24 AM »
ormuz, when you say "themegallery" to what are you referring?

The latest releases of TinyPortal do not include actual themes, but are able to use most any theme that will work with SMF and you can find many of them here on SMF plus various other sites that make themes for SMF, including Blocs site 'BlocWeb'.
http://www.blocweb.net/index.php
"If you don't have a stack of failures in your shop, you aren't trying hard enough". --Richard Raffin.


Offline ormuz

  • Full Member
  • ***
  • Posts: 689
Re: TinyPortal
« Reply #798 on: September 28, 2010, 11:59:56 AM »
ormuz, when you say "themegallery" to what are you referring?

The latest releases of TinyPortal do not include actual themes, but are able to use most any theme that will work with SMF and you can find many of them here on SMF plus various other sites that make themes for SMF, including Blocs site 'BlocWeb'.
http://www.blocweb.net/index.php

I'm talking about the custom mod to have a theme gallery, that blocweb.net have and smfdegsign,net have too... Bloc's know what I'm talking about ;)

Offline Ken.

  • Full Member
  • ***
  • Posts: 496
  • Gender: Male
  • TinyPortal Rocks!
    • Our FamilyForum
Re: TinyPortal
« Reply #799 on: September 28, 2010, 12:39:05 PM »
That gallery was designed just for displaying themes on BlocWeb and is not currently available for use elsewhere. If Bloc dose release a public version it is likely to be some time before that happens.
"If you don't have a stack of failures in your shop, you aren't trying hard enough". --Richard Raffin.