News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Stop Spammer

Started by M-DVD, December 31, 2008, 07:31:43 AM

Previous topic - Next topic

live627

Quote from: spiros on January 12, 2022, 05:11:47 AMHas anybody tested it with php 8? I get Call to undefined function create_function() when accessing Members (using 2.3.9, when I tried to uninstall it shoes 3 errors in 2 files)
https://www.simplemachines.org/community/index.php?topic=580270.new#new
I believe 2.4.0 fixes this

DomDom Skye

I'm using SMF 2.0.19 and when I try to install the package, I read "The package you are trying to download or install is either corrupt or not compatible with this version of SMF."
Any chance to have it working for the latest version? It stopped to 2.0.18

Diego Andrés


SMF Tricks - Free & Premium Responsive Themes for SMF.

Arskrigitsioniets

Doesn't work on 2.0.19.

Shades.

Quote from: Arskrigitsioniets on January 25, 2022, 05:39:38 PMDoesn't work on 2.0.19.
What errors are your getting? I have it installed and working just fine on 2 seperate 2.0.19 forums!
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

SugarD-x

#2145
Quote from: Shades. on January 25, 2022, 06:28:51 PM
Quote from: Arskrigitsioniets on January 25, 2022, 05:39:38 PMDoesn't work on 2.0.19.
What errors are your getting? I have it installed and working just fine on 2 seperate 2.0.19 forums!
Literally this for me: "The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

Edit: Found the issue...

Extract the package. In package-info.xml:

Find:
<install for="2.0.15, 2.0.16, 2.0.17, 2.0.18">
Change to:
<install for="2.0.15, 2.0.16, 2.0.17, 2.0.18, 2.0.19">
Find:
<uninstall for="2.0.15, 2.0.16, 2.0.17, 2.0.18">
Change to:
<uninstall for="2.0.15, 2.0.16, 2.0.17, 2.0.18, 2.0.19">
ZIP up the package and upload it again. If you uploaded it previously, delete the old package via the Package Manager first, then upload the fixed one.

Shades.

Or just click on "Advanced" at the bottom right in Package Manager and type in 2.0.18 in the "Emulate Version" box and click "Apply". Then you'll be able to install it without editing anything, unless of course if you already have other mods installed that have changed the code. ;)
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

live627

Quote from: SugarD-x on February 08, 2022, 07:41:03 PMExpand
<uninstall for="2.0.15, 2.0.16, 2.0.17, 2.0.18">
or make a wildcard2.0.*

jacbier

Will there be an update for SMF 2.1?

SugarD-x

Quote from: live627 on February 08, 2022, 10:30:15 PM
Quote from: SugarD-x on February 08, 2022, 07:41:03 PMExpand
<uninstall for="2.0.15, 2.0.16, 2.0.17, 2.0.18">
or make a wildcard2.0.*
Correct. I was just trying to modify the original package as little as possible since it already used that format.

Matthias

I am currently in the process of updating for 2.1.
My forums are currently still 2.0.x
But hopefully an update will come soon.
Quality first

Diego Andrés

Quote from: Matthias on February 16, 2022, 06:43:42 PMBut hopefully an update will come soon.
When you do update the mod make sure you include a license with the package  :D

SMF Tricks - Free & Premium Responsive Themes for SMF.

SugarD-x

Quote from: Matthias on February 16, 2022, 06:43:42 PMI am currently in the process of updating for 2.1.
My forums are currently still 2.0.x
But hopefully an update will come soon.
You have no idea how much I appreciate your reply stating this. This is by far the best anti-spam mod I've used on any forum software thus far, and without it my life has been a nightmare trying to keep spam bots off of my forums. SMF 2.1 compatibility would be a HUGE relief of stress for me in forum management and administration.

izotz

Quote from: Matthias on February 16, 2022, 06:43:42 PMI am currently in the process of updating for 2.1.
My forums are currently still 2.0.x
But hopefully an update will come soon.

Same thing, as SugarD-x said, our moderators would have a hard time without this.  It is the most useful mod in our forum.

I understand this can take time, but even very high level, I don't know if you could tell us if you are expecting the update to take weeks, a couple of months, or more. Just to set expectations, because I'd rather not upgrade our forum to version 2.1.1 if there is a chance of this mod to be compatible within the next 1 or 2 months.

Thanks so much for your work and patience.

Matthias

I have a working version for 2.1
Only a few small things need to be done.
I think this will be ready in the next days.
Quality first

Arantor

If your mod is taken from the mod here and tweaked, neither you nor SMF are legally allowed to distribute it :(

The original author did not indicate a suitable licence for modified works so any 2.1 version must be limited to "if you take the existing mod, here are the changes to make it work on 2.1" unless someone can get hold of the original author and confirm the legal situation as such.

Copyright law sucks, but that is unfortunately the law.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

Diego Andrés

He recently (last year) was added as an additional author for this mod  :P
I'm hoping he'll include a license this next update.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Arantor

Even that is dubious legally without it actually in writing what licence the original was under, or some formal notice from its original author. Licences cannot be changed without all of the copyright holders agreeing to it.

Do I think it's a *problem*? Realistically probably not, but *legally* it could be.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

Matthias

In the StopSpammer.php file it says this. I think that's why the update is not a problem.

/******************************************************************************
* This program is free software; you may redistribute it and/or modify it     *
* under the terms of the provided license as published by SMF.                *
*******************************************************************************
* This program is distributed in the hope that it is and will be useful,      *
* but WITHOUT ANY WARRANTIES; without even any implied warranty of            *
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.                        *
******************************************************************************/
Quality first

Matthias

Last year I had email contact with virtualsnoopy. He wrote this:

QuoteHi Matthias

I haven't been working in that mod for years, because I've been too busy and I never find time to do it.

If you are interested in keeping the mod alive and publish updates, I can ask the staff to add you as coauthor if you want.

This way you would be able to publish updates and maybe in the future, if I have some free time, we could work together in future updates.

Or, if you just want to publish this update but are not interested in working in future updates, just send me the zip file and I will publish it with your name.

It's up to you

Quality first

Advertisement: