• Welcome to Simple Machines Community Forum. Please login or sign up.
November 30, 2021, 01:16:54 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


[Solved] Upgrade B4 -> RC1: Unknown column

Started by Sageth, February 06, 2009, 11:32:21 AM

Previous topic - Next topic

Sageth

February 06, 2009, 11:32:21 AM Last Edit: February 06, 2009, 12:15:01 PM by Sageth
I did a fresh install of B4 and then went to upgrade to RC1.  When I did, I encountered two strange issues, which I have corrected, but now I'm stuck.

The first two errors were related to the smf_calendar.  It was looking for start_date rather than startDate and the same for end_date.  I modified the database and it proceeded from there.

Now I'm getting the error:
Upgrading...
Updating holidays and calendar...
done.
    Converting other date columns... done.
Successful.
Adding custom message icons...
    Checking for an old table... done.
    Creating "message_icons"... done.
    Inserting "message_icons"... done.
Successful.
Adding package servers...
    Creating "package_servers"... done.
    Inserting "package_servers"... done.
Successful.
Cleaning up database...
    Updating flood control log... done.
    Updating ip address storage... done.
    Converting "log_online"... done.
    Updating poll column sizes... done.
    Updating attachments table... done.
    Updating boards and topics... done.
    Updating members... done.
    Recounting member pm totals (step 1)... Unsuccessful!
This query:

    SELECT mem.ID_MEMBER, COUNT(pmr.ID_PM) AS instantMessages_real, mem.instantMessages
    FROM smf_members AS mem
    LEFT JOIN smf_pm_recipients AS pmr ON (pmr.ID_MEMBER = mem.ID_MEMBER AND pmr.deleted = 0)
    WHERE mem.ID_MEMBER > 0
    AND mem.ID_MEMBER <= 0 + 256
    GROUP BY mem.ID_MEMBER
    HAVING instantMessages_real != instantMessages
    LIMIT 256;

Caused the error:

    Unknown column 'mem.instantMessages' in 'field list'



Obviously, the error is saying that the column doesn't exist.  But any idea on what I can do for this one or why I'm seeing these errors?

karlbenson

If you were at Beta 4, the database should already have been using start_date rather than startDate.

It seems to be running queries expecting you to be running a 1.1.x database?

Sageth

February 06, 2009, 11:55:22 AM #2 Last Edit: February 06, 2009, 12:14:38 PM by Sageth
Hmm... Thanks.

It was definitely a clean install and only had one mod (ad management).  I have backups, so maybe I'll try recopying the installation files.

Edit:
Not sure what happened, but I restored from last night's backup and tried again.  All went well this time. 

::)

Advertisement: