• Welcome to Simple Machines Community Forum. Please login or sign up.

Login problems

Started by joshkol, August 06, 2009, 09:25:08 PM

Previous topic - Next topic

joshkol

August 06, 2009, 09:25:08 PM Last Edit: September 20, 2009, 12:42:29 AM by joshkol
Whenever I try to login I get this error:

You are not authorized to view this resource.

Im using the latest SMF and Mambo (not beta) and the bridge login.

Orstio

What version NUMBER of SMF?

What version NUMBER of the bridge?

Do you have a URL?

Are you using the bridge login module?  Is your bridge component menu item publicly accessible?

joshkol

Smf 1.1.10
Mambo 4.6.2
Bridge 1.1.2

kilowattlaser.com
It is publicly accessible

Orstio

Your SMF database user does not have access to your Mambo database.

joshkol

Im using 1and1 hosting and the admin backend is not cpanel, any idea on how to add users to the database?

Orstio


joshkol

Dont tihnk so, although I have phpmyadmin

Orstio

Then you need to have SMF and Mambo in the same database.

joshkol

So I need to uninstall smf, should I just delete the bridge then smf and reinstall both?

Orstio

Why do you need to uninstall SMF?

Export your SMF database to a gzip file on your computer from phpMyAdmin.

Go to your Mambo database, and import the gzip file.

Change your SMF database info in your SMF admin panel to match your Mambo database info.

joshkol

I got this error trying to import

#1044 - Access denied for user 'dbo293818669'@'%' to database 'db293906775'

dbo293818669 is mambo
db293906775 is smf

Orstio

Check the text file inside the gzip.  Make sure it does not have any database specific information.

joshkol

The error is no longer there now that its in the same database, but I cant login now. It just goes back to index.

Orstio

In SMF, do you have subdomain independent cookies enabled?

Do you have the SMF_login or SMF_logout mambots published?

Are you accessing your site at kilowattlaser.com , or at www.kilowattlaser.com ?

joshkol

Subdomain independent cookies are enabled.
Both of those mambots are published.
And I access it with the www

Orstio

QuoteBoth of those mambots are published.
And I access it with the www

There's two of your problems.

If you are using the bridge login module, you should not have the SMF_login and SMF_logout mambots published.

When you installed Mambo, you told it that the URL was without the www.  You'll never be logged into Mambo unless the URL in your browser matches the URL you told it when it was installed.

joshkol

I changed the url to www in the global config and unpublished both mambots. When I try to login it still wont work =/

joshkol

Still can't get this to work, any help is appreciated.

Orstio

Make sure the SMF_header_include mambot is published.

joshkol

I published it just now and got the same results.

Advertisement: