News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Subaccounts

Started by SlammedDime, November 12, 2009, 09:59:09 AM

Previous topic - Next topic

Rotten Apple

#300
Hello again! =D I noticed while posting about with the mod, that if I'd accidentally post with an account and change the author using a mod, that it would raise the post count of the new author even if the permissions of the forum are set to disable post count increments. The post count increase would only occur with the new author, and I'm uncertain if this is a bug or not? If it's not, can this solution be fixed? If not, that's fine - it's not a big issue on my end.

Also, I'm using 2.0 RC4.

SlammedDime

Quoteif I'd accidentally post with an account and change the author using a mod
With 'a' mod?  Do you mean this mod? or another?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Rotten Apple

This mod, using the little dropdown that appears while posting in threads.

SlammedDime

Sounds like a bug, i recall adjusting post counts when authors change, i might have forgotten to account for this.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Mari-chi

Quick question: How do I get the subaccounts to show up as though they were regular members in the Members listing? I happened to come across another site whose layout was shown like this:

http://i1127.photobucket.com/albums/l635/irinaqueer/misc/subaccount_memberlist.png

I only saw an option to display subaccounts in the Members listing in the admin panel, but nothing about the way it's displayed. :S

Rotten Apple

Alright, thanks! I figured that it could have been that. It's not much of a big issue though on my end. I'll just have to be more careful what account I'm posting on. XD.

Mari-chi

Oh, and one more thing!: New subaccounts seem to inherit the value of their parent accounts' custom profile fields. one of my custom profile fields is called "RPP", and if the parent account has 12 RPP, then any subaccount created by that parent account will also inherit the value "12" for their RPP. Can this be changed? :S

Caltan

Quote from: Mari-chi on January 25, 2011, 11:22:56 AM
Quick question: How do I get the subaccounts to show up as though they were regular members in the Members listing? I happened to come across another site whose layout was shown like this:

http://i1127.photobucket.com/albums/l635/irinaqueer/misc/subaccount_memberlist.png

I only saw an option to display subaccounts in the Members listing in the admin panel, but nothing about the way it's displayed. :S

Lol, that's my site.  Small world. :)

To display subaccounts as regular members, revert the edits the mod makes to Themes/default/Memberlist.template.php and Sources/Memberlist.php.  If you haven't installed any other mods since this one that make changes to those files, you can just copy the backup Memberlist.template.php~ and Memberlist.php~ back over. 

QuoteNew subaccounts seem to inherit the value of their parent accounts' custom profile fields. one of my custom profile fields is called "RPP", and if the parent account has 12 RPP, then any subaccount created by that parent account will also inherit the value "12" for their RPP. Can this be changed? :S

I've always observed the behavior that subaccounts inherited the parent account's profile fields; we just replace the text with whatever it should be for the new account, it's never seemed like a big deal.  I assume this is because the mod clones the entire account in order to allow more than one account to use the same email address.

Mari-chi


SlammedDime

Cloning of profile fields shouldn't be happening (that I remember anyway...) I'll have to take a look.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Mari-chi


Robin1989

will this see a rc5 update?

sodmanccc

any chance we can get a update for rc5

Mari-chi

It works for RC5. I believe it takes one or two manual edits, if I remember correctly.

sodmanccc

Quote from: Mari-chi on February 21, 2011, 11:34:44 PM
It works for RC5. I believe it takes one or two manual edits, if I remember correctly.

when we use it on smf 2.xrc5 we get high sever load veryy fast it seams to be over loading sever might have to do with it thinking we on rc3.

but yea we turn it on and use it and our sever load jumps over 100-400%

SlammedDime

I don't really see how it could be increasing your server load... it doesn't do anything to increase load that I know of.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Robin1989

on the default theme it shows a dropdown to switch accounts next to the members avatar - what php code would i need to create a custom block for simpleportal to display that dropdown as the members avatar etc is hidden on my custom theme so i want to create a block to switch accounts as at the minute the only way to do that on the custom theme is to go into your profile and swap global account.  thankyou for any help

Robin1989

bump anyone have any idea?

Spoogs

Check page 13 (not sure if that code will help you but you can take a look)

Robin1989

its ok i got it sorted - plus there isnt a page 13.


however i think i have found a bug - im not sure if its just my forum or a bug in the mod with rc5. when using the drop down on the main forum page and changing acounts there is a 404 but then if you go back to the forum you have changed.

what happens is if your url is just domain.com/forum/ then it works fine but if it is domain.com/forum/index.php it 404's and if its domain.com/forum/index.php? it works fine as well.  it looks like when you choose the dropdown it is removing the index.php from the url and just leaving the action as the 404 link is at domain.com/forum/action=forum


i have simpleportal installed if that makes a difference

Advertisement: