• Welcome to Simple Machines Community Forum. Please login or sign up.

Simple ImageShack (latest release: v3.1.3)

Started by Rik©, June 03, 2005, 02:50:34 PM

Previous topic - Next topic

tbk22

Portuguese translation attached

Read NOTE please

Thanks for your mod...

Looking forward for the RC 2 version
=)

Rik©

Quote from: tbk22 on February 10, 2010, 06:57:13 PM
Portuguese translation attached

Read NOTE please

Thanks for your mod...

Looking forward for the RC 2 version

Thanks.
And i've read the note.

-Rik©

virtualband.ru

February 11, 2010, 08:26:03 PM #382 Last Edit: February 12, 2010, 06:11:55 AM by virtualband.ru
Hi,
Is it possible somehow to make this mod automatically copy one of 4 links into the reply box. Because when some users see the thumbnail, they mistakenly think that the image is already attached so they press Post button and there's no image in their reply.

Thanks.


And BTW when I don't set the path to the image and click Host it! there's php error:


Warning: unlink(): No such file or directory in /some_directory/SISxmlapi.php on line 42

Warning: unlink(/tmp/): Permission denied in /some_directory/SISxmlapi.php on line 42

Oops, something went wrong
(XML return failed)

Rik©

Quote from: virtualband.ru on February 11, 2010, 08:26:03 PM
Hi,
Is it possible somehow to make this mod automatically copy one of 4 links into the reply box. Because when some users see the thumbnail, they mistakenly think that the image is already attached so they press Post button and there's no image in their reply.
Maybe i'll add auto-insert to a later version, but atm it's not top priority.

Quote from: virtualband.ru on February 11, 2010, 08:26:03 PM
And BTW when I don't set the path to the image and click Host it! there's php error:


Warning: unlink(): No such file or directory in /some_directory/SISxmlapi.php on line 42

Warning: unlink(/tmp/): Permission denied in /some_directory/SISxmlapi.php on line 42

Oops, something went wrong
(XML return failed)

Thanks for this 'bug report'.
This only happens if you 'Host it' without selecting a file.
I will add a check to a later version.

-Rik©

navjotjsingh

How much more time before you come out with a 2.0RC2 Version?

Rik©

Quote from: navjotjsingh on February 19, 2010, 12:26:02 AM
How much more time before you come out with a 2.0RC2 Version?
Well. 3.0.1 is ready for release (i will test it first @ SimpleTweaks).
After 3.0.1 release i will start coding 3.1.0 for SMF2.

-Rik©

ps
Remember that i (like most other mod-developers) also have some paid jobs.
And although i enjoy coding for SMF, the 'paid projects/jobs' will always have a higher priority than the free ones.


Rik©

Simple ImageShack 3.0.1 has been released!

As promised this release supports greek (villasg) and portuguese ( FragaCampos).
This release also fixes the 'Image Path Not Set' bug reported by virtualband.ru

Enjoy and have a nice weekend!

-Rik©

Am'

very nice ^^

it's possible to improve your module that also integrates to upload avatars ?
اذا أحس أحد انه لم يخطأ ابدا في حياته, فهذا يعني أنه لم يجرب أي جديد في حياته
My Mods For SMF 2 RC3 : XQuote XCode - Vbulletin Style New Meta Tags

aw06

February 19, 2010, 10:19:26 AM #388 Last Edit: February 19, 2010, 11:25:32 AM by aw06
Does this new version give the option to show the simple image shack below post and not inside additional options ?

And how can i check if i have the PHP extension CURL
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

Rik©

Quote from: aw06 on February 19, 2010, 10:19:26 AM
Does this give the option to show the simple image shack below post and not inside additional options ?

And how can i check if i have the PHP extension CURL
No, the option to change location will be added later, probably 3.1.0
SIS 3.1.0 will probably also have a built-in cURL check (if it fails the mod will (automatically) use the iframe from ImageShack.us).

Quote from: Am' on February 19, 2010, 10:17:09 AM
very nice ^^

it's possible to improve your module that also integrates to upload avatars ?

Is it possible.... yes, but it will take some time.
But i like the idea, maybe i'll code this after release of SIS 3.1.0

-Rik©

ps I will code a small 'cURL check' file tonight so you can check if cURL is installed yourself.

Am'

اذا أحس أحد انه لم يخطأ ابدا في حياته, فهذا يعني أنه لم يجرب أي جديد في حياته
My Mods For SMF 2 RC3 : XQuote XCode - Vbulletin Style New Meta Tags

aw06

Ok thanks .. guess will wait for next release .. really want it to remain outside of additional options ...
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

Rik©

Quote from: aw06 on February 19, 2010, 11:32:43 AM
Ok thanks .. guess will wait for next release .. really want it to remain outside of additional options ...
I'll see what i can do...  ;)

-Rik©

firstsrgt

I just download the new version 3.0.1 but i still get the same error as other fellow
QuoteInternal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@hhhclan.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I look on the SIS folder to see if there was any error but unfortunately none any idea how can i solve this problem?

Rik©

Quote from: firstsrgt on February 19, 2010, 02:52:28 PM
I just download the new version 3.0.1 but i still get the same error as other fellow
QuoteInternal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@hhhclan.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I look on the SIS folder to see if there was any error but unfortunately none any idea how can i solve this problem?
Did you check if cURL is enabled?

-Rik©

virtualband.ru

February 19, 2010, 04:57:23 PM #395 Last Edit: February 19, 2010, 05:03:47 PM by virtualband.ru
Quote from: firstsrgt on February 19, 2010, 02:52:28 PM
I just download the new version 3.0.1 but i still get the same error as other fellow
QuoteInternal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@hhhclan.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I look on the SIS folder to see if there was any error but unfortunately none any idea how can i solve this problem?

I solved this problem by setting

chmod 444 ./sis/*.php


Anyway thank you very much, Rik©  :)

tonnybarros


Rik©

Quote from: virtualband.ru on February 19, 2010, 04:57:23 PM
Quote from: firstsrgt on February 19, 2010, 02:52:28 PM
I just download the new version 3.0.1 but i still get the same error as other fellow
QuoteInternal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@hhhclan.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I look on the SIS folder to see if there was any error but unfortunately none any idea how can i solve this problem?

I solved this problem by setting

chmod 444 ./sis/*.php


Anyway thank you very much, Rik©  :)
Did you also had the error with SIS 3.0.0?

virtualband.ru

Quote from: Rik© on February 19, 2010, 05:36:08 PM
Did you also had the error with SIS 3.0.0?
Yes, exactly the same one. I think it's somehow connected with permissions and apache configuration. I've just checked, it works fine with 644 also. By default after installation i had 666 on all files.

Rik©

February 19, 2010, 06:11:58 PM #399 Last Edit: February 19, 2010, 07:49:19 PM by Rik©
Quote from: virtualband.ru on February 19, 2010, 05:46:08 PM
Quote from: Rik© on February 19, 2010, 05:36:08 PM
Did you also had the error with SIS 3.0.0?
Yes, exactly the same one. I think it's somehow connected with permissions and apache configuration. I've just checked, it works fine with 644 also. By default after installation i had 666 on all files.
Glad you got it resolved!

-Rik©


Advertisement: