Join the Facebook Fan Page.

Main Menu


Started by Bugo, February 15, 2011, 03:48:12 PM

Previous topic - Next topic


I could not find " scheduled task "
Can youshow path as > > >?

Pls see my dasboard screenshoot of OPTIMUS MOD...


I've marked the path on your screenshot.


I checked , it is already marked under scheduled task  ,
But I do not see a sitemap is created...


Hi Bugo, thanks for the last 2.4.6  :)

When the task is executed I have the following error

Hook call: la funzione "Bugo\Optimus\Addons\PortaMx::makeSefUrl" nel file /home/user2560/public_html/Sources/Optimus/addons/PortaMx.php non può essere chiamata.;area=scheduledtasks   
Tipo di errore: Generale

The callable Bugo\Optimus\Addons\PortaMx::makeSefUrl could not be called.;area=scheduledtasks

Optimus 2.4.6 and SMF 2.1 RC2


PortaMx.php, replace this line:
add_integration_function('integrate_optimus_sitemap', __NAMESPACE__ . '\PortaMx::makeSefUrl', true, __FILE__);

add_integration_function('integrate_optimus_sitemap', __NAMESPACE__ . '\PortaMx::makeSefUrls', true, __FILE__);



Thanks for the new update Bugo, now i think my sugestion is implemented!
Excelent work!

Diego Andrés

Can I update safely from 1.8.7 by just replacing the files? (SMF 2.0)

SMF Tricks - Free & Premium Responsive Themes for SMF.


It is better to remove the previous version, then install the current one. Save your settings, if you want.



we ran into an issue with TinyPortal that seems to be caused by Optimus.

In SMF2.0.15 the BBC code editor in blocks and articles is missing smileys and BBC buttons when Optimus is installed & a Twitter account name is set in Meta data. This only happens if the Twitter account is entered.
Using package:

This issue does not occur in SM2.1  using package

I tracked down the exact cause in the Optimus code, and it is in the file Integration.php

In 2.2.1 this code is used:
if (!empty($modSettings['optimus_tw_cards'])) {

Where 2.4.6 uses this code:
// Twitter cards
if (!empty($modSettings['optimus_tw_cards']) && isset($context['canonical_url'])) {


The check for $context['canonical_url'] is missing in the 2.2.1 code
As a result it seems that a $twitter variable is being incorrectly set on admin pages, causing the bbc editor to break.

Is this left out on 2.2 on purpose? I am asking because it was there in Optimus version, but appears te be removed with 1.9.9..
If not, updating this line of code to this fixes the conflict..

if (!empty($modSettings['optimus_tw_cards']) && isset($context['canonical_url'])) {

Running SMF 2.1 with latest TinyPortal at


Thanks, I've updated the Github repository.


Thanks, that does the trick!
Running SMF 2.1 with latest TinyPortal at


Add  to the sitemap only those topics that have the number of replies is more than


It is the default value.
If I set 0 then will it add all of the posts? Or any problem will come?


Approved topics only.


Hi Bugo

I have been reading all the questions and your patient replies to all queries. Hats off to you.

I had a question of my own.

Do you know if there is a reason why a link to the XML sitemap wouldnt appear on the footer on 2.0? Do you think it has something to do with the theme I may have installed?

If I manually go to the sitemap URL, I can read it but I it does not update even after I run the task manually.

Just some background. I reinstalled SMF 2.0. I tried 2.1 but not many mods available fo I am trying 2.0 however I think I am having cache issues as it takes a while for the site to show any changes once they are made.


Quote from: alitech on October 11, 2019, 10:48:02 AM
Do you think it has something to do with the theme I may have installed?
I think so.


The callable \Bugo\Optimus\Integration::scheduledTask could not be called.

I am seeing in error LOG above given error code, is something to correct or?


Hi @Bugo do you know if Facebook changed it's API? Smaller 1st images stopped parsing in debugger 2 days ago.


Thank you


I have just tried to upgrade Optimus and got HTTP 500 error

Now my site gone offline


Remove /Sources/Optimus dir and uninstall the mod.
Did you install the package?