• Welcome to Simple Machines Community Forum. Please login or sign up.
October 28, 2021, 04:56:00 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Update 2.0.6 na 2.0.7

Started by Branko., January 21, 2014, 02:58:37 AM

Previous topic - Next topic

Dzonny

Resenje je da promenis hosting kompaniju.
Kompanija koja ne azurira php, ili u tvom slucaju koja ne azurira php godimama - svakako to i zasluzuje. Svi forum softveri su odavno prekinule podrsku za tako stare verzije php-a, tako da je ovakav korak smf-a bio sasvim ocekivan.

savicmi

Pazi, to je poslednji odgovor koji sam očekivao. Promeni hosting i sve će biti super, jer SMF je to sigurno uradio na najbolji mogući način...
Hosting smo promenili pre godinu dana i sada smo kod jednog domaćeg. Mogu ih ja pitati da li će uskoro da ažuriraju, ali nije to poenta mog komentara. Ranije smo bili na stranom hostingu, koji je među najpoznatijima i tamo je bila i starija verzija. Verzija 5.3.17 nije previše stara, izašla je 13.09.2012, dakle prošlo je tek nešto više od godinu dana, dok je PHP 5.5 izašao 20.06.2013, što je tek 7-8 meseci i uveren sam da cilj SMF programera nije bio da ukine podršku za ranije verzije PHP-a. Štaviše, u sistemskim zahtevima stoji da je minimalna potrebna verzija 4.1.0, a preporučena 5.2 ili viša i navedeni su još neki parametri, između ostalog memory_limit samo 8M, i svi su kod mene ispunjeni i sve bi moralo biti dovoljno za normalno funkcionisanje. Uostalom, izvesno je da je ogroman broj na verzijama nižim od 5.5, mada problem neće svi uočiti.

Branko.

SMF mora pratiti sve promjene ako želi da ostane u trci na duže staze. Jasno je da to ne zavisi od SMF tima ili nekog pojedinca. Što se tiče starosti PHP verzija, čak i PHP 5.5.x je prilično "stara" jer je tek ovih dana izašla PHP 5.5.9 verzija. Upućeniji znaju da se trenutno razvija PHP 5.6 verzija i objavljena je već  PHP 5.6.0alpha1. Naravno da se ažuriraju i starije verzije ali će za njih podrška prestati za 1-2 godine.
Što se tiče korisnika koji se, htjeli to ili ne, moraju prilagođavati hostingu je nešto sasvim drugo. To PHP programere ne tangira puno jer se sve podređuje sigurnosnim i ostalim zahtjevima.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

savicmi

Sve je to ok i normalno je da često izlaze nove verzije, ali to nema veze sa rešavanjem ovog problema. Sasvim je u redu da se SMF razvija i prilagođava novim verzijama PHP-a i to je za pohvalu, ali reći da je problem do hostinga i da je jedino rešenje da svi pređu na 5.5, a pritom SMF zvanično podržava starije verzije, nije logično rasuđivanje. Pričamo o datumima, a oni koje sam naveo nisu udaljeni godinama, već svega godinu dana. Opet, to što je trenutno u razvoju 5.6 i stiglo se do alfa verzije nema veze sa ovim niti išta znači. Stabilne verzije softvera se nikad neće prilagođavati ni beta verzijama. Imajući u vidu da je nerealno očekivati da većina u ovom momentu pređe na poslednje vezije PHP-a, treba pronaći kompromisno rešenje, tako da to radi dobro i na prethodnim verzijama. Niko ne traži da se pruži puna podrška nečemu što se pojavilo pre 5 godina, već pre samo godinu dana. Inače, rečeno je da ovaj update nema veze sa sigurnosnim zahtevima, ali to bi trebalo rešiti pre narednog update-a. Nisam imao priliku da testiram na 5.5 i ne mogu reći da li je tačno tu ta granica, odnosno da je tamo sve ok, ali ako se pronađe da jeste, neka se reši na neki način detektovanjem verzije, ako je manja radi ovako, inače radi onako i kraj. Ovo nije baš mali problem, pa da se ignoriše. Zamislite da imate temu u kojoj se prilično diskutuje, možda ima i par hiljada postova i iznenada zbog nerazumne upotrebe memorije ne može više da se nastavi ta diskusija. Za godinu-dve kada će prestati podrška kako kažeš, promeniće se dosta toga, ali u ovom trenutku problem postoji i direktno je vezan za poslednji update.

Branko.

Vidim da ne pratiš previše događanja oko PHP. SMF nije u prilici da nešto podržava ili ne. Jednostavno se prilagođava zahtjevima i potrebama. Zasigurno ovo nisu radili iz dosade. Zato je potpuno logično ovo što ti je predloženo ili vratiš na prethodnu verziju i gotova stvar.
Ne znam da li se razumijemo, pokušaću da ti objasnim to na primjeru Microsofta. Za koji mjesec prestaje podrška za WinXP a meni je on i dalje potreban jer koristim alate koji su još iz vremena 98-mice. O prelasku na Win7 ili 8 i nadogradnji hardvera nema ni govora. Vjerovao ili ne ne pada mi na pamet da se ljutim na Bila Gejtsa.
Što se tiče tvog problema on definitivno nema veze sa SMF-om već sa hostingom kome je lakše ubirati novac i ne raditi ništa.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

savicmi

Branko, daješ ekstremne primere, koji nikako nemaju veze sa ovim o čemu pričam. Prvo, treći broj u verziji označava manje promene ili ispravku neke greške, a ovog puta dovelo je do toga da softver postane neupotrebljiv, jer se izgleda nije razmišljalo o potrebnim resursima. Da je ovo potpuno nova verzija, npr. 3, ili hajde 2.1, pa da kažemo ok, moramo prilagoditi hosting ako želimo novu verziju SMF-a. Ne možeš da porediš razvoj operativnog sistema, koji se u slučaju Windowsa menja na svakih nekoliko godina sa PHP-om koji se menja znatno brže. Takođe, neki programi zahtevaju i određenu hardversku podršku, a i ne može se porediti korišćenje trećih alata ili analogno kod SMF-a, neka to budu modovi, sa update-om koji objavljuje SMF tim i kojim prestaju da funkcionišu osnovne mogućnosti softvera. Primera radi, to bi bilo kao kada mi Microsoft objavio novi service pack za XP, posle čije instalacije više ne bi mogao da koristiš Notepad. Po pravilu, nove verzije prati i specifikacija sistemskih zahteva i da skratim priču, to je možda glavni problem ovde i zbog čega ono što kažete pada u vodu. To je u slučaju SMF-a na http://download.simplemachines.org/requirements.php. Zar je toliki problem reći korisnicima, od ove verzije preporučujemo PHP 5.5 i toliko i toliko memorije i gotovo. Umesto toga, krive se drugi, a svima je jasno da većina ne može da priušti nešto više od deljenog hostinga i da nema puno logike menjati ga svake godine. Pisaću ovim mojima i pitati hoće li uskoro to da se ažurira, nije to problem, i za sada sam se vratio na 2.0.6. Problem je stav, prilagodili smo se PHP-u 5.5, a to što zvanično podržavamo mnogo starije verzije, neka ostane samo na papiru i briga nas, jednostavno ćemo reći menjajte hosting i rešen problem. Da sam jedini koji će se susresti sa ovakvim problemom, pa da kažem ok, ko zna do čega je, ali kada sam video da sve više ljudi piše o tome, ne mogu baš da razumem nezainteresovanost onih koji rade na ovom softveru. Da napomenem, ja se ne ljutim ni na koga i imam u vidu da je ovo open-source rešenje i da mnogo ljudi radi sve ovo volonterski. Inače, ja nisam pao ovde sa kruške, po struci sam informatičar, tako da dovoljno dobro znam kako neke stvari funkcionišu.

Branko.

Kad znaš kako stvari funkcionišu onda znaš koje i kakvo rješenje je najbolje. Izvoli pa ga predloži (i obrazloži) SMF timu.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

savicmi

Nema svrhe nastaviti ovu diskusiju posle tvog komentara. Valjda nismo ovde da bismo pametovali već diskutovali i pomagali jedni drugima koliko se može, a ne po svaku cenu opravdavati nečiji potez i ignorisati ono što sam pisao, odnosno izvlačiti stvari iz konektsta, a očligledne propuste zanemarivati. Vezao si se za taj hosting, a sve ono bitno ignorisao.

Branko.

Upravo si ti pametovao. Počev od iznošenja proizvoljnih zaključaka pa do neukusnog isticanja svojeg informatičkog znanja. Lijepo ti je rečeno i objašnjeno. Nisi zadovoljan, traži dodatno objašnjenje od SMF ili PHP tima. Tamo ćeš zasigurno dobiti mjerodavan odgovor.
Ovu diskusiju nećemo nastavljati, bio ti zadovoljan mojim komentarom ili ne, zbog toga jer je tema otvorena da se ljudi informišu o ovoj nadogradnji.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

Seiz

February 17, 2014, 02:43:22 AM #29 Last Edit: February 17, 2014, 06:11:05 AM by Seiz
Primetio sam da pojedine modifikacije ne rade na smf 2.0.7

Dzonny

One koje rade na 2.0 i 2.0.6 radice i na 2.0.7, ukoliko je potrebno samo emuliraj verziju...

John.

Zašto mi se ne želi povezat sa SMFom u admin panelu kod provjera zadnje verzije i novosti? Samo mi ?? stoji, to mi je došlo odkako sam prebacio na 2.0.7 ako se ne varam.

bule

Danas sam htio napraviti update sa 2.0.6 na 2.0.7 preko managera međutim kad idem na install mod javlja mi grešku:
"Greška u instalaciji paketa
Došlo je do najmanje jedne greške prilikom test instalacije ovog paketa. Preporučamo vam da ne nastavljate s instalacijom osim ako ste sigurni da znate što radite, i ako ste nedavno napravili backup. Uzrok ove greške možda je konflikt između paketa kojeg pokušavate instalirati i paketa kojeg ste već instalirali, greška u paketu, paket koji treba drugi paket kojeg još niste instalirali, ili paket namijenjen drugoj SMF verziji."

./Sources/Load.php               Neuspješno
./Sources/Subs-Post.php       Datoteka nije pronađena

Da li da instaliram ili ne?

Dzonny

o.0
Imaš li taj drugi fajl Subs-Post.php u Sources folderu?
Nemoj nastavljati instalaciju dok ne vidiš šta je problem.

bule

Nema ga u Sources folderu.
Da li da skinem full 2.0.7 pa prebacim Subs-Post.php u Sources folder ili???

Dzonny

Zanimljivo. A forum ti radi bez problema? Tj sigurno ne radi bez problema, ali samo pitam da li si primetio probleme.

Naravno, uploaduj fajl iz originalne arhive.

bule

March 19, 2014, 11:42:54 AM #36 Last Edit: March 19, 2014, 12:22:58 PM by bule
Nisam primjetio probleme.
Sad sam prebacio iz 2.0.7 Subs-Post.php i bilo je još više crvenih, pa sam prebacio iz 2.0.6 Subs-Post.php i sad je on ok, ali mi je za ovaj prvi Load.php i dalje pisalo neuspješno.
I  taj file sam onda iz 2.0.6, svježi prebacio i sad je konačno OK. Uspješan upload na 2.0.7


Hvala Dzonny na pomoći!

Advertisement: