Advertisement:

Author Topic: Mysql and PHP Upgrade?  (Read 887 times)

Offline Kenny01

  • Sr. Member
  • ****
  • Posts: 767
  • Gender: Male
Mysql and PHP Upgrade?
« on: June 07, 2014, 07:52:32 PM »
1. Please i want to know if SMF 2.0.7 is compatible with mysql and PHP latest version?

2. What's the latest version of mysql and php?

Because i asked my host to upgrade my server mysql and php to the latest version, they asked me to confirm that SMF is compatible with mysql and php  latest version because upgraded the action can not be reversed.


Please i need your urgent reply.

Thanks.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,404
    • StoryBB/StoryBB on GitHub
Re: Mysql and PHP Upgrade?
« Reply #1 on: June 07, 2014, 08:01:01 PM »
Latest versions? You *never* upgrade to the 'latest' version of anything. The latest version of PHP at time of writing is 5.6.0 beta 4, which would be totally unsuitable to run in a production environment such as your webserver. PHP themselves say not to run it. Similarly, the latest version of MySQL is an in-development milestone for version 5.7, and again, you would not run it in a production environment.

They should be telling you what version of PHP/MySQL they plan to upgrade to and we can go from there.

SMF 2.0.7 itself works on PHP 5.5.x, or best to use 2.0.6 on 5.4.x, and as for MySQL versions, fine on 5.5 with MyISAM tables, specific configuration required for InnoDB tables, requires a separate mod to be installed against MySQL 5.6 regardless of table type.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Kenny01

  • Sr. Member
  • ****
  • Posts: 767
  • Gender: Male
Re: Mysql and PHP Upgrade?
« Reply #2 on: June 07, 2014, 08:22:45 PM »
Thanks Arantor,
I have forwarded your reply to them and i will update this thread once i hear from them.

Offline Kenny01

  • Sr. Member
  • ****
  • Posts: 767
  • Gender: Male
Re: Mysql and PHP Upgrade?
« Reply #3 on: June 07, 2014, 08:31:23 PM »
Below is my host reply

"The following are the versions differences your are requesting:

mysql: 5.1 -> 5.5
php: 5.2 -> 5.3

Please let me know when you are prepared for me to perform these upgrades for you. Please verify you understand these upgrades will be irreversible on your server. Let me know if you have any questions.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,433
  • Gender: Male
    • Kindred-999 on GitHub
Re: Mysql and PHP Upgrade?
« Reply #4 on: June 07, 2014, 08:52:56 PM »
Php5.3 is certainly anything but the latest...   5.3 is almost ready for sunset, actually....

There will be no problem running smf on it...  But 5.4 is a better choice

MySQL 5.5 is just fine
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,404
    • StoryBB/StoryBB on GitHub
Re: Mysql and PHP Upgrade?
« Reply #5 on: June 07, 2014, 09:12:29 PM »
Technically, 5.3.28 is the latest 5.3 version but yes, it's far from the latest.

Moving those versions will not adversely affect SMF whatsoever.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Kenny01

  • Sr. Member
  • ****
  • Posts: 767
  • Gender: Male
Re: Mysql and PHP Upgrade?
« Reply #6 on: June 08, 2014, 03:31:53 AM »
Upgrade done and SMF was working fine only my dating sites in the same server that was affected.
Thanks.