Advertisement:

Author Topic: Wrong PM showing when opened  (Read 551 times)

Offline TheEngineer

  • Semi-Newbie
  • *
  • Posts: 42
Wrong PM showing when opened
« on: January 09, 2018, 04:02:20 PM »
Hi everyone!

We are running v2.0.14 and some of our users are seeing a strange issue with their personal messages.  If they click on the newest message of a conversation from their inbox they don't see the newest message, rather they see an older message.  I've tried running the maintenance tasks, but it didn't help (I didn't expect it to, but hoped it might).

I'm not sure what is causing the issue or if this is a known problem with a solution.  I wanted to upgrade us to v2.1.x but our hosting provider won't upgrade our MySQL(never use hostgator!) so we need to switch to a new host.  In the meanwhile, I'd like to get this resolved.  Appreciate any pointers!

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 56,493
  • Gender: Male
    • Kindred-999 on GitHub
Re: Wrong PM showing when opened
« Reply #1 on: January 09, 2018, 07:05:55 PM »
Have your host turn off the caching - probably varnish or something like that


Also, unless you know exactly hat you are doing and are capable of hand-modifying code, etc -- do not install 2.1 on a production site
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline TheEngineer

  • Semi-Newbie
  • *
  • Posts: 42
Re: Wrong PM showing when opened
« Reply #2 on: January 09, 2018, 07:31:44 PM »
Thanks!  I'll ask them to turn off caching.

I tried to do a fresh install of 2.1 on its own and planned to move the data over after it was successfully working.  Couldn't even get that far...

Offline TheEngineer

  • Semi-Newbie
  • *
  • Posts: 42
Re: Wrong PM showing when opened
« Reply #3 on: January 10, 2018, 07:47:39 AM »
Somewhat unsurprisingly, HostGator has no idea what to do and blames the forum software. >:(

Anything I can try on my side that doesn't require their intervention?

Offline TheEngineer

  • Semi-Newbie
  • *
  • Posts: 42
Re: Wrong PM showing when opened
« Reply #4 on: January 10, 2018, 10:29:50 AM »
One of my users just reported that the problem resolves if he sorts messages from oldest to newest (oldest on top).  If he switches it to newest on top, the problem comes back.  Just wanted to add that bit of information.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 56,493
  • Gender: Male
    • Kindred-999 on GitHub
Re: Wrong PM showing when opened
« Reply #5 on: January 10, 2018, 11:15:45 PM »


So, What mods? What is your url?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline TheEngineer

  • Semi-Newbie
  • *
  • Posts: 42
Re: Wrong PM showing when opened
« Reply #6 on: January 11, 2018, 12:38:22 PM »
I had Enhanced PMs installed, but no other PM mods.  I deleted it to upgrade to 2.0.15.

The url is http://www.delreefclub.org/smf

Offline lurkalot

  • Sophist Member
  • *****
  • Posts: 1,098
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Wrong PM showing when opened
« Reply #7 on: January 11, 2018, 01:23:06 PM »

I had Enhanced PMs installed, but no other PM mods.  I deleted it to upgrade to 2.0.15.


Did you actually delete it? or did you Uninstall it?

Offline TheEngineer

  • Semi-Newbie
  • *
  • Posts: 42
Re: Wrong PM showing when opened
« Reply #8 on: January 11, 2018, 01:29:06 PM »

I had Enhanced PMs installed, but no other PM mods.  I deleted it to upgrade to 2.0.15.


Did you actually delete it? or did you Uninstall it?
Fair question and poorly chosen words by me.  I uninstalled it.

Offline lurkalot

  • Sophist Member
  • *****
  • Posts: 1,098
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Wrong PM showing when opened
« Reply #9 on: January 11, 2018, 01:41:51 PM »

I had Enhanced PMs installed, but no other PM mods.  I deleted it to upgrade to 2.0.15.


Did you actually delete it? or did you Uninstall it?
Fair question and poorly chosen words by me.  I uninstalled it.

No problem, thought I'd ask as deleting instead of uninstalling can cause major problems.   ;)

Offline Aleksi "Lex" Kilpinen

  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,088
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Wrong PM showing when opened
« Reply #10 on: January 17, 2018, 01:45:59 PM »
I had Enhanced PMs installed, but no other PM mods. 
Did the uninstallation go without errors?
Are you using Curve or a custom theme?
What mods do you have installed right now?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,806
    • Arantor on GitHub
Re: Wrong PM showing when opened
« Reply #11 on: January 17, 2018, 01:53:09 PM »
One of my users just reported that the problem resolves if he sorts messages from oldest to newest (oldest on top).  If he switches it to newest on top, the problem comes back.  Just wanted to add that bit of information.

This sounds like Varnish. I'd definitely be going back to your host about this.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.