Advertisement:

Author Topic: TinyPortal Mod Issue  (Read 1221 times)

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 37
TinyPortal Mod Issue
« on: February 17, 2019, 02:32:14 PM »
Hello,

I've recently installed SMF 2.0.15 and I would like to install the mod called TinyPortal 1.6.2, but unfortunately after I upload it and proceed to install, it asks me to make some folders/files writeable from which one is the forum directory (where all the forum files are in - I think that might be the problem as it makes non sense at all). After making all the requested folders writeable I get the message that the mod (TinyPortal) is succesfully installed and after that, anything I click, I get the following page (https://imgur.com/a/meLRXVk) saying Unable to load the 'tp_above' template.


Hope someone would know what's the reason for such a message.
Cheers!

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,909
Re: TinyPortal Mod Issue
« Reply #1 on: February 17, 2019, 02:57:54 PM »
Still seeing your original problem at https://elite-duckerz.eu/forumsmf/, no theme.  What are the directory/file permissions in your install?  Should be 755/644.

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 37
Re: TinyPortal Mod Issue
« Reply #2 on: February 17, 2019, 03:05:08 PM »
Quote
Still seeing ypur original problem at https://elite-duckerz.eu/forumsmf/, no theme.  What are the directory/file permissions in your install?  Should be 755/644.
I have found a solution to that problem. If you refresh the page you can see that it has a theme, so no worries about that.
I really like the TinyPortal modification, but unfortunately I am having issues throughout the installation process as stated above.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,909
Re: TinyPortal Mod Issue
« Reply #3 on: February 17, 2019, 03:08:04 PM »
Is package manager reporting errors before you install?  Does TP work in Curve theme?

Offline @rjen

  • Full Member
  • ***
  • Posts: 414
  • Gender: Male
Re: TinyPortal Mod Issue
« Reply #4 on: February 17, 2019, 03:11:38 PM »
Just checked your site and it seems that the default theme is missing?

This link should bring up curve:
https://elite-duckerz.eu/forumsmf/index.php?theme=1

And it does not?
Did you delete the default theme?

If so, that may be the cause: TinyPortal installs in the default theme folders. If those are missing...
It the folders are there then it seems that some (or all files) are missing...
Running SMF 2.0 with Tinyportal 1.6.3 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal 1.6.3 at http://test2.fjr-club.nl/

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,909
Re: TinyPortal Mod Issue
« Reply #5 on: February 17, 2019, 03:15:06 PM »
It will not load ?theme=1 if members are not allowed to select theme.  No theme will work if Curve is missing.

Offline @rjen

  • Full Member
  • ***
  • Posts: 414
  • Gender: Male
Re: TinyPortal Mod Issue
« Reply #6 on: February 17, 2019, 03:19:40 PM »
Then there must be files missing from the install... what you can try is extract the Tree from the install package into the forum root to complete missing files...
Running SMF 2.0 with Tinyportal 1.6.3 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal 1.6.3 at http://test2.fjr-club.nl/

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 37
Re: TinyPortal Mod Issue
« Reply #7 on: February 17, 2019, 03:47:35 PM »
I did not deleted neither miss uploaded the default theme. I'm experiencing troubles with the default theme by not showing up since a fresh installation of SMF, not really sure why.
On the screenshot attached you can see that all the folders (and files - checked by me) are on my FTP server.

Offline @rjen

  • Full Member
  • ***
  • Posts: 414
  • Gender: Male
Re: TinyPortal Mod Issue
« Reply #8 on: February 17, 2019, 03:53:27 PM »
That does not show any TinyPortal files... see attached screenshot for an indication of the files that should be installed by TinyPortal...

But give the fact that you also are having problem with the theme, I suspect that the issue with TinyPortal is not related to the package, but somehow to your server setup...
Running SMF 2.0 with Tinyportal 1.6.3 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal 1.6.3 at http://test2.fjr-club.nl/

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,909
Re: TinyPortal Mod Issue
« Reply #9 on: February 17, 2019, 03:58:35 PM »
If you can PM admin and ftp access, will have a look,

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,909
Re: TinyPortal Mod Issue
« Reply #10 on: February 17, 2019, 06:00:55 PM »
This is an odd one.  755/644 permissions don't work, they're not writeable.  Must be 777/666 for themes to work and to install mods, but when SMF files are uploaded via ftp, they come up as 755/644 and must be changed.   

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,187
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: TinyPortal Mod Issue
« Reply #11 on: February 18, 2019, 12:51:10 AM »
I've seen that before, must be PHP is running as a different user. That's usually not the easiest way to do things, and most times the hosting would allow a different PHP setup as well.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline @rjen

  • Full Member
  • ***
  • Posts: 414
  • Gender: Male
Re: TinyPortal Mod Issue
« Reply #12 on: February 18, 2019, 02:34:33 AM »
I see TinyPortal is installed and working now.  :)
Running SMF 2.0 with Tinyportal 1.6.3 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal 1.6.3 at http://test2.fjr-club.nl/

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 37
Re: TinyPortal Mod Issue
« Reply #13 on: February 18, 2019, 05:00:40 AM »
I see TinyPortal is installed and working now.  :)

Yes, thanks to Sir Osis of Liver for that :)

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 37
Re: TinyPortal Mod Issue
« Reply #14 on: February 18, 2019, 07:49:39 AM »
Another kind of "error" happening; Regular members and Guests can't see TinyPortal as you can see on the screenshot attached. Maybe I haven't looked through the settings well enough, but any suggestion/help would be appreciated.

Offline @rjen

  • Full Member
  • ***
  • Posts: 414
  • Gender: Male
Re: TinyPortal Mod Issue
« Reply #15 on: February 18, 2019, 08:15:55 AM »
I am a Guest and I can see the Tinyportal blocks... so it is more likely that there is a section in your forum where you have not activated the blocks for a certain membergroup.

If you want to get more familiar with TinyPortal, please spend some time reading the documentation...
https://www.tinyportal.net/docs/index.php

Specifically: https://www.tinyportal.net/docs/index.php?page=Troubleshooting-blocks

If you still cannot get the blocks to show please post in the support topic for TinyPortal, or post you question directly on the TinyPortal site...

https://www.tinyportal.net/index.php?action=forum
Running SMF 2.0 with Tinyportal 1.6.3 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal 1.6.3 at http://test2.fjr-club.nl/

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,909
Re: TinyPortal Mod Issue
« Reply #16 on: February 18, 2019, 11:25:36 AM »
I'm getting 404 at https://elite-duckerz.eu/forumsmf/, all forum installs are gone.  Did you move them?

Offline lurkalot

  • Sophist Member
  • *****
  • Posts: 1,264
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: TinyPortal Mod Issue
« Reply #17 on: February 18, 2019, 12:33:13 PM »
I'm getting 404 at https://elite-duckerz.eu/forumsmf/, all forum installs are gone.  Did you move them?

Was ok earlier. I also noticed TP installed and working. Maybe someone has fiddled with something.  ???

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 37
Re: TinyPortal Mod Issue
« Reply #18 on: February 18, 2019, 03:57:19 PM »
We have moved to a new sub-domain:
- https://forum.elite-duckerz.eu

Offline folioli

  • Newbie
  • *
  • Posts: 2
Re: TinyPortal Mod Issue
« Reply #19 on: February 26, 2019, 09:35:44 PM »
Was a resolution to this issue identified?

I am experiencing the same issue. During PHP version upgrade, I upgraded SMF to 2.0.15, had to uninstall TP due to incompatibility with PHP 7.x and when I tested installing TP 1.6.2, no warnings were issued but now the forum is unusable with the error
Code: [Select]
Unable to load the 'tp_above' template.