News:

Wondering if this will always be free?  See why free is better.

Main Menu

Attachments no longer readable

Started by ecotypes@verizon.net, August 31, 2020, 06:15:58 PM

Previous topic - Next topic

ecotypes@verizon.net

Upgraded from 2.0.11. 2.0.17

Database seems to have come over OK

Attachments are, at best, mangled.  I tried setting the Cookie per repair_settings suggestion.  No.  I tried setting it to match the old forum.  No.
However, I can load a new attachment and download it successfully.

Both new and old attachments are in the correct directory.

Something similar happened to user avatars.  Avatars uploaded by the old forum could not be loaded.  Avatars uploaded in the new version load fine.

Does anyone have any ideas of what the issue could be?  There are at least a thousand attachment, so I need a solution.

Thank you in advance. 

Arantor

Did you move servers during the upgrade?
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

ecotypes@verizon.net

Yes.  Completely different server.

Arantor

Please read https://www.simplemachines.org/community/index.php?topic=374178.0

In short: the way you downloaded them from the old server and uploaded to the new damaged them.

Fixing them without redownloading the original files correctly is borderline impossible and would have to be done forensically at the binary level. (=very time consuming, very expensive if it's even achievable; some kinds of files it is simply not achievable for)
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

ecotypes@verizon.net

Thank you!  I'll download and re-upload them again per this information.


jdgretz

Great link - solved a problem that was on my to-do list

jdg

ecotypes@verizon.net

The solution worked and worked well.  I would never have guessed that Filezilla would have changed that default.

Thanks!

Advertisement: