• Welcome to Simple Machines Community Forum. Please login or sign up.
January 17, 2022, 12:28:45 PM

News:

Wondering if this will always be free?  See why free is better.


[gelöst] Upgrade auf SMF 1.1 RC2

Started by Stasvde, December 23, 2005, 07:50:21 PM

Previous topic - Next topic

Stasvde

December 23, 2005, 07:50:21 PM Last Edit: December 30, 2005, 02:04:44 AM by noex
Hallo erstmal,

Ich wollte gerade mein Testforum upgraden wie gewohnt habe ich alle files aus dem upgrade - pack auf den Server geschoben.

und habe dann wie immer die "upgrade.php" ausgeführt nur dann bekomme ich folgende Fehlermeldung :
"The upgrader found some old or outdated language files.

Please make certain you uploaded the new versions of all the files included in the package, even the theme and language files for the default theme."

Was läuft da nicht ganz rund ?
Ich bin mir 100% sicher das ich alle Sprachen files für RC1 installiert hatte
Nobody is Perfekt.

noex

Du musst auch die deutschen Sprachfiles für RC2 installiert haben!

Diese gibt es leider noch nicht, du kannst also entweder deutsch entfernen und mit englisch Arbeiten. Oder du änderst in sämtlichen deutschen Sprachdateien den Text oben im Kommentar von RC1 auf RC2. Womit du aber ziemlich sicher Fehler im Fehlerprotokoll haben wirst, da ja dann doch einige Texte fehlen.

lg
noex
"Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

Stasvde

das komische  ist beim upgrage von meinem zweiten test system kommt folgender fehler zu tage :

Upgrading log system... Unsuccessful!

This query:
UPDATE Forumlog_boards
SET ID_MSG = 1
WHERE logTime >= 1114806424;
Caused the error:
Unknown column 'logTime' in 'where clause'

was sollte ich hier tun ?

beide systeme waren vorher auf RC1
Nobody is Perfekt.

noex

Gibt es denn in der Tabelle "Forumlog_boards" die Spalte "logTime" ?

Stimmd das Prefix?
"Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

clearly

December 24, 2005, 06:25:07 AM #4 Last Edit: December 24, 2005, 06:29:35 AM by clearly
Wirds denn überhaupt eine deutsche Sprachpaket für den RC2 geben?

Ach bin ich blind. Okay, vergesst die Frage. :-[

dieter4

ich denk erstmal nicht, weil Daniel D. dafür zuständig ist und er momentan nicht da ist/sein wird.

Daniel D.

Quote from: Dark_Neakro on December 24, 2005, 06:29:38 AM
ich denk erstmal nicht, weil Daniel D. dafür zuständig ist und er momentan nicht da ist/sein wird.
Die Dateien gibt es doch schon längst... ::) Leute, bitte schaut euch doch etwas mehr um auf der Downloadseite.

dieter4


Daniel D.

Für CM schon, er ist doch einer... Außer er meinte mit seinem Edit, dass er sie schon gefunden hat.

clearly

Als ich danach fragte, ob es überhaupt Sprachpakete geben wird, waren sie noch nicht verfügbar. Grudge hat vergessen, sie hochzuladen.

Ich habe dann editiert, aufgrund noex' Aussage
Quote from: noexDiese gibt es leider noch nicht
Logischerweise wirds also welche geben, aber es ist unklar wann.


Und als ich editiert hab, waren sie auch noch nicht verfügbar, die kamen erst später:
Quote from: Grudge on December 24, 2005, 07:42:26 AM
Note, the language files are now available - I had forgot to add them to the download page :o



Daniel D.


Stasvde

December 27, 2005, 04:07:46 AM #11 Last Edit: December 27, 2005, 04:11:41 AM by Stasvde
Ich habe den ersten fehler mit dem deutschen RC2 Sprachpacket behoben nun bleibt noch dieser Fehler :

Upgrading log system...
Unsuccessful!
This query:

   UPDATE smf_log_boards
   SET ID_MSG = 1417
   WHERE logTime >= 1135324763;

Caused the error:

   Unknown column 'logTime' in 'where clause'

Ich habe mir mal die Tabelle / Datenbank "smf_log_boards" angesehen , ich habe dort keine Spalte "logtime" gefunden.
Wie bekomme ich den Fehler weg ?
Das System ist seitdem im "Upgrade modus" ich kann auf das Forum nicht normal zugreifen.
Nobody is Perfekt.

ディン1031

lege mal die Spalte im SQL am ende dieser tabelle an... aber es schon seltsam das du garkeine drin hast... das ist sehr sehr kurios... normal dachte ich das die Standardmäßig mit drin ist ohne diese gibt es fehler ohne ende XD. Dann sollte der Fehler weg sein, aber ich finde es wirklich sehr seltsam :x
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Stasvde

ich habe die betreffende Spalte angelegt, aber keine veränderung
Nobody is Perfekt.

Stasvde

December 27, 2005, 04:45:47 AM #14 Last Edit: December 27, 2005, 04:52:41 AM by Stasvde
ich werde das ganze wieder in den anfangs zustand zurück setzen und noch mal von vorne beginnen.
beim Test Forum geht das ja glücklicherweise ohne das der normale betrieb gestört wird.  :)

Was muss ich tun wenn ich später das Theme "Babilon" nutzen möchte ?
Benötige ich dafür auch ein langaue Pack ?
Nobody is Perfekt.

Stasvde

Ich habe es jetzt nocmal ganz von anfang an versucht der Fehler bleibt.
wenn das eine standart Tabelle / Spalte ist wieso kam dieser Fehler nicht beim upgrade von 1.05 auf 1.1 RC1 ?
Nobody is Perfekt.

Stasvde

ich habe das ganze mal mit einem frisch instaliertem 1.05 Forum versucht ergebnis :

Upgrading...
Updating Settings.php... Successful.
Creating new tables and inserting default data...
    Creating "themes"... done.
    Creating "collapsed_categories"... done.
    Creating and verifying "permissions"... done.
    Inserting data into "permissions"... done.
    Creating and verifying "board_permissions"... done.
    Inserting data into "board_permissions"... done.
    Creating "moderators"... done.
    Creating "attachments"... done.
    Creating "log_notify"... done.
    Creating "log_polls"... done.
    Creating "log_actions"... done.
    Creating "poll_choices"... done.
    Creating "smileys"... done.
    Loading default smileys... done.
    Dropping "log_search" and recreating it... done.
    Dropping "sessions" and recreating it... done.
    Verifying "settings"... done.
Successful.
Converting activity logs...
    Converting "log_online"... done.
    Converting "log_floodcontrol"... done.
    Converting "log_karma"... done.
    Retiring "log_clicks"... done.
    Converting "log_notify"... done.
    Converting "log_errors"... done.
    Converting "log_boards"... Unsuccessful!
This query:

    SELECT lmr.ID_BOARD, lmr.ID_MEMBER, lmr.logTime
    FROM ACW2_log_mark_read AS lmr
    LEFT JOIN ACW2_log_boards AS lb ON (lb.ID_BOARD = lmr.ID_BOARD AND lb.ID_MEMBER = lmr.ID_MEMBER)
    WHERE lb.logTime < lmr.logTime;

Caused the error:

    Unknown column 'lb.logTime' in 'where clause'

Nobody is Perfekt.

ディン1031

Hast du diese frage eigentlich nicht mal versucht im Support Concern Berreich des Charter Members zu posten?

Gruß
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Stasvde

December 28, 2005, 09:50:56 AM #18 Last Edit: December 28, 2005, 09:53:48 AM by Stasvde
mittlerweile schon.

sie arbeiten dran

Ich hoffe ich kann mein Test -System und mein Hauptsystem bald wieder nutzen .

Solange der Support dran arbeitet kann ich ja nichts machen .
Nobody is Perfekt.

Stasvde

Test board läuft wieder.  :D

Danke für alle Tipps.

Mir gefällt die neue Optik von RC2 sie ist zwar ein wenig gewöhnungsbedürftig aber sonst ok.  :)

Wenn die die optik bis zum Final Release noch ihren feinschliff bekommt , ist alles wunderbar ( was die optik angeht)



Nobody is Perfekt.

Advertisement: