• Welcome to Simple Machines Community Forum. Please login or sign up.

Bug in Firefox 1.5 Causing Server Issues with SMF 1.1

Started by Grudge, January 20, 2006, 07:47:20 PM

Previous topic - Next topic

Prasad007

Quote from: Grudge on January 20, 2006, 07:47:20 PM
All,

It's come to our attention that a bug in Firefox 1.5 is causing some issues on SMF forums. The bug causes Firefox to time its javascript functions incorrectly, which in turn results in a page reloading in the background many, many times. It's possible that some hosts may incorrectly flag this as a Denial of Service (DoS) attack due to the ferocity of the calls. If you are having problems with your server, with many calls looking like: "index.php?action=keepalive", then it almost certainly is this Firefox bug - in this case we recommend you following the advanced information included in this post.

To minimize the risk to this happening when viewing an SMF forum, we've created a work around for the bug which should solve this issue. If you are using SMF 1.1 RC1 or RC2 we recommend you simply replace the current script.js file found in your Themes/default directory with the attached file. This does not affect uses running SMF 1.0.5 or lower.

Advanced Information:
If you are currently experiencing these issues, replacing script.js with the attached should solve them for all new users, but existing users may hold a cached version of the file in their browser. If you are still experiencing issues after changing the file, we recommend editing your copy of index.template.php in your themes and searching for:
Code:

$settings['default_theme_url'], '/script.js?


After this line, regardless of what currently follows the "?", simply add a "j", this will invalidate any cached data and force clients to refetch the document.

Regards,

Simple Machines
Thank you for the info!
Now i dunno if im experiencing this problem
but should i still do this anyway
i use Smf 1.1 rc2

dyrer


Prasad007


Grudge

Anyone with SMF 1.1 (regardless of version) should use this file as it only takes a new visitor with Firefox 1.5 to visit the site and you can find yourself in problems.
I'm only a half geek really...

Teknomancer

How do I know if I'm getting this problem? All my URLs appear correctly and not with a "?action=keepalive" or similar.. Does this mean I don't have it?

Anyway, I plan to replace the "js" file, so all I need to do is replace it and that will solve the bug?? Because you guys are discussing some CODE and stuff so I was wondering if i need to do anything BESIDES replacing the JS file.

Thanks. And the e-mail was such a good idea!! I wouldn't have noticed it otherwise!!!  Thanks a lot guys, its so nice that you care about your users to inform them thru email.
My SMF Forum:

Prasad007

Quote from: Grudge on January 22, 2006, 06:32:52 AM
Anyone with SMF 1.1 (regardless of version) should use this file as it only takes a new visitor with Firefox 1.5 to visit the site and you can find yourself in problems.
okay will do thanks!

Prasad007

i will have to make this change for each skin right?
or is this code only applicable to the default theme?

Grudge

Teknomancer,

If you have yet to experience any server problems just replacing the file should be fine. For people who have already experienced issues they need to make the code change.

Grudge
I'm only a half geek really...

Motorhead

I've replaced the file to be on the safe side, but don't think I've had any problems....

I'm use FF 1.5 have been for a while ?? pretty sure a few others are


huijaa

at ../Themes/default/index.templates.php i see

<script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/script.js?rc2p"></script>


What do i change it?
Dovenforum Nederland -- a forum for deaf people in the Netherlands --

Grudge

huijaa, literally just add a "j" after the question mark
I'm only a half geek really...

huijaa

Dovenforum Nederland -- a forum for deaf people in the Netherlands --

The_Devil

I'm puzzled. The bug is apparently caused by the combination of a specific version of FF and a specific version of SMF. SMF blames FF. FF has not confirmed it (I've done a search of their site and found only one 7-month old reference to SMF).

There is obviously an incompatibility between the two, but this could end up as a fruitless dialogue between deaf people, each saying the other is the cause. SMF has a workaround; why not simply add this workaround to a new RC build?

Now you see why I'm still with FF1.0 and SMF1.0.5 :)

H

Thanks, updating my site now :D

Also is this fixed in Firefox 1.5.01 RC1 (the next firefox minor release)?
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Daniel D.

Quote from: The_Devil on January 22, 2006, 07:18:36 AM
I'm puzzled. The bug is apparently caused by the combination of a specific version of FF and a specific version of SMF. SMF blames FF. FF has not confirmed it (I've done a search of their site and found only one 7-month old reference to SMF).

There is obviously an incompatibility between the two, but this could end up as a fruitless dialogue between deaf people, each saying the other is the cause. SMF has a workaround; why not simply add this workaround to a new RC build?

Now you see why I'm still with FF1.0 and SMF1.0.5 :)
Read your post and say who is starting this fight... ::) We told the user about the error but didn't cry around etc. - instead we post a fix and you're not satisfied? What do you want? It helps the users so stop talking this way.



Grudge

huijaa,

Either version.

The_Devil,

This is not about compatibility between SMF and FF - but about a bug in Firefox that adversely affects SMF. Firefox would not have SMF listed in their bug list as it's not a flaw in SMF that causes this bug - it's a problem with a very popular timing mechanism. The two important points to note are:
1) The bug in Firefox is linked to in my original post in this topic (Note the link under the word "bug")
2) The reason it only affects SMF 1.1 and not SMF 1.0.5 is because we added a new feature into SMF 1.1 to stop session timeouts. This feature uses javascript to ping the forum every 2 minutes to keep the session alive. The problem is that Firefox 1.5 has a bug in it's timer that means instead of running every 2 minutes, it does it many times a second - this effectively is a DoS attack from the users browser. The fix we've releases puts some extra javascript around the timer to counteract Firefox's problem.
I'm only a half geek really...


Prasad007

i added the j
it says this now
QuoteUnable to load the 'main_above' template.

Advertisement: