• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 09:25:21 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Bug in Firefox 1.5 Causing Server Issues with SMF 1.1

Started by Grudge, January 20, 2006, 07:47:20 PM

Previous topic - Next topic

DrDom

Quote from: The_Devil on January 22, 2006, 07:18:36 AM
Now you see why I'm still with FF1.0 and SMF1.0.5 :)

If everyone was to simply use FF1.0 and SMF1.0.5, as you do, to avoid any type of error/bugs etc, then there would never be any kind of advancement, everything would just remain stagnant, is that what you would like to see?  or would you prefer to see more reliability, features and progress?

I think that it has clearly been demonstrated that the developers of smf have indeed got their fingers on the pulse when a fix was released so quickly.

To the all the developers I congratulate you on you hard work and dedication.


MacGig

you mention put it in the default directory. what If im not using that theme??? do I still need this file?

Grudge

macgig, yes, put it in the default directory - all other themes get that file from the default directory.

Prasad007, you must have added it in the wrong place :) Can you post the line you changed?
I'm only a half geek really...

nokonium

I'd had server problems and I know one of the admin team always uses FF. So I've updated the script.js file on the server and also in my PC copy of the RC2 install files. Fortunately all my themes are based on the NDT and all I had to do was alter the default index.template and one copy with the modifications for all the others.

Thanks



Prasad007

Quote from: Grudge on January 22, 2006, 10:25:08 AM
macgig, yes, put it in the default directory - all other themes get that file from the default directory.

Prasad007, you must have added it in the wrong place :) Can you post the line you changed?
i use helios multi for rc2
heres the line:
Quote<script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/script.js?jrc1"></script>
after i restored to the default i.e. deleted the j
it still gives the error now!! :( :(

Grudge

Parasad, you must have unwittingly edited another line as well - as that j is no problem. Maybe try modifying a new heliod index.template.php file, if you're really stuck email me the one with the error and I'll email it back (smf@mattwolf.co.uk)
I'm only a half geek really...

Prasad007

ill try reuploading a fresh copy of that file and retry
ill keep you updated
but im sure i did it correctly

MacGig

thanks for the help grudge, and everyone. great support here. ;)

Prasad007

i tried again
it worked when i uploaded a fresh copy
but again when i added a j after ?
i get:
QuoteUnable to load the 'main_above' template.


please help!!

Kindred

Prasad...

What editor are you using to make this change?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Prasad007


Grudge

I'm sure notepad is messing it up somehow. If you wish to send me the file unmodified I'll open it with UltraEdit and send it back.

EDIT: Or you could of course use the editor within the admin centre itself?
I'm only a half geek really...

Prasad007

how can notepad or anything mess up anything for adding a simple j
i did it correctly im sure

Daniel D.

Quote from: Prasad007 on January 22, 2006, 11:24:46 AM
how can notepad or anything mess up anything for adding a simple j
i did it correctly im sure

Before this topic goes on another page, please send him the file and let him try it or use another editor.

Prasad007

Quote from: Daniel D. on January 22, 2006, 11:27:19 AM
Quote from: Prasad007 on January 22, 2006, 11:24:46 AM
how can notepad or anything mess up anything for adding a simple j
i did it correctly im sure

Before this topic goes on another page, please send him the file and let him try it or use another editor.
okay
i uploaded it @ http://tech-ultimatum.uni.cc/Files/index.template.zip
zipped version

jough

This bug caused me a great deal of time and expense in tracking down last week.  Two Apache modules, mod_security and mod_ddosevasive will likely see anyone using SMF1.1 with Firefox 1.5 (as I am and a number of my board users are) as an attack and not send data to them.

I can't begin to elaborate on how frustrating it was to try to find out what was wrong with the server, and am not relieved to find that SMF was the culprit all along.

Pinging the server to keep the connection alive... for a message board?  Why, oh why would this be necessary?  It's not like it's a live chat.

Is this a "feature" we can turn off in the admin control panel, or do we have to edit the script.js file to remove it?

With the feature, SMF is essentially a server attacking tool.

Compuart

Quote from: jough on January 22, 2006, 11:35:58 AMI can't begin to elaborate on how frustrating it was to try to find out what was wrong with the server, and am not relieved to find that SMF was the culprit all along.
SMF's script was alright in this case, just the execution by Firefox 1.5 wasn't.

QuotePinging the server to keep the connection alive... for a message board?  Why, oh why would this be necessary?  It's not like it's a live chat.
No, it's not a live chat. That's why the server is only pinged each 20 minutes. But it does prevent frustration about having worked on a message for an hour and then finding out your session timed out.

QuoteIs this a "feature" we can turn off in the admin control panel, or do we have to edit the script.js file to remove it?
The easiest way would be to remove it from the script.js.

QuoteWith the feature, SMF is essentially a server attacking tool.
I don't agree, pinging 3 times an hour like it's supposed to, is no server attack imho.
Hendrik Jan Visser
Former Lead Developer & Co-founder www.simplemachines.org
Personal Signature:
Realitynet.nl -> ExpeditieRobinson.net / PekingExpress.org / WieIsDeMol.Com

diegolyanky

January 22, 2006, 12:43:42 PM #57 Last Edit: January 22, 2006, 12:47:42 PM by diegolyanky
Must I make modification with the " j " in default theme only or in all my themes ?




SMF ... SimpleMachines ... Simple, but complete if you want it ;)

Compuart

That modification should be done in all themes, though it's only to prevent the old script from being cached. Browsers will refresh the cache from time to time as well.
Hendrik Jan Visser
Former Lead Developer & Co-founder www.simplemachines.org
Personal Signature:
Realitynet.nl -> ExpeditieRobinson.net / PekingExpress.org / WieIsDeMol.Com

diegolyanky

Ok ... Thanks for instant reply ....

But:

This was on my original index.template.php :

<script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/script.js?rc2p"></script>


And this is changed:

<script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/script.js?jrc2p"></script>

Is that ok ?
SMF ... SimpleMachines ... Simple, but complete if you want it ;)

Advertisement: