• Welcome to Simple Machines Community Forum. Please login or sign up.
December 01, 2021, 11:12:26 AM

News:

Wondering if this will always be free?  See why free is better.


Custom Profile Field Mod

Started by winrules, March 30, 2006, 02:21:25 PM

Previous topic - Next topic

entwistlej

Yes My custom fields don't appear in posts even when configured to do so. I'm running 1.1.1

winrules

entwistlej - Look at the first post in this topic.


winrules
SMF Developer
               
My Mods
Please do not PM me for support.


nolageek

January 14, 2007, 01:30:21 AM #802 Last Edit: January 14, 2007, 02:00:50 AM by nolageek
Great mod.  Any chance you could add an field where users can pick multiple items? (Say, from a list of 10 options, they can pick however many apply to them.)

Also, I'd like a "Label" field, which will let us add a label (without giving the user anything to choose from) so we can separate our fields into groups. (This would also add a horizontal rule.)

Also, not sure if this as has been reported, but I've noticed a odd bug when creating multiple selection type fields.  If I create several fields, they all have the same amount of options after saving. What I mean is, if I create a field with say, 5 options... then create a second field with 2 options, the one with 2 options gets saved with 5 options, with the remaining 3 options filled from the first field.

Example...

if I create a few fields that ask:

What is your favorite color?
Options: red, orange, blue, green, black, yellow

What is your favorite Number?
Options: one, two three, four

What is your favorite game?
Options: Hopscotch, Badminton, Checkers


When I go to answer them in my profile, I get the following:

What is your favorite color?
Options: red, orange, blue, green, black, yellow

What is your favorite Number?
Options: one, two three, four, black, yellow

What is your favorite game?
Options: Hopscotch, Badminton, Checkers, green, black, yellow



After I go back, and open each field and delete the incorrect options, everything seems ok.. just wanted to bring it to your attention.

abc-survivors.net

I loved this mod, had it running with my RC2 forum.  I've finally updated my forum to 1.1.1. I uninstalled this mod before I did the upgrade.

Now I and am wondering how do I get the new mod version and keep the old custom profile fields and data that were in my forum?

Thanks!
Mary

DenDen60

January 15, 2007, 09:08:08 PM #804 Last Edit: January 17, 2007, 05:57:40 PM by denden60
For one reason or another, when  I want to install this mod, it doesn't give me the right directory. I think it's because I imported the database. Where is the information for the uploade drectory stored so that I can change them

This is what is tells me now. I should change 2,3,4 and 5

1. Execute Modification ./Sources/ModSettings.php Test successful
2. Execute Modification /home/denis/public_html/....../Themes/default/Profile.template.php Test successful
3. Execute Modification /home/denis/public_html/... .../Themes/default/Display.template.php Test successful
4. Execute Modification /home/denis/public_html/... .../Themes/default/PersonalMessage.template.php Test successful
5. Execute Modification /home/denis/public_html/... .../Themes/default/Register.template.php Test successful
6. Execute Modification ./Sources/Register.php Test successful
7. Extract File ./Sources/CustomProfile.php 
8. Extract File /home/denis/public_html/... .../Themes/default/languages/CustomProfile.english.php 



SvenJTD

Sorry to bulge in like this, but is there any way I can use Custom Profile so I can make birthday mandatory but so it is linked to the calendar - so it can display when someone has a Bday ?

Thanks
New here - help

gemigene

January 16, 2007, 05:55:48 PM #806 Last Edit: January 16, 2007, 08:06:25 PM by gemigene
For some strange reason, I can only input text boxes. I want to add dropdown fields and checkboxes but to no avail.

Installation went without a glitch.

SMF 1.1.1 with Dilber theme (I also tried it with the default theme and ditto)

???
"Religion is metaphysical statism. I will be ruled by no man on earth, nor by any god in heaven"

neskiairti

January 17, 2007, 05:21:00 AM #807 Last Edit: January 17, 2007, 05:51:42 AM by neskiairti
im having an odd problem, im trying to add a large field..
2000 characters possible.. but when i do, i hit submit in the edit profile screen.. and, it just hangs there.. then gets a simple "page cannot be displayed" error.. as if the server sits there, not noticing..

this is likely a problem with the settings, or SMF, but, is there a way to circumnavigate it?

I do have annother problem though..
i am trying to make a selection field.. >.> and i accidentally made to many.. well, so i go to re-create.. and it says "Session verification failed. Please try logging out and back in again, and then try again."
so i delete it.. and try to remake it.. well its stuck.. every selection field i make (and move up) ends up with the same options, and imputs, as if they are all the same one, -.- its pissing me off, cause even if i use it, it doesnt work! its an empty dropdown menu..
Moo!

do NOT milk the bull!

Tanix

If I create a custom profile field for 'City', say - how would I get it to show in Profile Forum Information after the 'Location' field?

Also, say I create a number of custom profile fields, what would I need to do to have them all show on a new tab instead of at the bottom of Profile Forum Information?

szinski

Quote from: mark7144 on December 13, 2006, 09:56:37 AM
I really love this mod but it could just be me but the administration side of it seems very buggy (on my non-default theme).

Adding a new field doesn't happen unless I first click 'Add Field' then uncheck one of the other fields, then click save and then I assume I should have them all checked again.

The same process has to happen if I try and move the position up or down.

Also once getting it to move up or down, all of my profiles used the same description from another one.

Same problem here. Sometimes it takes multiple clicks to get a new field added. Reordering is also giving me major headaches.


Cookiemonster

hi i've got a problem too, i just downloaded the new version of custom profile field mod from the smf mod site
i installed it without problems on smf1.1.1
but normally i should see this mod under features and options,
well here's my problem you see, i don't see this at all...
so i can't add any extra fields to the profiles...

should i reïnstall it????
btw: i'm using smf 1.1.1 in dutch
My Forum [nofollow]
[nofollow] [nofollow]

bruce marusich

This is a great mod and works fine on my board. I do have a question though, about how to search for the data held in the custom fields. The custom fields I have are first name and last name. How can I search in the admin area for these custom fields? What do I have to mod, so that just  the admins can see the real
first and last names, or any other custom field info?

Thanks for a great mod!

Cookiemonster

ok kinda solved it, if i change my settings to english i can use it, so problem solved, btw: great product!!!
My Forum [nofollow]
[nofollow] [nofollow]

neskiairti

so anyone want to give me a solution to my problem here? i mean, i cant add anything with a drop down select now!
Moo!

do NOT milk the bull!

JamesWC

I'm using 1.1.1, and it seems that when I reorder my custom fields they lose their descriptions.

samames

I think this may be related to calimarinas post but am not sure, i have this mod now uninstalled and i cannot see my posts, instead i get this error:

Fatal error: template_main() [function.require]: Failed opening required '/x/x/x/forums/Sources/CustomProfile.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in
/x/x/x/forums/Sources/Load.php(1744) : eval()'d code on line 372

thanx in advanxce

ps: smf 1.1.1
Firefox 3 user. Mac user. Pc user.

Snape

Quote from: gemigene on January 20, 2007, 06:22:32 PM
Kinda looks like the developer lost interest in this project, doesn't seem to visit this thread much.

I asked a simple question and even sent a PM but to no avail:

QuoteFor some strange reason, I can only input text boxes. I want to add dropdown fields and checkboxes but to no avail.

Installation went without a glitch.

SMF 1.1.1 with Dilber theme (I also tried it with the default theme and ditto)

Update, I reinstalled SMF and wonder if I should give this MOD another try but using the default template only...

I don't like to criticize but look at how many questions are left unanswered, what gives?
Gemigene
???
His last post is only a page back...he's answered a ton of questions to date, I'm sure he'll get back to you eventually.  You sure you PM'ed the right guy (winrules)?

winrules

I'll try to answer the unanswered questions tomorrow.

Please understand that I have not lost intrest in this project. I am currently developing a new version of the mod (4.0) which is a complete rewrite. I am also planning on starting a support site for my mods (though this might not happen so no guarantees). I know the current verison of this mod is quite buggy. That is why I am rewriting the entire mod and how it stores its data. I won't be making any more bug patches or adding new features (with the exception of security patches if issues arise) to the 3.x line.


winrules
SMF Developer
               
My Mods
Please do not PM me for support.


Tanix

Quote from: winrules on January 20, 2007, 11:09:35 PM
I am currently developing a new version of the mod (4.0) which is a complete rewrite.

Looking forward to it. Do you have a list of new features you're currently planning to include in 4.0?

Advertisement: