News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

SMF 1.1 Release Candidate 3 is available!

Started by Thantos, August 19, 2006, 04:12:52 PM

Previous topic - Next topic

Gary

Quote from: SinekSekiz on October 28, 2006, 10:10:02 PM
I would like to ask you about a tool which is able to convert SMF 1.0.8 DB backups to SMF 1.1.RC3.

We do. It's called upgrade.php ;) Download the UPGRADE package for 1.1 RC3 and simply overwrite all the files for 1.0.8 with those for 1.1 RC3. And then run upgrade.php in your browser.

-AwwLilMaggie
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

SinekSekiz

#481
Happy Halloween guys (and girls of course : ))

Hey is this a new theme that you do not like to share whit us? Shame on you. >: [ I like this you know. It is kind of cute.

Quote from: AwwLilMaggie on October 28, 2006, 10:33:40 PM
Quote from: SinekSekiz on October 28, 2006, 10:10:02 PM
I would like to ask you about a tool which is able to convert SMF 1.0.8 DB backups to SMF 1.1.RC3.

We do. It's called upgrade.php ;) Download the UPGRADE package for 1.1 RC3 and simply overwrite all the files for 1.0.8 with those for 1.1 RC3. And then run upgrade.php in your browser.

-AwwLilMaggie

Thanks for the reply AwwLilMaggie.

I have been messing whit that little bugger (upgrade.php) since 5 days know. I had every kind of trouble. I had use your search engine for like couple of thousends times. I even learned how to use Apache and phpMyadmin. My PHP skills had another step in to future. But at the and what did I have? Nothing.

Well I found a little bug tough? It is a security issue about installation step=0. I will be glad if you give me an address that I can send it...

OK I have talked too much (AGAIN >: [) I am coming to my point.

Since I have mess whit my SMF 1.0.8 so much it has become really unstable. Themes, Mods, TP and every single kind of other stuff made it like a mess. What I would like to is clean everything and install a fresh SMF 1.1.RC3. Before this as I said I tried everything on my localhost and a subdomain on my server... All I had was tons of errors.

I see 2 ways to sort my bloody problem out;

1) Converting my DB to SMF 1.1.RC3 supported or at least I would be able to import my backups to this new DB after installation.

2) Throw my DB and all my work (and 500 other people work) in to bin and start to a new beginning with SMF 1.1.RC3.

I will be much appreciated if you guys help me on the 1st way...

Happy Halloween guys (and girls... (is there any girl in this forum? : DDD))

TRICK OR TREAT!!!!
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

Dannii

"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

SinekSekiz

Quote from: eldʌkaː on October 29, 2006, 01:21:42 AM
What errors does upgrade.php tell you?

Wow that was quick... I do not understand why people keep complaining about your response time... : D

Well I had mostly all problems after I install the forum.

FiFirstt gave me an error like this;

8: Undefined index: show_sp1_info
Dosya: /mounted-storage/home17b/sub003/sc19217-JUWS/deneme/Sources/BoardIndex.php
Satýr: 399

Then I searched the board and I uploaded Load.php

Then it gave me another error that I can not recall it anymore : ) I lost the track betven 20th and 50th error : DDD

Now I can not even install it gives me this on step=2:
Fatal error: Call to undefined function: cache_put_data() in /mounted-storage/home17b/sub003/sc19217-JUWS/deneme/Sources/Subs.php on line 708

I am really sorry to ruin your Halloween day whit such troubles....

PS: This themes spell check has got a problem (or I am the problem here : ((( )...
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

SinekSekiz

Sorry to flood but if you like you can have a look at it on:

http://deneme.thegamestyle.com

I can give you any details if you need to.

Thanks again.
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

JayBachatero

Seems like some of your files are corrupted.  Reupload your source files.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

SinekSekiz

You know what, if any other person talk about you guys that you are avoiding them I will kick their ass. I was like "oh I send the post now and I can have a look tommorrow night..." but now I can not go to sleep because you are so willing to help. : D

Thank you very much guys. I am appreciated...

OK I will upload the source files again but would you like me to upload them from RC3 Install or RC3 Upgrade?

And one another thing just hit me now. I never tried to upgrade my actual site... What I did is Installed a new forum with in localhost and sub domain with SMF 1.0.8 and connect it to my backup DB then I have tried to upgrade either install 1.1.RC3. I could not risk to install it straight away to my forum. Is this might be the actual problem?

I will be really angry to myself if it is because of this. I have no right to waste your time...
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

JayBachatero

You need to run upgrade.php since the upgrade will make all the necessary changes.  Also need to upload the upgrade files not install.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

SinekSekiz

#488
Quote from: JayBachatero on October 29, 2006, 02:03:58 AM
You need to run upgrade.php since the upgrade will make all the necessary changes.  Also need to upload the upgrade files not install.

Well I did. And I did upgrade the forum. But afterwards everything fall apart. When I try to change forum language It gave me "Unindetifed index error on Admin.php". Then I had it back to english again. But this time I was not able to acces to some of my boards because it gave me another error like "bg.ban_group does not exist" and it was infront of me I was looking at the damn ban group on phpMyadmin...

May be I should try it on my actual forum huh. What you say?
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

JayBachatero

I say replace ALL of the files.  Seems like you still have outdated files.  Might want to use another FTP client.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

SinekSekiz

Quote from: JayBachatero on October 29, 2006, 02:14:48 AM
I say replace ALL of the files.  Seems like you still have outdated files.  Might want to use another FTP client.

8: Undefined index: lang_character_set
/mounted-storage/home17b/sub003/sc19217-JUWS/deneme/Sources/Load.php
1408

Well this is new.

I had this one first time : D. Ok Since my server has got an Unzip option what I do is delete the all folder and unzip it in a second.

Well After I delete Themes, Source, Packages, Avatars folders and unzip the smf_1-1-rc3_upgrade.zip to top of everything I had the error upthere...

Then started the upgrade.php and it has given me this (I think this is 5th time I had this in last two days);

"The upgrader found some old or outdated files.

Please make certain you uploaded the new versions of all the files included in the package.

Click here to try again."

I do not know what to do...
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

JayBachatero

Use a real FTP client.  Seems like the archive tool that you are using is corupt.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

SinekSekiz

Quote from: JayBachatero on October 29, 2006, 02:33:21 AM
Use a real FTP client.  Seems like the archive tool that you are using is corupt.

Might it be. But I had the same prob on my localhost aswell..

Well if you say so I will give it a shot. But the connection speed that I have wont allow me to do it at least in next two hours... I think I will see you guys tommorrow. I had to go to work whitout any sleep... (Again.)

Thank you very much for your helps till now...

I will see you guys (and girls... (I bet there is one girl there... : D )) when I come back.

Bye. (For now... : DDDDD)
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

Harzem

Quote from: SinekSekiz on October 29, 2006, 02:39:44 AM
I will see you guys (and girls... (I bet there is one girl there... : D )) when I come back.


Be sure there are many, including one of the project managers.

SinekSekiz

Quote from: HarzeM on October 29, 2006, 03:21:26 AM
Quote from: SinekSekiz on October 29, 2006, 02:39:44 AM
I will see you guys (and girls... (I bet there is one girl there... : D )) when I come back.


Be sure there are many, including one of the project managers.

We can't simply runaway from them can we? They are everywhere... : DDD

OK guys I uploaded the files via CoreFTP Lite Edition (sorry not enough money for the Pro Edition : D)...

Still same error.

I think I have to do what I had to before... I will copy my forum one to one to this new subdomain. Then I will run the repair_settings.php. Then I will make sure every single thing is ruining proply...

After that I have an exact copy of my site (including mods, TP, and My Themes) I will upload SMF 1.1.RC3 upgrade and I will run it and I will be able to give you a step by step guide of "How can you mess a good site up in 5 Steps".. : DDD

I guess what I have written till know was "How can you mess a good site up in 1000 ways"... : DDD

OK see you when I am done...
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

Gregory

Can I just say it would be really really nice if 1.1 final was out before christmas because then I could use my time of work to mash it up and move my site(s) to it.
A new years day release would be quite annoying because then I'd probably only have the day after to play.

Hope someone that has a say reads this (by 15th december would be wonderful).  :D
Ant's Life - My morpg that is integrated with SMF for good communications between players and staff.

mycroft

Speaking of 1.1 Final...

Is there a roadmap for SMF development anywhere?  I considered PMing one of the SMF staff, but everyone has "DON'T PM/EMAIL ME FOR SUPPORT!" in their signature.

Having at least some general idea of when releases are planned and features planned for each would help those of us who of are a detail-oriented bent plan our businesses somewhat more logically.

Any information would be appreciated.


SinekSekiz

#497
Hi Guys (and girls).

I have downloaded all my board to my local host. I have backup-ed my DB and import it to my local mysql server. Then I have run the repair_settings.php. Then I set my themes up and set the forum language to English. And when I finished I had exactly same version of my forum but offline.

All of this took my almost 2 days. (I have a really slow connection. Better than dial-up though but still slow)

After all this I have run the upgrade.php and in the process I had the error in the picture.



What is this ban_group I do not know. I have tgssmf1_banned in my DB. By the way my prefix is "tgssmf1_" I do not think this is the problem so what is the problem?

Thanks for replies.
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

SinekSekiz

#498
I think there is a problem whit my DB. Because it does not have so many keys. When i jump to another steps it gave me some more errors about my DB. But I have no problem whit SMF 1.0.8. So my DB is normal. I send to you what tables do I have in my DB.





  tgssmf1_attachments
  tgssmf1_banned
  tgssmf1_board_permissions
  tgssmf1_boards
  tgssmf1_calendar
  tgssmf1_calendar_holidays
  tgssmf1_categories
  tgssmf1_collapsed_categories

  tgssmf1_log_karma
  tgssmf1_log_mark_read
  tgssmf1_log_notify
  tgssmf1_log_online
  tgssmf1_log_polls
  tgssmf1_log_search
  tgssmf1_log_topics
  tgssmf1_membergroups

  tgssmf1_settings
  tgssmf1_smileys
  tgssmf1_themes
  tgssmf1_topics
  tgssmf1_tp_articles
  tgssmf1_tp_blocks
  tgssmf1_tp_data
  tgssmf1_tp_dlmanager

  tgssmf1_im_recipients
  tgssmf1_instant_messages
  tgssmf1_log_actions
  tgssmf1_log_activity
  tgssmf1_log_banned
  tgssmf1_log_boards
  tgssmf1_log_errors
  tgssmf1_log_floodcontrol

  tgssmf1_members
  tgssmf1_messages
  tgssmf1_moderators
  tgssmf1_permissions
  tgssmf1_poll_choices
  tgssmf1_polls
  tgssmf1_sessions

  tgssmf1_tp_settings
  tgssmf1_tp_variables
Thanks.
You know you want to use it... So use it.

Dulce et Decorum est Pro SinekSekiz Mori

We are all figures. For men it's the money in your bank. For women it's the cup size of your boobs.

Lionmane


Hi!

I downloaded "smf_1-1-rc3_install.zip" and attempted to install it on my server.

1) I downloaded the zip file
2) Unzipped it
3) Uploaded it to my domain in a folder named SMF

At this point, the instructions say to run the "install.php" in the forum's root directory.  I couldn't find "install.php" anywhere.

Any ideas?  Thanks!

mw

Advertisement: