• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 08:42:39 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


SMF 1.0.9 and patch for 1.1 RC3 released

Started by Compuart, October 29, 2006, 05:57:14 AM

Previous topic - Next topic

CGawker

Error for me: 2. Execute Modification ./changelog.txt Failure

(install via admin panel)

...what should I do?


Compuart

If changelog.txt is the only file for which the modification fails, there shouldn't be a problem. In that case you can just continue the patching.
Hendrik Jan Visser
Former Lead Developer & Co-founder www.simplemachines.org
Personal Signature:
Realitynet.nl -> ExpeditieRobinson.net / PekingExpress.org / WieIsDeMol.Com

caipirinha

The search still doesn't work (after update to RC3)

Can anyone tell me if the RC2 Search.php is affected by the xss bug?

SleePy

I believe so.. Since not many changes in rc2 to rc3 it would be there.. And since it had to patch the 1.0 line I am guessing it is in all versions...
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

manji

October 29, 2006, 07:11:20 PM #44 Last Edit: October 29, 2006, 07:16:04 PM by manji
Hi,

I'm using 1.1RC3 with TP 0,95 and I get this error:

                    Type                    Action                    Description   
1.   Execute Modification   smf_1-1-rc3-1.mod   Modification parse error

So... what gives?  ;D

Should I download updated_files_SMF_1-1-rc3-1.zip and upload it manually?

Cheers!   

SleePy

Redownload the file and try again..

I was able to upgrade just fine and I run TP..
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

manji

Hi,

So I downloaded updated_files_SMF_1-1-rc3-1.zip and uploaded the files. All is working OK, but it still says 1.1RC3 in the bottom, not 1.1RC3-1.

And the reminder on the package tab is still there. Should I do smth to remove that or just leave it :)

Cheers!

Debbie2

Does 1.0.9 support FULLTEXT search? Or do I need 1.1 RC3 for that?

    [/size][/list]
    [/

    FunPika4

    changelog.txt had no problems for my board.

    Also perhaps you should update your tinyportal to 0.9.6 manji.

    georgepdog

    Quote from: dphreak on October 29, 2006, 01:08:09 PM
    I just downloaded the updater-package manually from the website, the one for 1.0.9 and an error (old files) occurs, in the included upgrade.php the version has been set to 1.0.8...

    I updated from the package manager.  Everything went smoothly, but then, we had an issue with one of our mods.  It mentioned the following:

    Unknown column 'mem.pmAutoRespondAwayMsgActivate' in 'field list'
    File: /home/arsport1/public_html/smf/Sources/Load.php
    Line: 476

    Note: It appears that your database may require an upgrade. Your forum files are currently at version SMF 1.0.9, whereas your database is at version SMF 1.0.8. It is recommended that you execute the latest version of upgrade.php.

    So, I checked and noticed that all of the files were the ones updated by the package manager today.  However, since I ran it through the package manager, I did not run the upgrade.php separately.  So, I uploaded the upgrade.php to the site and ran it.  I got the same error message as above quote from dphreak with the exception that my forum shows it is at 1.0.9.  What can I do?  Or should I do anything?

    Fiery

    Thanks for the update, I appreciate all of your hard work!  ;D

    licheng

    I download update files to upgrade from SMF 1.0.8 to SMF 1.0.9, but got a messenge something like

    QuoteThe upgrader found some old or outdated files.

    Please make certain you uploaded the new versions of all the files included in the package.

    Click here to try again.

    I have tried upgrade files to upgrade SMF, but got the same messenge.

    Oh, yes, I use the default theme without any modification, and use English as default language.

    Any suggestion?

    Thanks. :)

    Macia Paladin

    Quote from: SleePy on October 29, 2006, 11:37:26 AM
    Oohh.. Finally..

    I have known about the search exploit for almost a week.. good thing its finally fixed.. ;D

    What is with all the bugs? 1.1 RC2 had to have 2 patches and RC3 has had 1 so far..  :-[ makes me feel like phpbb... >:(

    I tried doing a search fro an answer, but I'm not having much luck. What do you do if you were already hacked with the Search exploit BEFORE the patch came out? My forumers are getting tired of my "forum reboots".

    manji

    Quote from: funpika on October 29, 2006, 08:26:00 PM
    changelog.txt had no problems for my board.

    Also perhaps you should update your tinyportal to 0.9.6 manji.

    Thanks for the head's up! They seem to be having some trouble with it, though! :)

    Quote from: manji on October 29, 2006, 07:49:11 PM
    Hi,

    So I downloaded updated_files_SMF_1-1-rc3-1.zip and uploaded the files. All is working OK, but it still says 1.1RC3 in the bottom, not 1.1RC3-1.

    And the reminder on the package tab is still there. Should I do smth to remove that or just leave it :)

    Cheers!

    Any help with this?

    Cheers!

    zeniitti

    It gave me this error :(

    Fatal error: Call to undefined function: tp_loadtheme() in /home/xxxxx/domains/xxxxx/public_html/Sources/Load.php on line 660

    Possible error with theme? Running 1.0.8 + 0.9.6beta TP. Didn't try default theme though...

    ApocryphA

    Hi,

    I'm running 1.0.7.  The host doesn't seem to allow me to use the Package Manager, so I'll have to upload the upgrade files manually.  Now do I need to install the 1.0.8 first, or should I just go ahead with 1.0.9 directly?

    Thanks!


    Dannii

    If you're going to use the upgrade package, you can just skip straight to 1.0.9
    "Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."

    SuicideOption

    Apparently I'm stupid, or EXTREMELY new at this...but I can't find the patch in the package manager.  I've looked for about 20 minutes, but there's so many mods. I may just be overlooking it...

    manji

    Quote from: SuicideOption on October 30, 2006, 09:33:12 AM
    Apparently I'm stupid, or EXTREMELY new at this...but I can't find the patch in the package manager.  I've looked for about 20 minutes, but there's so many mods. I may just be overlooking it...

    When you click on the Package tab in the Admin section of YOUR forum, it should show right up :)

    Cheers,
    J

    SuicideOption

    Thank you so much, I was going to drive myself crazy.  I was actually going into the package server and scrolling through page after page of mods.

    Advertisement: