• Welcome to Simple Machines Community Forum. Please login or sign up.
January 26, 2022, 03:33:39 AM

News:

Wondering if this will always be free?  See why free is better.


What is repair_settings.php?

Started by [Unknown], October 13, 2004, 12:54:38 AM

Previous topic - Next topic

[Unknown]

Quote from: smitheejr on April 03, 2005, 01:05:31 PM
edit:    Re-reading the upgrade page it says I can use the update zip as this is an old board....is it correct that I download this zip, extract it and then ftp all of these files over the existing ones?  This won't ruin any of the current posts or categories?   Then online I pull up update.php?  Am I missing any steps or is there something else I should be doing?  Thanks.

You've got everything ready to go.  Upload the upgrade.php file and run it.... that's it.  This won't ruin any posts, members, categories, topics, boards, smiley sets, themes, or anything else.

-[Unknown]

smitheejr

Worked like a charm!  Thanks, everyone!

soulmanpete

Nearly  :)there run the program but cant save get
Settings.php cannot be written to by your webserver. Please modify the permissions on this file to allow write access.
Change the permissions in my file manager nothing happens
:(

[Unknown]


Drifter

Ok,
This really works  ;D i tried this early today but i guess i was doing something wrong as i just tried it again and hey presto i am up and running again. Thanks for this post.

dæmon

Will this work with the 1.1 public beta?

[Unknown]


allfripou

It would be nice if repair_settings sets correctly also the path of the themes, at least the default one.

Would it be possible?

[Unknown]

The default theme is editable by repair_settings.php.

-[Unknown]

Lisah

I just finished moving my forums to a new domain name. Following the instructions (download,edit settings.php upload run repair_settings etc...)

Now when I try to see my forums I get an error MSG saying....

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.


I have checked and my database is up and running, so I'm not sure what the problem could be. If it helps I'm running 1.1 Beta 3 Public.

Lisah

I got it. I had missed an option in the repair_settings.php.

cirkit

woohoo this Repair_settings.php really does work....now smilies/avatars work again  :D

mecane

Thank you very much for this job.
after a problem with a mod i have hab some problems with the foum.
repair_settings.php do a great job !

you save my afternoon :) let's go see the sun ;)




eye97

October 28, 2005, 07:29:17 AM #33 Last Edit: October 28, 2005, 07:35:37 AM by eye97
I also have this problem:

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

And used this repair setting file and everything was correct in there. But I still get this message. Any ideas?

Also when I save settings, I get this: Some settings are not being shown because the MySQL connection information is incorrect.

I have entered the right name and password and local host is 127.0.0.1 and the correct database info.

rickyreter

its says not a valid win32 application...... :(

xenovanis

You can't run it as a windows application. You need to  upload it to your forumlocation and point your browser at it, like http://www.youdomain.com/forum/repair_settings.php
"Insanity: doing the same thing over and over again and expecting different results."

eragonn

well...I did try it, but I get this error :

Queryless URLs:
Value not found!

Sheepy

Don't worry nothing is wrong.  By SMF 1.1 it is on by default. Or so says the changelog.

eragonn

But the forum is still full of errors!

And I dont want to reinstall it again...

What can I do to restore the forum?

I know im annoying, but please, understand me!

Sheepy

No, no, I'm not saying you're annoying or something. (Sigh)

If it says cannot connect to database, it's usually either 1) Incorrect connection setting or 2) MySQL not running or 3) Installation failed (or something messed with db after installation)

If it's something else, well, try to describe your problem at the support board.

Advertisement: