Advertisement:

Author Topic: Highslide Image Viewer  (Read 272094 times)

Offline tatore

  • Sophist Member
  • *****
  • Posts: 1,259
  • Gender: Male
    • salvo.franchina on Facebook
    • @tatore on Twitter
    • SalvoFranchina.it
Re: Highslide Image Viewer
« Reply #60 on: October 12, 2008, 02:00:12 PM »
Quote
Notice:  Undefined index:  subject in /home/XXXXXX/public_html/forum/Sources/Subs.php on line 2485
Unfortunately I have this problem, and it's displayed on my home (Joomla+smf Orstio's bridge).
Let me know, please, how to fix it. It's a great mod.

At the line 2485:
Code: [Select]
$message = str_replace($b[0], $b[5], $message) . '<div class="highslide-heading">' . $context['subject'] . '</div>';
Because with bridge it shows images outside a forum topics. There's no $context['subject'] in this case. I will fix it.
I would really appreciate. I love Highslide effects.
*Salvo*




Quote from: Rumbaar
I wont jump to conclusion, but you might be hacked?

Offline Animal_VY

  • Newbie
  • *
  • Posts: 1
Re: Highslide Image Viewer
« Reply #61 on: October 12, 2008, 04:31:31 PM »
Hello guys,
Many thanks to this really great job !
I 'm waiting for it since long time, but I'm a very too poor coder to do it myself, so  : thank you !  ;D

The least I can do, is to share a translation from my country : the France !  ;)

Code: (Save it as “ highslide.french-utf8.js ”) [Select]
// French - UTF8 language strings
hs.lang = {
loadingText : "Chargement...",
loadingTitle : "Cliquez pour annuler",
focusTitle : "Cliquez, pour mettre cette image au premier plan",
fullExpandTitle : "Agrandir l'image à sa taille maximum",
creditsText : "Propulsé par <i>“Highslide JS”</i>",
creditsTitle : "Allez la page officiel de “Highslide JS”",
previousText : "Précédente",
nextText : "Suivante",
moveText : "Déplacer",
closeText : "Fermer",
closeTitle : "Fermer [Echap]",
resizeTitle : "Redimensionner",
playText : "Lecture",
playTitle : "Lire en diaporama [Bar d'espace]",
pauseText : "Pause",
pauseTitle : "Mettre le diaporama en pause [Bar d'espace]",
previousTitle : "Précédente [Flèche gauche]",
nextTitle : "Suivante [Flèche droite]",
moveTitle : "Déplacer",
fullExpandText : "Taille maximum",
number: "Image %1 sur %2",
restoreTitle : "Cliquez, pour fermer l'image | Maintenez cliqué et glissez, pour la déplacer | Utilisez les icônes “flèches” en haut à droite, pour visionner les images suivantes et précédentes"
};

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #62 on: October 12, 2008, 04:44:34 PM »
Hello guys,
Many thanks to this really great job !
I 'm waiting for it since long time, but I'm a very too poor coder to do it myself, so  : thank you !  ;D

The least I can do, is to share a translation from my country : the France !  ;)

Please attach archived js to avoid problems with codepages.

Offline Rifugio

  • Semi-Newbie
  • *
  • Posts: 17
Re: Highslide Image Viewer
« Reply #63 on: October 12, 2008, 05:59:51 PM »
...only thing missing compared to lightbox - is lightbox shades the background web page with a very dark filter to help the images stand out.  Enjoying the slide show :)
No problem - Highslide can do this
http://highslide.com/example-mini-gallery.html [nofollow]
 
[view the sourcecode of the example]  ;)
 
Or add:
Code: [Select]

     hs.dimmingDuration = "15";
    hs.dimmingOpacity = 0.75;

I took a look at your link and was very impressed - I changed the opacity option and it worked well - also changed the location of the controls to match yours (needed to use "bottom center" instead of 'bottom center')
finally I set hideOnMouseOut: true - which also hides the controls when the mouse is outside the frame. 
I tried setting the hs.numberPosition = 'caption'; but it doesn't look like it's set up for numbering and gave me an error.

No problem as I've turned off captioning at the moment and this is much better than anything I've used before.  I was going to enlarge the size of the controls but the css file was locked and I took it that I'd tweaked enough for now.

Thanks for all your help.  I'm getting a few undefined index erorrs (modSetting & subject) but I'm not convinced these are to do with this mod.  Will try and track them down when I have more time.  I'm using this in 3 other themes and the set-up has been minimal :)
« Last Edit: October 12, 2008, 06:03:24 PM by Rifugio »

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #64 on: October 12, 2008, 06:47:26 PM »
Quote
Notice:  Undefined index:  subject in /home/XXXXXX/public_html/forum/Sources/Subs.php on line 2485
Unfortunately I have this problem, and it's displayed on my home (Joomla+smf Orstio's bridge).
Let me know, please, how to fix it. It's a great mod.

At the line 2485:
Code: [Select]
$message = str_replace($b[0], $b[5], $message) . '<div class="highslide-heading">' . $context['subject'] . '</div>';
Because with bridge it shows images outside a forum topics. There's no $context['subject'] in this case. I will fix it.
I would really appreciate. I love Highslide effects.
Fixed in RC7

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #65 on: October 12, 2008, 08:11:33 PM »
I took a look at your link and was very impressed - I changed the opacity option and it worked well - also changed the location of the controls to match yours (needed to use "bottom center" instead of 'bottom center')
finally I set hideOnMouseOut: true - which also hides the controls when the mouse is outside the frame. 
I tried setting the hs.numberPosition = 'caption'; but it doesn't look like it's set up for numbering and gave me an error.

No problem as I've turned off captioning at the moment and this is much better than anything I've used before.  I was going to enlarge the size of the controls but the css file was locked and I took it that I'd tweaked enough for now.
I am working on adding some mod settings to a forum admin area.

Offline tatore

  • Sophist Member
  • *****
  • Posts: 1,259
  • Gender: Male
    • salvo.franchina on Facebook
    • @tatore on Twitter
    • SalvoFranchina.it
Re: Highslide Image Viewer
« Reply #66 on: October 12, 2008, 10:45:39 PM »
Hi digger, you've fixed the error above  ;)
An old one comes back:
Quote
8: Undefined index:  host
File: /home/dxxxxa/public_html/forum/Sources/Subs.php
Linea: 2418

Code: [Select]
$c = empty($c) ? '' : $c['host'];
The all errors come from topics with attachments (not resized) that come from an old attachment path (before conversion to smf from a snitz forum).
Is there a way to fix it, eg. stating the path to those images?
*Salvo*




Quote from: Rumbaar
I wont jump to conclusion, but you might be hacked?

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #67 on: October 13, 2008, 02:33:07 PM »
Is there any way to only make this work for attached images ?

As it is now it works for posted thumbnails inside posts but it hangs on loading whenever the thumbnail links to an imageviewer (for example: img.php?image=66270.jpg)

So is there any way to turn it off so it only apply to attached images ?

Cheers

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #68 on: October 13, 2008, 02:52:34 PM »
Hi digger, you've fixed the error above  ;)
An old one comes back:
Quote
8: Undefined index:  host
File: /home/dxxxxa/public_html/forum/Sources/Subs.php
Linea: 2418

Code: [Select]
$c = empty($c) ? '' : $c['host'];
The all errors come from topics with attachments (not resized) that come from an old attachment path (before conversion to smf from a snitz forum).
Is there a way to fix it, eg. stating the path to those images?
Try RC8

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #69 on: October 13, 2008, 04:36:10 PM »
Hey digger any chance of helping me out ?

I want it to only apply to attachments !

My users are complaining that their thumbs are not opening but just hangs on "loading..." - Many of the free imagehosts uses view.php, image.php, etc to output images and your mod isn't working for them..

Please help - i really dont want to uninstal this great mod. :)

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #70 on: October 13, 2008, 04:52:07 PM »
Hey digger any chance of helping me out ?

I want it to only apply to attachments !

My users are complaining that their thumbs are not opening but just hangs on "loading..." - Many of the free imagehosts uses view.php, image.php, etc to output images and your mod isn't working for them..

Please help - i really dont want to uninstal this great mod. :)
So, what do you want?
Disable detect images from free imagehosts?

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #71 on: October 13, 2008, 04:58:42 PM »
Well yeah.. it's not working on my forum.. all free image host.. when you click the thumbnail it just say "Loading..." and nothing happens !

Works fine for Attached images - but not for images inside the post !

So is it hard to disable the free image host feature ?

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #72 on: October 13, 2008, 05:12:19 PM »
Well yeah.. it's not working on my forum.. all free image host.. when you click the thumbnail it just say "Loading..." and nothing happens !
Can i see any examples for this?

Quote
Works fine for Attached images - but not for images inside the post !
So is it hard to disable the free image host feature ?
In /Sources/Subs.php
find
// * Highslide mod
add before
/*
find
// Highslide mod *
add after
*/


I will add admin setting for this in 1.1 version.

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #73 on: October 13, 2008, 05:18:15 PM »
Quote
Can i see any examples for this?

I can send you a login but i cant post my url here because my forum is for adults only - i will send you a pm with login details and a link to an example of a thumb that is not working.

Quote
In /Sources/Subs.php
find
// * Highslide mod
add before
/*
find
// Highslide mod *
add after
*/

Would that not disable the mod completely ?

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #74 on: October 13, 2008, 05:22:08 PM »
Would that not disable the mod completely ?
That just disable highslide for non-attached images.

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #75 on: October 13, 2008, 05:26:41 PM »
Ok - i will change that later so you can have a chance of looking at that example i send you ;)

Thanks for helping me out here :)

Offline tatore

  • Sophist Member
  • *****
  • Posts: 1,259
  • Gender: Male
    • salvo.franchina on Facebook
    • @tatore on Twitter
    • SalvoFranchina.it
Re: Highslide Image Viewer
« Reply #76 on: October 13, 2008, 07:00:00 PM »
Hi digger, you've fixed the error above  ;)
An old one comes back:
Quote
8: Undefined index:  host
File: /home/dxxxxa/public_html/forum/Sources/Subs.php
Linea: 2418

Code: [Select]
$c = empty($c) ? '' : $c['host'];
The all errors come from topics with attachments (not resized) that come from an old attachment path (before conversion to smf from a snitz forum).
Is there a way to fix it, eg. stating the path to those images?
Try RC8
Thanks a bunch!!! That worked perfectly.
*Salvo*




Quote from: Rumbaar
I wont jump to conclusion, but you might be hacked?

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #77 on: October 14, 2008, 01:08:08 AM »
The reason why my thumbs are not working is that i vae an anonymizer on all outgoin links

just like http://anonym.to/en.html

Thats why it's not working - Thanks for your help Digger, i ill just disable it for free image hosts ;)

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: Highslide Image Viewer
« Reply #78 on: October 14, 2008, 01:13:56 AM »
Is that from the anonymizer mod here?
If it is, I have that installed also, and my images still work via this mod.
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #79 on: October 14, 2008, 01:32:08 AM »
No it's not any mod - i just read to insert something somewhere and its been working ever since.. don't even remember where i made the changes :D

I use my own anonymizer: http://www.rustysheriffsbadges.com/

Anyway i am happy and sitisfied that its only working for attachments now. Thats cool with me !