• Welcome to Simple Machines Community Forum. Please login or sign up.
November 26, 2021, 10:50:19 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


TinyPortal

Started by lurkalot, February 12, 2005, 04:43:00 AM

Previous topic - Next topic

JeffGoudreau

OMG. I cant figure this out? I must be retarded. I am in the block manager. There is no area that shows frontpanel or upper panel. All the options I have are right, left, center and front page. The front page one has nothing created so I know that the old admin didnt use it to create the front stuff.  I have created left side and right side blocks before but nothing on the front page. So I have nothing to copy from. 
Is there something I am missing? thanks for your help.

JeffGoudreau

Where else besides this area can you pick where it will show up? This area has NO selection for the HOME page. I cant figure out how to tell the block to show up on my home page and then further tell it where on my home page to show up? Thats where Im lost I guess. After that I have no clue how to code anything but thats another story :) For now I just need to figure out how to make the thing in the right area.

IchBin™

It's been a long time since I've seen TP 0.9.8. I can't remember what options are available TBH. If you have panel options, make sure your panel settings are set to show on the frontpage.
IchBin™        TinyPortal

JeffGoudreau


Do you mean in this area? Everything looks like its on.

JeffGoudreau

ok. I figured out something. An area in the frontpage section was turned to Articles only rather than show blocks. So I changed that and now my test block I created actually shows up :) Now I figure I can work from here. I hope :) Does anyone know where someone can find coding examples for these kinds of things? Im no good at that and I have been making do copying and pasting from the old Admin and then playing around with easy stuff like height and width numbers and being scared to mess up the original codes. I would love to find an area with some kind of examples outside this websites boundries.

JeffGoudreau

arrghh!! Now I finally figured out how to do this and there is some wierd little thing. if you go to the home page you will see CanadianKayakAnglers above my center block and I cant figure out why it is there and how to get rid of it? After I ditched the article that was there it just showed up?

IchBin™

That is the SMF linktree Jeff. If you want to remove it, you likely have to remove it from one of the TP files. Since I don't have 0.9.8 setup, I'd suggest you start by looking in for the words "theme_linktree()" in the Themes/default/TPortal.template.php file and either comment it out or remove it. After you're done with that, take a few deep breaths and relax. This is supposed to be fun, not full of "arrghh's". :P
IchBin™        TinyPortal

bloc

Indeed lol. :)

Quote from: MoreBloodWine on August 30, 2010, 10:00:42 AM
Quote from: Bloc on August 30, 2010, 08:22:01 AM
Yes, you did. ;D But really, it coincided with some long-time changes for improving smaller details I have been looking at lately.

Well, the RC1 will be out this week I reckon. So awaiting any bugs coming in from that the final might be not too far away, maybe a few weeks only. After that i like to add block/article/panel-cache features, to lessen TP's footprint on the server. That will be v1.1 of TP appropriately.
Sounds good to me, also Bloc, I hate to ask but if I gave you a copy of the theme I'm using would you do me a favor and remove all of the TP 098 edits ? I only ask because when upgrading with the edits in place the side bars for lack of a better word are doubled up but one sets invisible because it's looking for 098 side bars.

I would start with a clean theme but I have some mods installed with custom edits to the original code.

Sure, send it to bloc@blocweb.net and I will have a look.

MoreBloodWine

Quote from: Bloc on August 30, 2010, 06:07:16 PM
Indeed lol. :)

Quote from: MoreBloodWine on August 30, 2010, 10:00:42 AM
Quote from: Bloc on August 30, 2010, 08:22:01 AM
Yes, you did. ;D But really, it coincided with some long-time changes for improving smaller details I have been looking at lately.

Well, the RC1 will be out this week I reckon. So awaiting any bugs coming in from that the final might be not too far away, maybe a few weeks only. After that i like to add block/article/panel-cache features, to lessen TP's footprint on the server. That will be v1.1 of TP appropriately.
Sounds good to me, also Bloc, I hate to ask but if I gave you a copy of the theme I'm using would you do me a favor and remove all of the TP 098 edits ? I only ask because when upgrading with the edits in place the side bars for lack of a better word are doubled up but one sets invisible because it's looking for 098 side bars.

I would start with a clean theme but I have some mods installed with custom edits to the original code.

Sure, send it to bloc@blocweb.net and I will have a look.
Thx ;-)

Even with 0.98 being the "dinosaur" that it is in some peoples eyes hopefully you still remember what to look for to completely remove it from the heme ;-p
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


JeffGoudreau

lol. Thanks. To be honest I think this is fun. I just have noone to help me and for 2 years now I have asked a friend that ignores my requests. For some people this is super simple and it takes just one time of showing me and I can figure it out again. Just frustrating when the knowledgable dont help the retards. haha. Thank you for helping me. I am gonna try and figure out how to change that.

ZarPrime

Jeff,


Part of the problem here is that you are using a version of TinyPortal [version 0.9.8] that was released over 3 and a half years ago now.  This is the main reason why it is difficult to help you since many of us that offer support for the Mod have moved on to the latest version.  However, for each block you create, on the block edit screen, there should be a link at the bottom to [show] or [hide] where to show each block.  One of the selections should be to show the block on the FrontPage only.  If this doesn't help you, you might want to go to our support site, register there, and ask one of the Support Team Members to help you.  Both Ichbin and I are Team Members over there along with several others.  Once you post over there in Support, one of us may be better able to help you solve this issue.  The site is located here --> http://www.tinyportal.co.uk/index.php


ZarPrime

JeffGoudreau

My server guy says he does a backup daily and that I shouldnt worry about upgrading these kinds or things. But Im really rookie and I dont know what will happen with the existing stuff. If I upgrade to the latest version will the stuff I just did get screwed up? I can install a upgrade mod. I did a mod upload before. I will update it if you think its ok? lol.

bloc

It should work out fine, TP 1.0 will read the old data and use them.

MoreBloodWine

I found out not to long ago that I can't even use this new version because of what I said in that one email I sent you after you did those 098 theme code removal for me. Thx again for that BTW.
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


ZarPrime

MoreBloodWine,


Any version of TP after 1.x will work fine with any theme that works with SMF without special edits to the theme.  The only thing that might be required is the manual addition of a Forum tab.  Only TP 0.9.8 required the special edits to the theme.  In other words, if there is a theme that works fine with SMF 1.1.11 (without TP), it will work fine with the latest TP as well.  If you find this to not be the case, then I would suggest that you setup a test site to check this.


ZarPrime

agridoc

Quote from: JeffGoudreau on August 30, 2010, 09:01:12 PMMy server guy says he does a backup daily and that I shouldnt worry about upgrading these kinds or things. But Im really rookie and I dont know what will happen with the existing stuff. If I upgrade to the latest version will the stuff I just did get screwed up? I can install a upgrade mod. I did a mod upload before. I will update it if you think its ok? lol.

Hello JeffGoudreau

Estimating roughly from your posts your level of experience and knowledge I would rather advise you to leave TP 0.9.8 as is until you get more familiar with SMF and TP administration. There are a lot of big SMF and TP 0.9.8 (my main site is 0.9.7 with modifications  :D ) around working perfectly. Unless not been compatible with SMF 2.0 and needing some extra theme code TP 0.9.8 still stands well up in comparison.

Check the SMF Admin screens and options, learn which mods are added and how to handle packages. Go around TP admin and learn about TP settings, Frontpage settings, Blocks and articles. TP 1.0 has more features but is more complex. Whatever you create with TP 0.9.8 will be available when you will feel more comfortable with SMF and TP and decide to upgrade to TP 1.0x.
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

Anpu

Hi, I tried fresh install of SMF 2 RC 3 and TP 1beta5. I downloaded both from a site, and tried also to download TP in package section of SMF. It shows that TP is successfully installed, opens that pop up with list of created stuff, thank you etc. I close it, press "Home" and get following error: Table 'portal.smf_tp_settings' doesn't exist.
Any idea? Sorry if it was posted before, I searched on Google even but no useful results.

bloc

It would seem the database table wasn't created. You will have to do them manually then I am afraid. Try running the file "tp_upgrade.php" from the SMF20RC3 folder, it should then update just the database.

If not, you will need a SQL file to "import" into phpMyAdmin for example, I can help with that if you can't get tp_upgrade.php to work.

Anpu

Hm I couldn't repair. I see TP zip is in Packages, so I extracted that and tried to run file. It didn't allow even I set it 777 rights. So, I copied that file to root, but it just refreshes, and message I posted earlier stays. So, or I am doing something wrong,or it didn't work.

bloc

Hm, prob. didn't work then. Do you ahve the emans to run/import a SQl file? And can you see in the database if any xxx_tp_xxx tables were created?

Advertisement: