Advertisement:

Author Topic: TinyPortal  (Read 762875 times)

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #600 on: July 14, 2010, 09:58:19 AM »
lol no problem.
IchBin™        TinyPortal
Coding Guidelines       

Offline Akyhne

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,331
Re: TinyPortal
« Reply #601 on: July 16, 2010, 12:14:13 PM »
Code: [Select]
http://www.mysite.com/index.php?action=tpmod;dl & http://www.mysite.com/index.php?action=tpmod;dl=search

The DL Manager module is not active.
I don't see why this should generate an error that's placed in the log.

As I had the dl manager enabled the first week I had the 2.0 version installed, I now get a bunch of errors from spiders visiting my forum. It's not an error it's disabled - it's a (missing) feature.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #602 on: July 16, 2010, 12:26:55 PM »
If you'd like to change that, just open up the TPdlmanager.php file and change this part:
Code: [Select]
if(!$context['TPortal']['show_download'])
        fatal_error($txt['tp-dlmanageroff']);

To this:
Code: [Select]
if(!$context['TPortal']['show_download'])
        redirectexit();

That'll take you to the board index if it's disabled.
IchBin™        TinyPortal
Coding Guidelines       

Offline Akyhne

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,331
Re: TinyPortal
« Reply #603 on: July 16, 2010, 12:29:37 PM »
Already did ;)

Offline miDnIghtEr20C

  • Semi-Newbie
  • *
  • Posts: 64
  • Gender: Male
    • Showtime for Free
Re: TinyPortal
« Reply #604 on: July 21, 2010, 08:53:04 PM »
i get one error trying to install this.. and that's on the     ./Themes/default/index.template.php     Test failed.    is it because i have ajax chat up?

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #605 on: July 22, 2010, 09:45:23 AM »
It's likely because of another mod yes. If you want, you can install anyway and then make the alterations to the file that are shown when you click the parse button for your version of SMF on the mods download page. Make a backup before you do any changes though.
IchBin™        TinyPortal
Coding Guidelines       

Offline thellie

  • Semi-Newbie
  • *
  • Posts: 88
  • Gender: Male
Re: TinyPortal
« Reply #606 on: July 25, 2010, 06:01:20 AM »
before i go to my backup, i thought i'd see if you have an easy answer...

i've spent the day installing mods, most autoinstalling through packages, but some manually using the relevant manuals. checking them before going onto the next one, and backing up once or twice.

but, as things were going so well i decided to forego backing up for the final couple of hours. i also had a bright idea about the mods which wouldn't auto install - running the pre-install to see which files failed, then putting the originals into the folder (renaming the modded ones temporarily), and rerunning the pre-install to make sure all tests were successful... which worked well until i came to tiny portal.

i had fails on load.php, subs.php and index.template.php... after renaming the modded versions of these files, and then copying in the originals to relevant folders, i re-ran the pre-install in packages.

nothing but a blank page, all over the site.

i've run through all page modifications in the manual, checking every file, and nothing has been updated, there's no tiny portal code added in the entire site (apart from stuff put in by smf and other mods). i've even checked the database, and repaired it, just to be on the safe side.

i can't uninstall as i can't get to the packages (or any other) page...

any ideas? :)

EDIT: sorry, i should have said that i dropped those 3 original files back in again, but that didn't work - which is not surprising as the code hadn't been changed.

TP1b5.2.zip, modding smf 1.1.11

i will pull all the potential affected files out (those mentioned in the TP manual) and put the originals back in to see if this helps.

EDIT2: durrrrrrrr, i missed putting a file back in after it failed...  :-[
« Last Edit: July 25, 2010, 06:34:33 AM by thellie »
If you have any support questions, feel free to ask - be safe in the knowledge that I won't help because... I know nothing!

Offline tRu3_sKiTz0

  • Jr. Member
  • **
  • Posts: 173
Re: TinyPortal
« Reply #607 on: July 25, 2010, 06:15:23 PM »
Hey guys I had to make some changes to my site and I recently got everything back to normal, however, I tried to move the copyright from up above to below with the rest of the copyrights just like I did before using the steps posted on support site. Now when I try to do it I get rrors. My site won't even load. I put it back the way it was to make sure that my site will still load but I really don't like the copyright where it is. Could someone maybe take a look at my files and tell me what to fix or what to move? I will upload whatever files I need to. 

Offline hazyredeyes

  • Semi-Newbie
  • *
  • Posts: 11
Re: TinyPortal
« Reply #608 on: July 26, 2010, 03:47:37 PM »
New to the site, and i was recommended to this thread:
http://www.simplemachines.org/community/index.php?topic=392679.0

I updated our clubs SMF board to 1.1.11 and all was well.

Afterward,I tried to edit the HTML through admin to change up a banner we had at the top of the board. After i edited the HTML, no one cannot access the boards once trying to sign in. All we get is the attached screen shot once you try to sign in and on anything afterward,even on clickable items.

I must add, im 100% new to this. The guy  doing the work on the boards cut out a town and left it to me to figure out.

Any ideas on what i need to do to get the board aback and keep the paying members happy??

Offline gbsothere

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,780
  • I'm a Pappy!
Re: TinyPortal
« Reply #609 on: July 26, 2010, 03:48:22 PM »
I left a message for you on your 1.1.x Support thread, hazyredeyes.   :)  (Or edited my reply, rather.)
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.
I Don't Want To Grow Old Alone

It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.


A reminder about admin / ftp passwords etc.

Offline improv

  • Jr. Member
  • **
  • Posts: 395
Re: TinyPortal
« Reply #610 on: July 30, 2010, 10:16:33 AM »
I give you my thanks for this awesome and amazing mod.
I tried out a lot of portals and still TP is the best.
« Last Edit: July 30, 2010, 05:58:21 PM by improv »

Offline armycadets

  • Newbie
  • *
  • Posts: 3
Re: TinyPortal
« Reply #611 on: August 01, 2010, 11:34:27 AM »
Hello! I'm having a issue with TinyPortal useing 2.0 RC3
When i try to add a new block to tiny portal i get this error-

Field 'var3' doesn't have a default value
File: C:\HostingDIR\USERNAME\battlefield3news.com\wwwroot\Sources\TPortalAdmin.php
Line: 2337

This is the code from line 2299 to 2337
Code: [Select]
elseif($from == 'addblock')
{
checkSession('post');
isAllowedTo('tp_blocks');

$title = empty($_POST['tp_addblocktitle']) ? '-no title-' : tp_sanitize($_POST['tp_addblocktitle']);
$panel = $_POST['tp_addblockpanel'];
$type = $_POST['tp_addblock'];
if(!is_numeric($type))
{
if(substr($type,0,3) == 'mb_')
{
$request =tp_query("SELECT * FROM " . $tp_prefix . "blocks WHERE id =" . substr($type,3), __FILE__, __LINE__);
if(tpdb_num_rows($request)>0)
{
$cp = tpdb_fetch_assoc($request);
tpdb_free_result($request);
}
}
else
$od = TPparseModfile(file_get_contents($boarddir . '/tp-files/tp-blockcodes/' . $type.'.blockcode') , array('code'));
}
if(isset($od['code']))
{
$body = tp_convertphp($od['code']);
$type = 10;
}
else
$body = '';

if(isset($cp))
$request = tp_query("INSERT INTO " . $tp_prefix . "blocks
(type,frame,title,body,access,bar,pos,off,visible,var1,var2,lang,access2,editgroups)
VALUES(" . $cp['type'] . ", '" . $cp['frame'] . "', '" . $title . "', '" . htmlentities($cp['body'],ENT_QUOTES) . "','" . $cp['access'] . "',
" . $panel .", 0, 1,1," . $cp['var1'] . "," . $cp['var2'] . ",'" . $cp['lang'] . "','" . $cp['access2'] . "','" . $cp['editgroups'] . "') " , __FILE__, __LINE__);
else
$request = tp_query("INSERT INTO " . $tp_prefix . "blocks
(type,frame,title,body,access,bar,pos,off,visible,var1,var2,lang,access2,editgroups)
VALUES(" . $type . ", 'theme', '" . $title . "', '" . htmlentities($body, ENT_QUOTES) . "', '-1,0,1', " . $panel .", 0, 1,1,0,0,'','actio=allpages','') " , __FILE__, __LINE__);

Any insight you could give on this issue would be wonderful, thanks!

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #612 on: August 01, 2010, 04:49:25 PM »
Assuming you're running TP 1 beta 5.2 ?
IchBin™        TinyPortal
Coding Guidelines       

Offline armycadets

  • Newbie
  • *
  • Posts: 3
Re: TinyPortal
« Reply #613 on: August 01, 2010, 08:05:34 PM »
Yes

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
IchBin™        TinyPortal
Coding Guidelines       

Offline HugeLunatic

  • Newbie
  • *
  • Posts: 9
Re: TinyPortal
« Reply #615 on: August 07, 2010, 11:52:10 AM »
I'm having a problem with the text showing in the TP admin panel.  Some areas show but most don't (see image).   I just restored my forum from a backup and had to reinstall TP since that seemed to have gone MIA along with my custom theme.   My theme is a highly modified one by dziner studio and I use smf 1.1.11.  I have installed the theme from a fresh download since it appears version 1.0/beta now does not require a custom theme.  I did install the mod with no other mods installed and using the default smf theme.  This missing text is gone with both default theme and custom theme.  Any help to get the text to show would be very much appreciated as I love the TP front page.

Update:  Just wanted to post that the reason for this was the forum default language needed to be changed to English and not English uft-8.   So I guess I solved the problem, I will leave this for anyone else who may run into this.  Thanks.  =)
« Last Edit: August 07, 2010, 01:19:38 PM by HugeLunatic »

Offline moonrise

  • Semi-Newbie
  • *
  • Posts: 47
Re: TinyPortal
« Reply #616 on: August 07, 2010, 09:20:15 PM »
I'm posting here because Im not sure what else to do. I have poked about the tinyportal site, but I am leaving town first thing in the morning and I really need to figure this out.
SMF 1.11
TP Beta 5-1
Theme- Actualism
http://mysticalmundane.com

I installed tiny portal 5-1 . I was previously using simple portal.
I had a hard time figuring out how to use the categories etc for tiny portal. I was trying to make a welcome message to leave up on the board for while I went away.
Then I received a database error:

Error Message:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IFNULL(mem.realName,art.author) as realName FROM vlhl_tp_articles AS art
LEFT' at line 2
File: /home/mystical/public_html/Sources/TPortal.php
Line: 2153

So, searching about, I found a thread that suggested going into the Myphp admin and in the database removing the block. I did this, and got this message:
Table 'mystical_8Cj6Psm.vlhl_tp_blocks' doesn't exist
File: /home/mystical/public_html/Sources/TPortal.php
Line: 2025

It is on every page, except 'Home'
Home is now gone. Just a blank white page with 'Table 'mystical_8Cj6Psm.vlhl_tp_articles' doesn't exist'

Is there a way I can just remove tiny portal from my site altogether in the cpanel? Since I can't access my admin section anymore?
Or is there some way I can get my admin to reappear so that I can remove tiny portal (maybe try a fresh install, or just go with simple portal)
I have made a big mess and ridiculously close to tears.

Sincerely,
Shilo


Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: TinyPortal
« Reply #617 on: August 08, 2010, 12:36:53 AM »
This is one approach you may take.
Go into your packages folder, and then into the backup folder within, and select the backup which reads along the lines of before tiny portal.
Upload this to the root of your site(where your packages, sources and smileys folders are), and let it overwrite the folders and templates.
This will bring your site back to the state before you installed the portal.
Then proceed to remove the tables in your database.
If you like, I or an official TP staff member may be able to assist you in reinstalling it without flaw, if you decide to try it again :)
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline moonrise

  • Semi-Newbie
  • *
  • Posts: 47
Re: TinyPortal
« Reply #618 on: August 08, 2010, 01:34:43 AM »
Thank you so much!
Im going to finish packing for my trip (i leave in a few hours and will have no internet access), put the kids to bed and then I will give it a try.

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: TinyPortal
« Reply #619 on: August 08, 2010, 03:59:30 AM »
Good luck mate, if you have any issues, PM me and I'll get it sorted before you leave.
If you get it all done, good stuff, and enjoy your trip :)
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)