• Welcome to Simple Machines Community Forum. Please login or sign up.
September 16, 2021, 11:23:04 AM

News:

Wondering if this will always be free?  See why free is better.


RSS Feeder

Started by SlammedDime, January 11, 2009, 06:06:42 AM

Previous topic - Next topic

SlammedDime

The feeds are still in the database.... probably not displayed though... There is no code that would remove the feeds from the database when a board is deleted, but if I do remember correctly, the feeds are only displayed if they have a valid board, because of the SQL query used.

I'll keep in mind some different ways of accounting for deleted boards though... thanks.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

KahneFan

That would explain why my feeds were being doubled. I entered them twice since I thought they were gone.

(note to SD in case people mention double posts in future)
#eric_on_twit| (video) Creating Themes for SMF | Reset Your Forum
NOTE: No PM's for support please.

rii

February 01, 2009, 07:36:57 PM #182 Last Edit: February 01, 2009, 08:01:16 PM by rii
My RSS Feed is working well after the reinstallation. Thank you.

I now want to modify it. Please let me know how to take care of these:

- I want to exclude an extra title, time stamp and Source link from the automatic posts. How can I do this?

- There is a large extra space between the top post title and horizontal line. This is actually caused by the SMF but I don't know which file to look at. I use default theme. Is this in css file or php file?


Please help me.

Thank you.

Sudhakar Arjunan

Quote from: bloodfire on January 17, 2009, 07:58:05 AM
Quote from: A.SK on January 17, 2009, 07:40:54 AM
Quote from: bloodfire on January 16, 2009, 12:34:56 AM
Another thing I found... since using this mod.... I found core dump files in my server....

core.12437
core.24225
core.9285
core.6443

Does any1 getting these files? At first, I just delete them, ignoring it. Only just now, when I test this mod by 'run now' on the schedule tasks and abt 1 minute or so, the page shows 500 Internal Service page. Then I try to retrieve the error.log using ftp from my server to find wat other errors... my server seems to be timeout as well... then i reconnect and found the core file... however, no error was shown.

I do have many core dumps, and i have enable full article mode and not upgraded to latest version.

My advice... Download the updated mod and you won't get the dump core... however, I still get the 500 internal server error... but i guessed the limit this mod can gather the rss feed but then it gathered all the news.. hmmmm... no error shown in the error log...

I was not using it for long time, deactivated all the rss i have configured.

After a Month i have 38 core dump files with 40 mb sized file each.

So now i was really worried that could i able to delete them or not.

Any suggestions on it. I have not upgraded this mod as said by bloodfire.
Working on New Mods & Themes for SMF... Will update soon... My Blog page
My Smf forum : Discuss ITAcumens :: My SMF Forum

SlammedDime

rii - As for modifying how the post is created, you'll have to look in ScheduledTasks.php in the rss_feeder() function at the bottom and modify the $message variable.

As for the CSS issue, I'm not sure on that.  I developed this on RC1 which didn't have that problem.

A.SK - if you're still getting core dumps after disabling the rss feeds, then the problem is not with the mod... Can you delete them?  Yes, no harm in doing that.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Sudhakar Arjunan

Quote from: SlammedDime on February 02, 2009, 04:57:45 AM

A.SK - if you're still getting core dumps after disabling the rss feeds, then the problem is not with the mod... Can you delete them?  Yes, no harm in doing that.

Hi SlammedDime.

I have deleted the core dump files.

And these dumps were created on 16 & 17th Jan during i was using RSS Mod.
Working on New Mods & Themes for SMF... Will update soon... My Blog page
My Smf forum : Discuss ITAcumens :: My SMF Forum

Smoky "Rider" Blue

those dump files could also come from the server having a memory loss as well..

i'd have your host check his server and see what is said, if you are still having the issue.. ;)
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

Drivin and Cryin

I'm getting a ton of errors in my error log from simplepie.  On the forum, it seems to be working alright, but it's building a huge error log.  Is it because of the feeds i've set up?  I'm using yahoo pipes for some of the feeds  in order to get them to work with your mod.  Maybe that's why?  I'm clueless when it comes to programming.


here's a very small sample of the errors.   


[02-Feb-2009 16:32:03] PHP Strict Standards:  is_a(): Deprecated. Please use the instanceof operator in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 1729
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::get_curl_version() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 7713
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::get_curl_version() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 7725
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::xml_encoding() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 1833
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::change_encoding() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 1852
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::encoding() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 9179
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::encoding() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 9180
[02-Feb-2009 16:32:03] PHP Strict Standards:  is_a(): Deprecated. Please use the instanceof operator in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 8683
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Parse_Date::get() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 3652
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::absolutize_url() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 13699
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 8779
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::compress_parse_url() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 8837
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::normalize_url() should not be called statically, assuming $this from incompatible context in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 8843
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::percent_encoding_normalization() cannot be called statically in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 9103
[02-Feb-2009 16:32:03] PHP Strict Standards:  Non-static method SimplePie_Misc::percent_encoding_normalization() cannot be called statically in /home/xxxxxxx/public_html/yyyyyyy/forum/Sources/Subs-Rss.php on line 9103


SlammedDime

If you have the option of changing php.ini settings, or the error reporting level of PHP, change it to E_ALL, instead of E_STRICT.

I don't have the time or man power to navigate someone else's code and try to fix those errors, and they're not errors that are really worth fixing at this point time.

As for the very first one about is_a being deprecated, it has been undeprecated as of php 5.3, so I don't see a point in adjusting that line of code either, but all of the errors will go away if you adjust your reporting level to E_ALL.

If you have no clue about adjusting the error reporting level, ask your host to adjust it, or you can just ignore them.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Drivin and Cryin

Quote from: SlammedDime on February 02, 2009, 08:47:33 PM
If you have the option of changing php.ini settings, or the error reporting level of PHP, change it to E_ALL, instead of E_STRICT.

I don't have the time or man power to navigate someone else's code and try to fix those errors, and they're not errors that are really worth fixing at this point time.

but all of the errors will go away if you adjust your reporting level to E_ALL.

If you have no clue about adjusting the error reporting level, ask your host to adjust it, or you can just ignore them.


I'm not sure how to do it, but i'll figure it out eventually, i just needed a direction to look into.  I normally wouldn't worry about it, but it grows about 10 meg/day.  I'd like to eliminate that.

thanks again.

webhosting123

i install RSS Feed Poster in SMf 1.1.7 and create many rss feed post but not show they post in my forum.
why?

SlammedDime

This mod is for 2.0... if you have vb's mod for 1.1.7, you'll need to ask in that topic for support, not here: http://www.simplemachines.org/community/index.php?topic=141776.0
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Rbbn39

I have tried to use the SMF Feeder at my  SMF 2.0 beta 4 forum. www.voetbaltalk.nl/index.php I always tried to import te RSS file www.tcof.nl/rssn.php. You see it at many forums, but always the oldest post on the site, is the newest one one the forum.

I tried already to change some things in de PHP files. But always I got the same problem. For me it is important that the forum can be online tomorrow. So does someone here have a solution for this problem?

(Sorry for the bad English, I live in Belgium so I do not speak it every day)

SlammedDime

February 03, 2009, 06:11:45 PM #193 Last Edit: February 03, 2009, 06:15:28 PM by SlammedDime
I'll look in the SimplePie() code and see if it's possible... i'm not entirely sure that it is without turning the script into a memory hog...

Edit: It is possible to do with existing methods in SimplePie, but I'm not sure I can have a solution for you by tomorrow.  Unfortunately it's not entirely simple, no pun intended.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Smoky "Rider" Blue

might want to run that url, www.tcof.nl/rssn.php

thru http://www.feedburner.com  that will set up the rss thread correct for your site..  ;)
**Take the time to remember friendships and family.. Sometimes it's all we have, and missed very much**

rii

February 03, 2009, 09:13:55 PM #195 Last Edit: February 03, 2009, 09:16:07 PM by rii
Thank for the advice. I removed the unwanted lines from that file.

I use CDATA in XML file to take care of html codes and auto post it to the forum but the word [CDATA [ is also display in the post. Do you know why?

For example - I have this in my xml file:
<description><![ CDATA [ blah blah blah ]]</description>

After it posted, the code CDATA is also displayed like this:
[CDATA [ blah blah blah ]]

The forum is working functioned with other code but I don't know why CDATA is not working for me. The post works fine too.

Please help.

Thank you.

Quote from: SlammedDime on February 02, 2009, 04:57:45 AM
rii - As for modifying how the post is created, you'll have to look in ScheduledTasks.php in the rss_feeder() function at the bottom and modify the $message variable.

As for the CSS issue, I'm not sure on that.  I developed this on RC1 which didn't have that problem....

SlammedDime

Can you link to the XML file that your specifically working with?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

rii

February 03, 2009, 11:49:28 PM #197 Last Edit: February 04, 2009, 01:55:49 PM by rii
I have attached it to this message.


Thank you.

SlammedDime

You didn't properly close your cdata section...

All you have is ]].  It needs to be ]]>
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Rbbn39

Quote from: SmokyBlue on February 03, 2009, 08:19:55 PM
might want to run that url, www.tcof.nl/rssn.php

thru http://www.feedburner.com  that will set up the rss thread correct for your site..  ;)
Does feedburner also update my feed automatic like my script does?

@SlammedDine: If I have to change my RSS feed is also ok for me, the RSS feed won't be used for something else than this.

Advertisement: