News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

SMF Quiz

Started by Diego Andrés, February 18, 2009, 01:08:19 PM

Previous topic - Next topic

netpaydays

I un-installed this fab mod when I upgraded to the new smf 20 rc2 from the rc1 version, will it work on 2.0 or would it be best to wait.

Dave J

Quote from: netpaydays on March 10, 2012, 03:35:23 AM
I un-installed this fab mod when I upgraded to the new smf 20 rc2 from the rc1 version, will it work on 2.0 or would it be best to wait.

If you go back a few pages you'll see your answer.

vindinacho

Does it work - Absolutely thanks to Davejo ....

Davejo
I stripped out some code and managed to lose Search and Random as well.
I will compare to yours though as mine was a bit of hit and miss.

Thanks again
Vin

Dave J

Quote from: vindinacho on March 10, 2012, 04:16:19 AM
Does it work - Absolutely thanks to Davejo ....

Davejo
I stripped out some code and managed to lose Search and Random as well.
I will compare to yours though as mine was a bit of hit and miss.

Thanks again
Vin

No problem glad I could help.

GlitchPC

Although I only have a couple of quizzes added to this mod...it will be expanded...as soon as my board starts to gain in popularity...(hint-hint)... ;)

In the interim...is there any way I can get rid of those annoying .gif "new" images?  Although it may be nice to know a new quiz has been added...it's not really imperative that a user be notified with those annoying "flashing" images...since, if they visit the quiz page, they'll see what quizzes have been added anyway.  Just sayin'...

Would love to lose those images if anyone can enlighten me...

Thanks, in advance...

XHIBIT911

Ok after reading the first 7 of 23 pages I realized I dont have the entire day to go thru each and every post.

So I have some questions to speed this up.

1) Does this work or not work with v 2.0.2 ?
2) Ive seen so many error replies about it, has this been sorted out to where it ready to load and play ?
I dont want to have to hassle with adding snippets of coding and fiddling around in my MYSQL just to get this mod to work.

3)Can someone post a CURRENT link that I can check this out myself ?
and finally....

4) Can I download and install via package manager and start writing my own quizzes ?
I dont want to feel like I'm beta testing someone elses coding

Kindred

wow...    so we should cater to you because you don't feel like reading or using search?

sheesh.   All of your questions were actually answered in the last 2 pages of this thread.

in no particular order - I leave it to you to figure out which is the answer to which.
yes
yes
no issues
look at the download page or look at davejo's attachment
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

XHIBIT911

Wow this place has really gone downhill from years back.
At NO POINT did I say anything about catering to ME or anyone else. and any person with common sense would realize that 23 pages of posts with the majority of them being problems or errors is time consuming to dig thru, and maybe everyone doesnt have the time to read each, individual post.

It was more a waste of time just trying to figure out if it was current and patched.
And FYI..I DID read several of the last few pages and still I saw conflicting error reports until I gave up and simply asked if this mod was ready for 2.0.2, which by the way DOES NOT show its been upgraded to 2.0.2 and is working on the mod link.

SHEEESH

Dave J

Glitch,

I have managed to get rid of the 'New' gif for the 'New Quizzes' & 'Popular Quizzes' but I keep getting errors whenever I enter the 'Quiz Admin' section.

The error is:
Quotehttp://www.*****************/index.php?action=admin;area=quiz;f47dcd943a=43ddbbd3db35e8e14dfea553e669b3f8
8: Trying to get property of non-object
File: /home/********/public_html/Sources/SMFQuizAdmin.php
Line: 2398

I do not get any errors at all when using the quiz or when going to any other area of the quiz headings i.e " Home, Categories, Quiz Leagues, Statistics, User Details, User Quizes"

I have attached the template to this post but as I say it will show errors in the error log..even though it works. It's up to you if you want to use it.




XHIBIT911

Exactly !

Fatal error: Cannot redeclare parseleaguemessage() (previously declared in /home/loadedpa/public_html/PSHomeSource.com/home/Sources/ScheduledTasks.php:733) in /home/loadedpa/public_html/PSHomeSource.com/home/Sources/SMFQuizAdmin.php on line 348

And this was my entire point in asking only to have some moderator try to belittle my genuine question.
Furthermore the support links that the installed mod have listed no longer exist.
SMH..Yeah I guess my question HAS been answered after all

GlitchPC

Quote from: davejo on March 10, 2012, 11:47:54 AM
Glitch,

I have managed to get rid of the 'New' gif for the 'New Quizzes' & 'Popular Quizzes' but I keep getting errors whenever I enter the 'Quiz Admin' section.

The error is:
Quotehttp://www.*****************/index.php?action=admin;area=quiz;f47dcd943a=43ddbbd3db35e8e14dfea553e669b3f8
8: Trying to get property of non-object
File: /home/********/public_html/Sources/SMFQuizAdmin.php
Line: 2398

I do not get any errors at all when using the quiz or when going to any other area of the quiz headings i.e " Home, Categories, Quiz Leagues, Statistics, User Details, User Quizes"

I have attached the template to this post but as I say it will show errors in the error log..even though it works. It's up to you if you want to use it.





Thanks for taking the time to look into that for me, davejo...

If it's going to return more errors than I have already...I don't think so.  I just thought it'd be an easy fix.  Goes to show how much I know about coding, huh?  Anyway...I really do appreciate you taking he time to give it a shot for me.


All my best!

GlitchPC

Quote from: Kindred on March 10, 2012, 11:11:38 AM
wow...    so we should cater to you because you don't feel like reading or using search?

sheesh.   All of your questions were actually answered in the last 2 pages of this thread.

in no particular order - I leave it to you to figure out which is the answer to which.
yes
yes
no issues
look at the download page or look at davejo's attachment


Actually...I kind of like this answer.

I sometimes have to look through more than 100+ pages before I can find an answer to my question.  Sometimes someone will have pity on me...and because they have nothing to do...will volunteer their help.  I also try to use the Search box at the top of the site.  Most of the time...the answers I seek are silly mistakes I have made...and/or mod conflicts.  If you show initiative when it comes to finding the answer yourself...the god's will shine upon you.  If not...at least make an effort.  We're talking 23 pages here...and you don't have to read them verbatim...you can skim them to find the answer you need...

Just sayin'...  It's your choice...you can use the mod or not.  If not...move on...

vindinacho

Hi all you super support guys,

Just wanted to repeat what great support you have given me over the past few days, getting everything slick and running on the Quiz.
It runs like a dream on 2.0.2 and all my members love it.

For someone who knew nothing about Coding, Forums, Quiz Mod or even file types this thread and you guys answered everything I needed, and with a little "hard work" and "perseverance" from my end I got there - Thanks again

I have one question - a few of my members cannot get the quiz to run (I think they mean the quiz screen to popup, has anyone came across this problem and know the fix for it ? Could it be popups ? or anything to do with Java, I know one of them is using Explorer but thats all I know.

Any help greatly appreciated as per normal

Vin

Kindred

Quote from: XHIBIT911 on March 10, 2012, 11:57:39 AM
Exactly !

Fatal error: Cannot redeclare parseleaguemessage() (previously declared in /home/loadedpa/public_html/PSHomeSource.com/home/Sources/ScheduledTasks.php:733) in /home/loadedpa/public_html/PSHomeSource.com/home/Sources/SMFQuizAdmin.php on line 348

And this was my entire point in asking only to have some moderator try to belittle my genuine question.
Furthermore the support links that the installed mod have listed no longer exist.
SMH..Yeah I guess my question HAS been answered after all

Well, that error is not because of the mod itself... That error is because YOU double installed the mod.
The mod installed with no errors in 2.0.2, although you have to emulate a previous version to do it. As was said 1 page of posts ago.
Davejo has created an separate version with he made some tweaks in...   Also stated 2 and 1 page ago.

And I did not belittle your question, I merely snarked at your attitude of "there's a lot of posts, so I'll ask the question instead of looking for the answer"
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

XHIBIT911

#454
My point is that the last few years many of the mods feel so obligated to downtalk and assume that people have the time to go thru post after post after post, or they havent spent up to half an hour searching on their own.

You catch more flies with honey than vinegar and while there are many fantastic mods here now, there are some that are plain arrogant and nasty.

Its 50/50 and depends on whom replies...my other questions today were answered timely and politely and without assumptions. And for that professionalism I took time out and thanked the mods that displayed excellent support skills.

Regardless of what anyone thinks the truth of the matter is it would have been much easier to try checking into these pages, answering the question, or not answering at all. But as oppossed to trying to scold a grown man simply because he didnt have the time (after spending 45 minutes in the same thread and searching on his own) to find error after error report, then something is wrong with the machine and not the people who come here for support.

I dont see why its so hard to realize after reading a tidal wave of thread posts how some bits of info can become a blur.
But for the most part if you misread the demeanor of my original post, then I apologize for that.
My point was not everyone has tape on the bridge of their glasses and a pocket protector with 47 ink pens in it wearing an extra extra medium plaid shirt and can sit and scour every single post ALLLL DAY.
But it shouldnt be assumed that the search feature wasnt used either.

Thanks for your reply

In any event I'm done with the entire topic.

Dave J

Quote from: vindinacho on March 10, 2012, 12:37:53 PM
Hi all you super support guys,

Just wanted to repeat what great support you have given me over the past few days, getting everything slick and running on the Quiz.
It runs like a dream on 2.0.2 and all my members love it.

For someone who knew nothing about Coding, Forums, Quiz Mod or even file types this thread and you guys answered everything I needed, and with a little "hard work" and "perseverance" from my end I got there - Thanks again

I have one question - a few of my members cannot get the quiz to run (I think they mean the quiz screen to popup, has anyone came across this problem and know the fix for it ? Could it be popups ? or anything to do with Java, I know one of them is using Explorer but thats all I know.

Any help greatly appreciated as per normal

Vin


I think the first question to ask yourself Vin is; Is everyone having the same problem?...if the answer is no then it has to be a user orientated problem and nothing to do with the mod itself. Ask them to try using the 'Compatability Mode' in IE (that's if it's in their version)...or switching it off if it's on.

Also, as you say, get them to check the pop-up blocker...if they have the Google Toolbar then they probably have the popup blocker working twice, as it has one and so do most browsers.


vindinacho

Hi - They seem to have resolved it themselves  ::)

I do have another problem though, but I need to research this thread before crying wolf !

Thanks again

FrizzleFried

I keep getting this error...

http://www.xxxxxxxxxx.com/index.php?action=SMFQuiz;sa=categories;id_quiz=483
8: Undefined index:
File: /home/ahaforum/public_html/testingsite/Sources/Subs.php
Line: 3949

Any ideas?


Kindred

ummm.... undefined index WHAT?

What is line 3949 of your subs.php?
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

FrizzleFried

It's the LOGOUT button that I removed... i simply changed it to a blank space... putting LOGOUT back in now produces the same error but with LOGOUT included...

8:undefined index: logout


Advertisement: