News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Missing Field in user permissions page

Started by fantasydirtracing, March 10, 2010, 09:21:24 AM

Previous topic - Next topic

fantasydirtracing

I upgraded the forum from rc2 to rc3 yesterday i had uninstallled all mods prior, now in my permissions page I have a black space (with check marks available) in it....The part that is not showing is below moderate the entire forum and above contact members using personal message system, it looks like their are 7 boxes able to be checked does anyone know what section this is or why it would have dissapeared....Just fyi my members have some of the boxes checked....

Arantor

Please attach your Sources/ManagePermissions.php file.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

fantasydirtracing

#2
Attached...

Arantor

No, not the one with ~ at the end. That's a backup after a mod was installed or uninstalled.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

fantasydirtracing

#4
re-attached...thanks

kappazuhk

You should be able to go into your error log, and see an error from where you viewed your permissions page. Select the error and look at the line that is in question. It will refer to a missing description. Remove the lines that pertain to the description. This normally comes up when you uninstall a mod that used permission. EX... SMFGallery, I have had it leave the lines in and cause this issue. This is just one possibility but easy to check.

Arantor

Actually... it may or may not refer to a missing description. 2.0 series tends to check the string is present before using it.

It's the SMF Shop mod by the looks of it.

Assuming you're not using SMF Shop any more, there's two edits to be made:

Code (find) Select
'karma_edit' => array(false, 'general', 'moderate_general'),
// Begin SMFShop code
'shop_main' => array(false, 'shop', 'shop'),
'shop_buy' => array(false, 'shop', 'shop'),
'shop_invother' => array(false, 'shop', 'shop'),
'shop_sendmoney' => array(false, 'shop', 'shop'),
'shop_senditems' => array(false, 'shop', 'shop'),
'shop_bank' => array(false, 'shop', 'shop'),
'shop_trade' => array(false, 'shop', 'shop'),
// End SMFShop code
'pm_read' => array(false, 'pm', 'use_pm_system'),


Code (replace) Select
'karma_edit' => array(false, 'general', 'moderate_general'),
'pm_read' => array(false, 'pm', 'use_pm_system'),


Code (find) Select
'profile_remove_own',

// Begin SMFShop code
'shop_main',
'shop_buy',
'shop_invother',
'shop_sendmoney',
'shop_senditems',
'shop_bank',
// End SMFShop code


Code (replace) Select
'profile_remove_own',


If you *ARE*, it's a different story - let me know if that's the case.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.


Arantor

And did you install it manually?

Next step is to check your Themes/default/languages/ManagePermissions.english.php file for this:
// Begin SMFShop code
$txt['permissiongroup_shop'] = 'SMF Shop';
$txt['permissiongroup_simple_shop'] = 'SMF Shop';

$txt['permissionname_shop_main'] = 'Allow access to SMF Shop';
$txt['permissionname_shop_buy'] = 'Buy Items';
$txt['permissionname_shop_invother'] = 'View Other Members\' Inventory';
$txt['permissionname_shop_sendmoney'] = 'Send Money to Someone';
$txt['permissionname_shop_senditems'] = 'Send an Item to Someone';
$txt['permissionname_shop_bank'] = 'Bank';
$txt['permissionname_shop_trade'] = 'Trade Center';

$txt['permissionhelp_shop_main'] = 'If this option is unticked, the user will not be able to use the shop at all. If you want to disable access to only a particular section of the shop, use the permissions below this one.';
// End SMFShop code


Also, are you using a different language to English? Only English is supported by the mod at present.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

fantasydirtracing

#9
It was not a manual install, i used the mod, also english is defualt launguage, I have attached the next file, I did not see that script in their.

Arantor

Add the code I posted to the end of that file, then go to Admin > Maintenance > Routine > Empty the file cache

Also check the other edits listed in http://custom.simplemachines.org/mods/index.php?action=parse;mod=65;attach=136917;smf_version=2.0_RC3
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

fantasydirtracing

Its in their at the end, but nothing changed......what if I uninstall the shop and reinstall it?

Arantor

Did you do the second part of what I said - Admin > Maintenance > Routine > Empty the file cache?
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.


Arantor

Is there a ManagePermissions.english-utf8.php file?
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.


Arantor

That probably means you're using English UTF-8 not English.

OK, I posted a link to the parsing instructions for this mod, which dictates editing ManagePermissions.english.php and other .english.php files. Make the same edits to .english-utf8.php files, so any edits it lists for ManagePermissions.english.php, apply to ManagePermissions.english-utf8.php, Modifications.english.php -> Modifications.english-utf8.php and so on.

Then re-empty the file cache.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

fantasydirtracing

I did all that still didnt work, the shop is functioning correctly so it shouldn't be a big deal, is it a security risk and should I uninstall the shop?

Arantor

It's not a security risk. But it is a problem and should be fixed. Doubtful that uninstallation/reinstallation would fix it.

So you've changed all the files and re-cleared the cache (making sure you're changing them on the server)?

And you're definitely using English yourself (if you're using English and you've modified both sets of files, it SHOULD work)
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

fantasydirtracing

Yep, when I go to admin/configuration/launguages/settings it is set as english as default

Advertisement: