News:

SMF 2.1.4 has been released! Take it for a spin! Read more.

Main Menu

Optimus

Started by Bugo, February 15, 2011, 03:48:12 PM

Previous topic - Next topic

Kindred

this mod will not work on 2.1 beta...      2.1 is still in beta and will not run most 2.0 mods without edit -- even if they "install without error"
additionally, you should not be running 2.1 beta on any production site.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

tectonny

I am aware that I must not use SMF 2.1, this is not a problem for me.

And I know that was not done, but many MODs I could have run in SMF 2.1, but give this error.

I thought you could help me.

I'll try alone, as I did with those who are already working,

Thanks for the answer.

Paleus

How can I submit my sitemap to Google Webmaster if it is HTML? Should it not be an XML file?

www.example.com/sitemap.xml

Kindred

I don't believe that this mod creates an XML sitemap.  You would use a different mod for that
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Dblog

Quote from: Kindred on September 16, 2015, 03:21:05 PM
I don't believe that this mod creates an XML sitemap.  You would use a different mod for that
It does create an XML sitemap (yoursite.com/sitemap.xml)
check options as admin

Jade Elizabeth

So I recently discovered that I'm not indexed in google properly, and neither are any of my other forums using this mod. This is very disappointing.

I went into google webmasters and out of almost 200 submitted sitemap links only 50 were indexed.

I tried resubmitting the sitemap and this time 93 out of 20 links were accepted.

It (google) is not rechecking the sitemap and the sitemap is not adding topics specifically. How often is "periodically" and do I need to resubmit the sitemap each time? Can you please take a look and help?

www.colormeforum.com/sitemap.xml
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Jade Elizabeth

Is it a good idea to have the forum name in the title? When I google I am getting mixed results.

http://sixrevisions.com/content-strategy/5-common-seo-mistakes-with-web-page-titles/
Quote4. Using the Company/Site Name in All Web Pages

As previously said, Google displays up to 70 characters of a given page title in their SERPs. It does see longer ones, though, and despite what many SEO professionals preach, it isn't a huge problem to have page titles that are greater than 70 characters in a page title.

Nevertheless, you need to think of what should and shouldn't appear in the title. Many website owners tend to include their business name in the title, some of which can be very lengthy. What is even worse is that they want their name to appear first in every single web page.

Including your company name (unless it's a search term that will likely be used), is unnecessary, and is consistent with some of the mistakes I've discussed earlier.

For example, study this title:

<title>ACME Exporting/Importing Company, LLC: Export Surfboards to Hawaii<title>
With the page title including the company's name, it is using 37 more characters (with spaces)!

Search engine ranking might be better if it was simply:

<title>Export Surfboards to Hawaii</title>
It would make sense displaying your company name in the homepage, contact page, and about page but avoid them in content pages.


Additionally would you be willing to include open graph things so we can format the titles for Facebook, add the body as the description, maybe even choose a global Facebook image as well as using post images and avatars when sharing?
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Kindred

First... I disagree with that person's interpretation of seo.

Second, however... This mod author has not updated the mod ins a while so, it's unlikely to have any features added...
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Jade Elizabeth

There's a bunch of other posts for and against it. I can understand how it can be detrimental in come cases.
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Jade Elizabeth

Hey!

Not sure what's going on but on one of my forums the title is showing twice. It's showing as forum name - optimus brave title (which includes the forum name at the end). It's doing this when I look at it, when I share it on Facebook, and probably in search results too. I want that first forum name to bugger off.

I've compared the meta tags to the default theme (clean) and they're the same except I've added open graph things for facebook image and description. I'm having this across all themes. Any suggestions? or ideas on what to look for? :)
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Jade Elizabeth

Quote from: Jade Elizabeth on February 16, 2016, 08:13:15 PM
Hey!

Not sure what's going on but on one of my forums the title is showing twice. It's showing as forum name - optimus brave title (which includes the forum name at the end). It's doing this when I look at it, when I share it on Facebook, and probably in search results too. I want that first forum name to bugger off.

I've compared the meta tags to the default theme (clean) and they're the same except I've added open graph things for facebook image and description. I'm having this across all themes. Any suggestions? or ideas on what to look for? :)

Anyone? :)
Happening on all themes.
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Jade Elizabeth

Uninstalling and reinstalling isn't working. How do I completely wipe Optimus Brave's existence so I can try a fresh install like it's new? I don't know what else I can do.
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Jade Elizabeth

I found the DB stuff, still no dice. Can ANYONE help please?
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Paracelsus

Are there any plans to develop a "Social Optimus Brave"? :laugh:

Looking at WPSSO makes me wonder if some ideas there could be ported to a SMF mod in order to improve the way social networks pick up data from SMF (a glimpse: https://wpsso.com/ and https://surniaulula.com/2014/10/25/social-seo-wordpress-seo-vs-wpsso/

Jade Elizabeth

THERE IS A BUG

On a forum with Tinyportal installed that does not use the portal aspect, say they only use sidebars, etc, "integrate with Tinyportal" breaks the canonical URL. This is actually pretty major! ALL canonicals will be set to index.php?action=forum, topics, boards, the whole lot. Perhaps you want to check the settings of Tinyportal before assuming? Or perhaps you want to make a note for the end user to only integrate if using the portal function.

I checked it with simple portal and it doesn't happen. I don't have any other portals to test with so that bit is up to you :D.

Also it would be really good to put a check in for RIAST or to state they are not compatible because it duplicates the title and mucks it all up. It should be obvious but it's not if you installed it 20 years ago lol.
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Bob Perry of Web Presence Consulting

Open Graph default image doesn't work, is there anyone even supporting this anymore? I like this mod a lot and can't get anything with open graph enabled, running SMF 2.0.12 and aeva media... if there are embedded images it sometimes will work but usually not. Also a missing language entry for the sitemap title ...
Best Regards,
Bob Perry



"The world is moving so fast these days that the man who says it can't be done is generally interrupted by someone doing it." Elbert Hubbard

anidea

Hi All,

I just installed this mod on my site (2.0.12) and I keep getting this error.  Is anyone familiar with it and can help make it go away?  It generates a ton of errors at a time... (and I just noted the language error above me, is it the same thing?)

http://ragdollsunited.com/smf/index.php?action=admin;area=logs;sa=errorlog;desc
8: Undefined index: optimus_sitemap_title
File: /home/public/smf/Sources/Admin-Optimus.php
Line: 42

Thanks!  :)

wintstar

Open Themes/default/languages/Optimus/Optimus.xxx.php

XXX = france, english or german

find
Code (php) Select
$txt['optimus_sitemap_section'] = 'Optimus Sitemap';

add before
Code (php) Select
$txt['optimus_sitemap_title'] = 'Sitemap';



Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

anidea

Woo hoo!  Thank you, winstar!  :)

owemeone

Hello.

The mod works great, except for the analytics part.

Error:
Forbidden

You don't have permission to access /f/ on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


I am using the following code:

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', '****54392-1', 'auto');
  ga('send', 'pageview');

</script>


Theme: zone99

extra info: Without the <script> tags the code is displayed at the top of my page in normal text.

tried:
1. backlashing (adding \ before the ')
2. adding echo stuff
3. trying different combos, ie. removing <script> tags, only pasting my tracking ID, etc.

From this post you can see I have little knowledge about scripting, so any help is appreciated.

PS: I know there is a mod specifically for google analytics, but I would prefer to get this mod working.


Advertisement: