• Welcome to Simple Machines Community Forum. Please login or sign up.
October 18, 2021, 06:35:09 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


SMF 2.0.5 critical security patch released

Started by Oldiesmann, August 12, 2013, 08:34:06 PM

Previous topic - Next topic

ZakNik

is there any notification mod like one on facebook for smf forum...when i qoute someone or like his post that he get notification not on mail???

something like that but only for notification...2.0.4. version

Arantor

No good deed goes unpunished
All helpful urges should be circumvented

ZakNik

some forums have maybe you can adjust that with vbulletin?

Arantor

Maybe but not with SMF at this time, and I doubt anyone here wants to pay $200 for the latest incarnation of vBulletin complete with missing features, like it launching without any way to warn users.
No good deed goes unpunished
All helpful urges should be circumvented

ZakNik

i'm  :-\ why they don't make notification mod? is  that hard to make one?

Chalky

There's the ENotify mod but I've never used it.  This isn't the place for this discussion though, this is about the security patch.

Kindred

ummm....  Why the heck are you asking this question in the version release announcement thread?  This thread is not for support and your questions and comments have nothing at all to do with the release.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

PlaneShift

We have upgraded to 2.0.4 and then to 2.0.5 few days ago, I logged in today in the admin page and I see this:

Version Information:
Forum version: SMF 2.0.5
Current SMF version: SMF 1.1.18

Why is the current pointing to 1.1.x ? Is there a way to fix this? May this cause any problems with future upgrades?

emanuele

Because your SMF had a problem while fetching the latest version from the sm.org servers.
Nothing to worry about, it will clean up by itself.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

TrueZone

Thank you for update, you all make a great work !!!!

I want to ask, if i install a new theme, and  i already have modified the previsious theme with some plugins and pacakges. Will remain this modifications, on  the new theme ?

Thank you again!

Kindred

there were no changes to template files

as for your question - it is not relevant to the security patch - but no. If you add a new theme, any mods which affect the templates used by that theme would have to be manually applied
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

SwedishMarch1964

Go to http://photobucket.com

The easy way to upload your avatar. Just click the direct link.

zainilove

such long time not going to this forum
I didn't know if SMF is already on 2.0.5 version

Arantor

Quote from: zainilove on September 24, 2013, 06:58:10 PM
such long time not going to this forum
I didn't know if SMF is already on 2.0.5 version

The fact this topic is out and says that '2.0.5 patch is released'... yes, SMF is on 2.0.5.
No good deed goes unpunished
All helpful urges should be circumvented

hadesflames

Pretty sure something was lost in translation there =p

azkia

Quote from: Oldiesmann on August 12, 2013, 08:34:06 PM
Dear users,

Simple Machines Forum is pleased to announce the next security update for the SMF 2.0 product line.

To ensure the continued security of your forum it is advised that you update to SMF 2.0.5 without delay. These vulnerabilities do not impact the SMF 1.1.X branch.

If you are running 2.0.4, you can update your forum to 2.0.5 using the built in package manager. You should see the upgrade notification in the admin panel and in the package manager, allowing you to download and install seamlessly. If you don't have a notification about the update, please run the scheduled task "Fetch Simple Machines files" from the administration panel (Admin -> Maintenance -> Scheduled Tasks). You can also download the update for 2.0.4 from the customize site (http://custom.simplemachines.org/upgrades/): smf_patch_2.0.5.tar.gz, and install it using the package manager.

If you use an older version of SMF, you can upgrade it with the full upgrade packages from the downloads page. Note that this will remove all installed mods! It is recommended to use the patch as described above.

As always you can find more instructions on our wiki:
upgrading
patching

Support is available to all users for this upgrade, but it will only be provided in the support board: http://www.simplemachines.org/community/index.php?board=147.0
Please do not use this topic for support related inquiries. 

Charter Members can file a ticket for any assistance or assisted upgrades through the help desk.

Thank you,
SMF Team


thank you,,,,,i like this forum...thanks again to smf team

hanif


ArchKnight

Can this package used to upgrade from 2.0.2?

Kindred

the patch PACKAGE from the package manager? No.
The patches must be applied from version to next version
2.0.2 -> 2.0.3 -> 2.0.4 -> 2.0.5

The large upgrade archive CAN be applied to ANY previous version - but will remove all of your mods in the process.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

ArchKnight

If I upgrade from
2.0.2 -> 2.0.3 -> 2.0.4 -> 2.0.5, I won't lose mods?

Advertisement: