• Welcome to Simple Machines Community Forum. Please login or sign up.
November 26, 2021, 10:56:40 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


dopo l'aggiornamento 2.0.17 non funziona più su smartphone

Started by fmiglius, January 22, 2020, 10:10:58 AM

Previous topic - Next topic

fmiglius

Topic che prosegue dalla lingua inglese (https://www.simplemachines.org/community/index.php?topic=571448.0)

https://forum.riasc.it/

Da quando ho aggiornato all'ultima versione il forum ha problemi di visualizzazione sugli smartphone.
In pratica quando si accede al LOGIN compare una pagina bianca e si ferma tutto.
ciao e un grazie anticipato a chi mi aiuta
Flavio

Questa la situazione attuale

Darknico

Ciao Flavio,
come ti ho già detto, il problema non è solo se accedi da smartphone, anche da desktop hai lo stesso identico problema.
Qualsiasi pagina apri al di fuori dell'index risulta pagina bianca.

Il problema non è solo il login...

Come ti ho già chiesto:
- hai provato a mettere il tema di default, Curve, e vedere se funziona tutto correttamente?
- Il log degli errori di SMF segnala qualcosa?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fmiglius

Non è così,
sia io che tutti gli altri utenti accedono perfettamente da PC a tutte le pagine.
Ci si deve solo riloggare.
Il problema si verifica solo da smartphone (sia IOS che Android)
Anche svuotando la cache del telefono non cambia nulla
Il Log mi segnala un'infinità di errori di tipo indefinito
A rileggerti
Grazie ancora


Darknico

e 3, continui a non fare le prove che ti dico..
diventa inutile andare avanti se non rispondi alle mie domande...

Prova ad accede come visitatore e vedrai che non funziona nulla neanche da desktop
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fmiglius

Quote from: Darknico on January 22, 2020, 12:11:40 PM
e 3, continui a non fare le prove che ti dico..
diventa inutile andare avanti se non rispondi alle mie domande...

Prova ad accede come visitatore e vedrai che non funziona nulla neanche da desktop

Vero, ho provato e da guest non si accede neanche da PC
Schermata bianca.
Quindi qualcosa non è andata a buon fine durante l'aggiornamento?
ciao e grazie ancora
Fla

Darknico

e 4... ti ho fatto delle domande e delle prove da fare e ancora non so nulla...

Quote from: Darknico on January 22, 2020, 10:55:17 AM
Come ti ho già chiesto:
- hai provato a mettere il tema di default, Curve, e vedere se funziona tutto correttamente?
- Il log degli errori di SMF segnala qualcosa?

Anzi, un'ulteriore domanda: nome del tema in uso?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fmiglius

Quote from: Darknico on January 23, 2020, 03:14:39 AM
e 4... ti ho fatto delle domande e delle prove da fare e ancora non so nulla...

Quote from: Darknico on January 22, 2020, 10:55:17 AM
Come ti ho già chiesto:
- hai provato a mettere il tema di default, Curve, e vedere se funziona tutto correttamente?
- Il log degli errori di SMF segnala qualcosa?

Anzi, un'ulteriore domanda: nome del tema in uso?

Il tema in uso si chiama ORANGE.
Ho impostato il tema di default, che in questo caso si chiama WELLCOME ma non è cambiato nulla sia da PC che da Smartphone.
Il tema CURVE non è presente.
Il LOG degli errori segnala pagine e pagine di errori "indefiniti" solo di oggi. Saranno centinaia per ogni giorno
Attendo tue
Fla

Darknico

Quote from: fmiglius on January 23, 2020, 03:33:53 AM
Il LOG degli errori segnala pagine e pagine di errori "indefiniti" solo di oggi. Saranno centinaia per ogni giorno

ehm.. potresti almeno postare qualche errore per capire? Ho lasciato la sfera di cristallo a casa  :P
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fmiglius

Quote from: Darknico on January 23, 2020, 03:51:46 AM
Quote from: fmiglius on January 23, 2020, 03:33:53 AM
Il LOG degli errori segnala pagine e pagine di errori "indefiniti" solo di oggi. Saranno centinaia per ogni giorno

ehm.. potresti almeno postare qualche errore per capire? Ho lasciato la sfera di cristallo a casa  :P

Stavo giusto cercando il modo di scaricare il LOG ma non trovo alcuna istruzione.
Posso fare degli screenshot.



Darknico

Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)



Darknico

Purtroppo non è facile capire cosa è successo ed ho paura che c'è poco da fare..
Dato che da errori in ogni dove, trovare il problema principale è dura!
Quello che consiglierei io è una simil "formattazione", ovvero rimettere su tutti i files originali, cosi dovremmo essere sicuro di farlo tornare a funzionare..

Non è un operazione esente da rischi, infatti prima di farla è meglio fare un backup totale di tutto, ovvero sia files che database

Visto che hai solo 2 mod installate, non vedo grosse cose da ri-applicare (a meno che non hai fatto modifiche manuali, quelle andrebbero perse)

Significa reinstallare SMF, ovviamente non perderesti nulla, né utenti né messaggi, riporti solo il forum come appena installato senza modifiche.
Dimmi prima se è una soluzione che può andarti bene e ti spiego come fare

Altra domanda: versione php in uso?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fmiglius

Quote from: Darknico on January 23, 2020, 06:07:20 AM
Altra domanda: versione php in uso?

Informazioni sulla versione:
Versione installata: SMF 2.0.17 (maggiori dettagli)
Ultima versione disponibile: SMF 2.0.17
Versione GD: bundled (2.1.0 compatible)
Server in cui si trova il database: MySQL
Versione MySQL: 5.6.43-cll-lve
PHP: 7.3.9
Versione server: Apache


E migrare alla 2.1 RC2...?

Darknico

QuotePHP: 7.3.9

Mmhh... SMF non è compatibile con php 7.3.
Quando hai aggiornato? Insieme quando hai aggiornto smf alla 2.0.17?

SMF 2.0.17 è compatibile al massimo a php 7.2

QuoteE migrare alla 2.1 RC2...?

È ancora presto, è una RC
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fmiglius

Quote from: Darknico on January 23, 2020, 08:55:55 AM
QuotePHP: 7.3.9
Mmhh... SMF non è compatibile con php 7.3.
Quando hai aggiornato? Insieme quando hai aggiornto smf alla 2.0.17?
SMF 2.0.17 è compatibile al massimo a php 7.2

io ho aggiornato solo SMF e l'antispam. Probabilmente php si è aggiornato da solo, ma posso riportarlo alla 7.2
E poi si potrebbe fare come dici ossia backuppare tutto e reinstallare exnovo.
Bello sarebbe riuscire a salvare e ricaricare il tema personalizzato.
A rileggerti
Flavio

Darknico

Cominciamo a mettere PHP 7.2 e vediamo come si comporta :)
magari il problema è solo quello
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fmiglius

Quote from: Darknico on January 23, 2020, 10:49:17 AM
Cominciamo a mettere PHP 7.2 e vediamo come si comporta :)
magari il problema è solo quello

fatto, vedi allegato

fmiglius

Ho provato da smartphone e non mi sembra sia cambiato nulla

Darknico

per curiosità, puoi provare ad impostare il forum in lingua inglese e vedere se funziona?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fmiglius

Quote from: Darknico on January 24, 2020, 03:35:33 AM
per curiosità, puoi provare ad impostare il forum in lingua inglese e vedere se funziona?

In inglese funziona perfettamente

Advertisement: