SMF just installed but weird url causing problems

Started by Paula, March 31, 2006, 02:40:14 PM

Previous topic - Next topic


SMF Version: SMF 1.1 RC2
SMF Version: SMF 1.1 RC2

This is probably a daft question and probably simple to sort but as a newbie who can't find the answer in any of the support forums.....Can anyone help?

I recently installed SMF 1.1 RC2, Joomla1.0.8 (separate databases) and bridge 3.20 and everything seems to have installed correctly.  The forum displays correctly ,however when I triy to access discussion board (or anything else) I am greeted with the following error "404: Not found Sorry, but that content could not be found".

I noticed that the url is incorrect when I click on  general discussion board,/

If I take out the first [nofollow], it works correctly

Any ideas as to why the url seems to double up?

Anyone any idea what I've done wrong/how to correct it? Embarrassed

Any advice will be greatly appreciated!

PS I have tried repair_settings.php without any joy.

Forgot to mention the forum is wrapped.


Have you set up the real path for forum at bridge options in joomla?


Yeah..I set the absolute path:- /home/username/public_html/forum


For the bridge to work, you must turn off SEF in SMF.


Thanks for the reply!

I don't have SEF enabled...I double checked by going to admin/features and option settings.
Is there somewhere else I should double check this?

While I was  there I looked in the forum error log and I noticed I have quite a few of the following errors

"8: Undefined index: sa
File: /home/username/public_html/components/com_smf/smf.php
Line: 497

Does this have anything to do with this problem or is it something separate?



Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."


Hi Orstio


I turned off the SEF in Joomla Admin/Global configuratiion and everything is working.. ( week of grief coming to an end).

My partner's not too happy about turning off SEF..will this cause us any problems with search engines?




What SEF engine is that?

The bridge works fine with Joomla's default SEF.  Some people have been able to get it to work with OpenSEF, but not with SEF Advanced enabled.


Hi Orstio

Call me thick...but I'm not quite sure exactly what you mean by the "bridge works correctly with Joomla's default SEF".  It was in Joomla/Admin/Global configuration/SEO that I disabled SEF and by doing so the forum worked correctly.  By default the SEF was set to enabled.

Should I not have changed the default Joomla settings but changed SEF settings somewhere else?

(I'm just worried that I might have caused unknown problems as I was on a Joomla forum earlier and it said to leave SEF enabled and just to make sure that within SMF forum admin that SEF was unchecked)

Sorry to be a pain...but I just need some clarification and then I'll leave your poor head alone!


There are third-party SEF engines you can install, like OpenSEF and 404SEF.

Because your SEF URLs look like this:

It is obviously not the default Joomla SEF.  Default SEF would look like this:,com_smf/Itemid,97

Another problem you will encounter will be related to the fact that you do not have the bridge login module published.  You must unpublish the Joomla login module, and publish the mod_smf_login module.