• Welcome to Simple Machines Community Forum. Please login or sign up.

What is repair_settings.php?

Started by [Unknown], October 13, 2004, 12:54:38 AM

Previous topic - Next topic

JayBachatero

Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Kesvirit

   I got the same error with the new file.   I looked more carefully and the problem was the settings.php was zero bytes.  After copying in each of my backups I found one that worked.  So I'm good now.  Yay for reading the whole thread.

dmacdonald111

I hope I'm in the right post here.

I've just installed SMF 1.1.1 and everything went smoothly with no errors displayed, etc. But it doesn't seem to want to display the graphics;



I have used the repair_settings.php and everything came up with the same settings as suggested. I have checked the mysql database and the admin section and there are no errors at all but the images still won't display.

I have not installed anything other than the forum.

Thanks.

JayBachatero

Did you upload all the files that came with the archive?  Seems like you didn't upload the icons dir. http://www.paid2hyip.com/forum/Themes/default/images/icons/
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

dmacdonald111

I feel like such an idiot! lol. My ftp client actually timed-out and a load of stuff didn't get uploaded at all! Thanks anyhoo. Soz to waste yer time.  :-[

JayBachatero

Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

netlink

hi, can you use MSSQL instead MySQL? I get this error

Cannot connect to the MySQL database server with the supplied data.

If you are not sure about what to type in, please contact your host.
Unknown MySQL server host 'PENTIUM4\SQLEXPRESS' (11004)



and repair settings give me an error too:


Some settings are not being shown because the MySQL connection information is incorrect.

Daniel15

Quote from: netlink on February 23, 2007, 08:04:38 AM
hi, can you use MSSQL instead MySQL? I get this error

Cannot connect to the MySQL database server with the supplied data.

If you are not sure about what to type in, please contact your host.
Unknown MySQL server host 'PENTIUM4\SQLEXPRESS' (11004)



and repair settings give me an error too:


Some settings are not being shown because the MySQL connection information is incorrect.
Currently, SMF is MySQL-only (although the next major version will support multiple database types, it won't be out for a while).
Daniel15, former Customisation team member, resigned due to lack of time. I still love everyone here :D.
Go to smfshop.com for SMFshop support, do NOT email or PM me!

netlink


netlink

does it make conflict if you run both mysql and mssql 2005?

Daniel15

Quote from: netlink on February 23, 2007, 10:07:37 AM
does it make conflict if you run both mysql and mssql 2005?
It shouldn't... You should be able to run both of them on the same PC :)
Daniel15, former Customisation team member, resigned due to lack of time. I still love everyone here :D.
Go to smfshop.com for SMFshop support, do NOT email or PM me!

netlink

thanks Daniel, one more question :D I tried repair settings but they are having problems view the page



but viewing from localhost, I don't have any problem...it shows all the images

Daniel15

It looks like you set the URL (during setup) to "localhost", rather than the correct URL.
Go to Admin Panel → Server Settings and make sure the correct URL is set. Then, go to Admin Panel → Themes and Layout → Themes and Settings, check the URL at the bottom of the page is correct, and click on "Attempt to reset all themes".

If you have any further problems, please make a seperate topic for them (it's not really related to this topic ;))
Daniel15, former Customisation team member, resigned due to lack of time. I still love everyone here :D.
Go to smfshop.com for SMFshop support, do NOT email or PM me!

RawVeganMom

Hello.  I cannot get the repair file to work.  It says Page not found error 404.

I just switched domain names and my smileys and other things are not clickable.  I hope you can help me!

My board: http://therawpath.com/forum/ [nofollow]
"The doctor of the future will give no medicine,
but will interest her or his patients in the care of the human frame,
in a proper diet, and in the cause and prevention of disease."
-Thomas Edison

schzongx

This tools works like magic to me :)

Big Thanks!!!

01smicha

Quote from: CapriSkye on January 14, 2005, 10:32:46 AM

what you have to is download that file, then upload it to your smf's root folder, for example hxxp:yourwebsite.com/smfdir/ [nonactive]


how do you specify it to upload it to there?

donnpipop

Thank you. This topic is very good for us. :-)

wimvincken

Well, it is not true that the repair_settings.php is innocent. It screwed up my board.
http://www.writingcenter3.teamhost.us/index.php

It also reports critical errors, which are not there.
It refers to an error, which does not exist:
Fatal error: Call to undefined function: dropdownquicksearch() in /home/wimvinck/public_html/Sources/Load.php(1851) : eval()'d cod

There is no dropdownquicksearch in Load.php

So, be warned everyone. DON'T USE THE repair_settings.php!

JayBachatero

How did repair_settings.php screw up your board? Seems to me like a mod issue and not an SMF issue.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

wimvincken

There were some problems in the board with some mods.  But the repair_settings.php really brought it to the attention and right now before I need to go to work.

Well, remove all mods in the board and see what happens, not?


Advertisement: