Advertisement:

Author Topic: General support topic for Aeva Media (Latest release: July 28, 2010)  (Read 2619281 times)

Oya

  • Guest
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4720 on: September 03, 2010, 08:04:11 PM »
hmm i thought it should work since thats handled slightly differently

to remove videos throughout the rest of the forum is edits to at least display.php and tinyportal (dont know it to say where it should be changed though but it wont just be the shoutbox) but also probably boardindex.php and messageindex.php on some themes because they process bbcode which means autoembedding is done too

the code to add to those pages is that as posted on the first post of this thread - $context['aeva_disable'] = 1;

Offline str00py

  • Semi-Newbie
  • *
  • Posts: 37
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4721 on: September 03, 2010, 08:09:31 PM »
Can I just add $context['aeva_disable'] = 1; anywhere in the file?

Oya

  • Guest
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4722 on: September 03, 2010, 08:13:14 PM »
no its not as simple as that unfortunately

needs to be inside display() in display.php after the line that calls global $context no idea about tinyportal though sorry

Offline str00py

  • Semi-Newbie
  • *
  • Posts: 37
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4723 on: September 03, 2010, 08:18:24 PM »
I tried several ways but I only get errors now.

Could you please tell me where and what to edit, because I can't get it to work. :(

Code: [Select]
// The central part of the board - topic display.
function Display()
{
global $scripturl, $txt, $db_prefix, $modSettings, $context, $settings;
global $options, $sourcedir, $user_info, $ID_MEMBER, $board_info, $topic;
global $board, $attachments, $messages_request, $language;

Oya

  • Guest
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4724 on: September 04, 2010, 06:31:45 AM »
Code: [Select]
// The central part of the board - topic display.
function Display()
{
global $scripturl, $txt, $db_prefix, $modSettings, $context, $settings;
global $options, $sourcedir, $user_info, $ID_MEMBER, $board_info, $topic;
global $board, $attachments, $messages_request, $language;

$context['aeva_disable'] = 1;

Offline Stop-TussiN

  • Semi-Newbie
  • *
  • Posts: 19
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4725 on: September 04, 2010, 07:05:57 AM »
Hello. Install a SMG and SSI I have this code:
Code: [Select]
function ssi_lastphoto($output_method = 'echo')
{
global $sourcedir, $user_info, $ID_MEMBER, $context, $txt, $galurl, $galurl2, $scripturl, $settings, $db_prefix;

require_once($sourcedir . '/Subs-MGallery.php');
loadMGal_Settings();

if(loadlanguage('MGallery') == false)
loadLanguage('MGallery', 'english');
$items = getMediaItems(0, 10, 'm.id_media DESC');

if ( mGalAllowedTo('access') ) {
if ($items) {

foreach($items as $item) {
echo '
<div class="photolist">
  <a href="' , $galurl , 'sa=item;id=' , $item['id'] , '"><img src="' , $galurl , 'sa=media;id=' , $item['id'] , ';thumb" alt="' , $item['desc'] , '" /></a>
      <div class="photoaut">' , smg_profile($item['poster_id'], $item['poster_name']) , '</div>
</div>';
}
}

How can I specify which album are photos? Please, please help. :)

Offline str00py

  • Semi-Newbie
  • *
  • Posts: 37
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4726 on: September 04, 2010, 02:00:44 PM »
Thanks for all your help so far Oya but I tried the code you gave me but still no luck.
The topic post still has a video. :(

Offline str00py

  • Semi-Newbie
  • *
  • Posts: 37
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4727 on: September 05, 2010, 12:16:46 PM »
Anyone? Please. :(

Offline InsaneMustang

  • Jr. Member
  • **
  • Posts: 296
    • Bama Nation
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4728 on: September 07, 2010, 08:51:29 AM »
I'm sure this has been asked, but I'm not reading 200+ pages... if I have the SMG installed and want to upgrade to this AEVA Media, will I lose my albums and pictures?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4729 on: September 07, 2010, 09:06:46 AM »
InsaneMustang,

So, in other words, you are lazy and can't even be bothered to try search?

Short answer... No.   For the long answer, I suggest you try search.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline InsaneMustang

  • Jr. Member
  • **
  • Posts: 296
    • Bama Nation
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4730 on: September 07, 2010, 09:24:22 AM »
Name calling is cool, I was just wondering if someone could post it faster than I could find it.

I don't mind searching, as I typically do... I was just extremely busy this morning and was looking for the quick answer.

Offline visualuser

  • Jr. Member
  • **
  • Posts: 232
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4731 on: September 07, 2010, 09:24:49 AM »
hallo smf people,

i just install aeva 1.4 in RC3,
but when i make a gallery, there is no option to upload photo.

What did i miss???
(i believe that must something simple but.....)

 :o

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4732 on: September 07, 2010, 09:43:55 AM »
visualuser... (another one which search would have answered)

short answer: permissions in SMF and permission profiles in the gallery admin
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline visualuser

  • Jr. Member
  • **
  • Posts: 232
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4733 on: September 07, 2010, 10:20:37 AM »
Kindred

many thanks!!!

simple for you, but i believe i will spent many hours in order to find the soloution.

Offline InsaneMustang

  • Jr. Member
  • **
  • Posts: 296
    • Bama Nation
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4734 on: September 07, 2010, 10:43:16 AM »
InsaneMustang,

So, in other words, you are lazy and can't even be bothered to try search?

Short answer... No.   For the long answer, I suggest you try search.

Ok, now I tried the search and didn't even find what I needed to know.  Would you mind pointing me in the right direction?

Oya

  • Guest
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4735 on: September 07, 2010, 11:31:50 AM »
Ok, now I tried the search and didn't even find what I needed to know.  Would you mind pointing me in the right direction?

the first post or the mods page will tell you

Offline YogiBear

  • SMF Hero
  • ******
  • Posts: 1,936
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4736 on: September 08, 2010, 05:02:52 AM »
Out of curiousity can anyone tell me what this member was trying to do? If I ask him he's unlikely to give me a straight answer so here's the error code in the admin log...
 
 
8 Undefined index in file ... forums/Sources/Aeva-subs.php Line: 1749
 
I looked up the error code and saw...
 
1749:    $ret[2] = $actions['in'];
 
 
Thanks for any help.  :)
SMF v2.0.15  Mods : Ohara YouTube Embed v1.2.9,  Custom Tab v1.2 , Bakers' Dozen Pages v1.2 , SMFPacks Shoutbox v1.1,  Board Color & Icons v1.1 , Simple Image Upload , Snow & Garland v1.4

Offline str00py

  • Semi-Newbie
  • *
  • Posts: 37
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4737 on: September 09, 2010, 10:54:22 AM »
Can anyone please help me?
How can I prevent embedding videos in my shoutbox and on the forum, so it's just a link and not a video?

I'm still not able to solve this. :(

Offline YogiBear

  • SMF Hero
  • ******
  • Posts: 1,936
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4738 on: September 09, 2010, 11:55:55 AM »
One method is to use {nobbc} tags, str00py, only use [] instead of {}

Thus {nobbc}anysitevideolink{/bobbc}
SMF v2.0.15  Mods : Ohara YouTube Embed v1.2.9,  Custom Tab v1.2 , Bakers' Dozen Pages v1.2 , SMFPacks Shoutbox v1.1,  Board Color & Icons v1.1 , Simple Image Upload , Snow & Garland v1.4

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4739 on: September 09, 2010, 05:03:18 PM »
[nobbc]link[/nobbc]
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor