Advertisement:

Author Topic: "Don't allow post text in notifications" not working...  (Read 4796 times)

Offline echelon3

  • Semi-Newbie
  • *
  • Posts: 15
"Don't allow post text in notifications" not working...
« on: April 12, 2008, 11:35:27 PM »
Hi, I've tried having the box next to Don't allow post text in notifications checked and unchecked, but I still get the PM message in my emails. Not sure if this is a bug or just me....


I'm on SMF 2.0 Beta 3 Public

Offline SleePy

  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,371
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: "Don't allow post text in notifications" not working...
« Reply #1 on: April 20, 2008, 01:54:05 PM »
Is this still happening?
Do you have any mods installed?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline echelon3

  • Semi-Newbie
  • *
  • Posts: 15
Re: "Don't allow post text in notifications" not working...
« Reply #2 on: April 22, 2008, 12:19:16 AM »
Yup and I recently did a clean install. There are no mods installed. I suppose I can edit it's template to make sure...

Offline niko

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,003
  • Gender: Male
    • Madjoki
Re: "Don't allow post text in notifications" not working...
« Reply #3 on: April 22, 2008, 07:55:01 AM »
I think this option doesn't affect PMs.

In PersonalMessage.english.php

You could replace

Code: [Select]
$txt['pm_email'] = 'You have just been sent a personal message by SENDER on ' . $context['forum_name'] . '.' . "\n\n" . 'IMPORTANT: Remember, this is just a notification. Please do not reply to this email.' . "\n\n" . 'The message they sent you was:' . "\n\n" . 'MESSAGE';
with
Code: [Select]
$txt['pm_email'] = 'You have just been sent a personal message by SENDER on ' . $context['forum_name'] . '.' . "\n\n";

Offline echelon3

  • Semi-Newbie
  • *
  • Posts: 15
Re: "Don't allow post text in notifications" not working...
« Reply #4 on: April 22, 2008, 10:42:12 PM »
THanks, I'll try it out