• Welcome to Simple Machines Community Forum. Please login or sign up.

SMF 1.0.3 released

Started by Owdy, March 25, 2005, 03:21:27 AM

Previous topic - Next topic

Owdy

March 25, 2005, 03:21:27 AM Last Edit: March 31, 2005, 03:23:32 PM by Owdy
Simple Machines is happy to bring you the latest update to SMF. As always, it contains some bugfixes. While most of the changes are minor, one of the fixes is important. We strongly suggest that you upgrade to this version, because it's more stable and secure.

What's changed:

  • fixed a few minor issues
  • updated the URL to the lacnic whois server
  • fixed "notify of replies" getting turned off accidentally
  • database error emails weren't always or often sending
  • a few theoretically possible security related issues were tightened down

As always, we would appreciate if you give us constructive feedback about this release, as well as bug reports.

If you are upgrading from 1.0.2, the easiest way to update is through the package manager.  If not, you only need to use the "update" package as it includes only the changed files since 1.0's release. However, if you have any mods installed it would be better to use the "upgrade" package because it contains all the files for an SMF installation. Remember that you can use the "upgrade" package to come from any previous version of SMF, as well as from YaBB SE 1.5.1 or higher.

http://www.simplemachines.org/download.php

Thanks,
Simple Machines
Former Lead Support Specialist

Tarvitsetko apua SMF foorumisi kanssa? Otan työtehtäviä vastaan, lue:http://www.simplemachines.org/community/index.php?topic=375918.0

Thantos

The package manager failed to update $boarddir/index.php correctly

The following needs to be corrected (in smf_1-0-3.mod)


<search for>
$forum_version = 'SMF 1.0.3';
</search for>

<replace>
$forum_version = 'SMF 1.0.3';
</replace>


should be

<search for>
$forum_version = 'SMF 1.0.2';
</search for>

<replace>
$forum_version = 'SMF 1.0.3';
</replace>

[Unknown]

Done, that's what I get for not uploading the one I made just before I left to work and redoing it at home.

-[Unknown]

Bobby


guppy

I've problems using package manager to upgrade due to ftp permission problem but I'm reading up on that, so not an issue.

But I would like to know what files or folders must not be chmod to 777 or if chmod to 777 for upgrading purposes, must be chmod back to the original permission after upgrading?

Thanks!

Tristan Perry

Upgrade went great, apart from updating the update log, although that's never updated correctly for me since the 1.0.1 update? Ah well, thanks all  :)

[Unknown]


Lazy

its not a security risk, if the admin knows what he does. Updating went fine like allways. my member reports that it is running faster now although i see no changes or idea why. but, if member happy, i`m happy. :) bad english, just german, sry.

Trekkie101

Updating..... (Package Manager)

Failed, needs to open stream blady, blah

Il need to run fix ownership again.

guppy

thanks [Unknown] for the link  :)

i've (finally) got to use the package manager with some help from fix_ownership.php hee hee hee  :D

HEB XI 1

March 29, 2005, 09:12:25 AM #10 Last Edit: March 29, 2005, 09:14:01 AM by hebxi1
I am again having issues with getting the package manager to install this patch:

2: fopen("/<root>/community/Sources/News.php", "w") - Permission denied
File: /<root>/community/Sources/Subs-Package.php
Line: 1454


Would fix_ownership help with this or is it something else?

Cypher7

the SMF news needs to be updated :P

QuoteNews: If you're not yet using the latest version, SMF 1.0.2, please upgrade as soon as possible.

Daniel D.

Quote from: hebxi1 on March 29, 2005, 09:12:25 AM
I am again having issues with getting the package manager to install this patch:

2: fopen("/<root>/community/Sources/News.php", "w") - Permission denied
File: /<root>/community/Sources/Subs-Package.php
Line: 1454


Would fix_ownership help with this or is it something else?
CHMOD 666 or 777 for News.php

LiroyvH

Thanks SMF Team,
and congratulations ;D
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

eksimba

I'm new to SMF so this was my first opportunity to use the package manager to update my forum, and I have to admit that I'm impressed. I've never been able to apply a forum update so quickly or easily. Kudos to the SMF team!
- Eric

el-brujo

updated  to SMF 1.0.3 (from SMF 1.0.2) without problems via Package Manager.

Han

Update of both my forums from 1.0.2 to 1.0.3 went smoothly.   :)
I updated manual (Not by Package manager)

James Woodcock

manual install a treat, nice one guys and gals ;)

Thantos

March 29, 2005, 10:53:32 AM #18 Last Edit: March 29, 2005, 04:49:52 PM by [Unknown]
Using the following link
http://www.twilightavengers.com/forum/index.php?action=pgdownload;auto;package=http://mods.simplemachines.org/downloads/smf_1-0-3_package.tar.gz;sesc=...

I get the following error:
QuoteAn Error Has Occurred!   
The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

DoctorToxn

Thank you so much.  I think that SMF will out do any and all the other forums(Paid or Free).  Hope to see verson 1.1 soon.

BuilderDan

Advertisement: