• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 06:42:37 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


Simple ImageShack (latest release: v3.1.3)

Started by Rik©, June 03, 2005, 02:50:34 PM

Previous topic - Next topic

firstsrgt

lol i did change the file permission to 644 and now this the error i get

QuoteForbidden

You don't have permission to access /forum/sis/SISiframe.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Thank you very much for all those fast response about this issue

firstsrgt

 OK i just got thank you for all your help in my case the permission i need it is 755 or 655 depending on your server

Thanks for everyone help

Rik©

Quote from: firstsrgt on February 19, 2010, 06:46:01 PM
OK i just got thank you for all your help in my case the permission i need it is 755 or 655 depending on your server

Thanks for everyone help
For most users it should work with 755 or 777.

-Rik©

Rik©

Quote from: aw06 on February 19, 2010, 11:32:43 AM
Ok thanks .. guess will wait for next release .. really want it to remain outside of additional options ...
Well, i have SIS v3.0.2 ready for release.
With this version you can choose to put the mod inside or outside the Additional Options.
I only need to translate some $text and then i will release it.

-Rik©

virtualband.ru

February 19, 2010, 08:44:43 PM #404 Last Edit: February 19, 2010, 08:52:40 PM by virtualband.ru
Quote
Forbidden

You don't have permission to access /forum/sis/SISiframe.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I've just tested 3.0.1 on another host with 666 permission in ./sis directory. This is the error I've got:

CGI Script Error
File is writable by others. CGI must have a permission mask to 0755

So I think 755 should do the trick.

virtualband.ru

Translation into Russian language (utf-8)

Rik©

Quote from: virtualband.ru on February 19, 2010, 08:44:43 PM
Quote
Forbidden

You don't have permission to access /forum/sis/SISiframe.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I've just tested 3.0.1 on another host with 666 permission in ./sis directory. This is the error I've got:

CGI Script Error
File is writable by others. CGI must has a permission mask to 0755

So I think 755 should do the trick.
For most of us yes (or 777)
And thank you for the translation, i'll add it to SIS 3.0.2 and release it this weekend.

-Rik©

vroum

This is a great mod man ! Thank you very much !!!  ;)

Btw, there's a little error during the installation.
Here's what it says:

Error in Package Installation
At least one error was encountered during a test installation of this package.
It is strongly recommended that you do not continue with installation unless you know what you are doing,
and have made a backup very recently.
This error may be caused by a conflict between the package you're trying to install and another package you have already installed,
an error in the package, a package which requires another package that you don't have installed yet,
or a package designed for another version of SMF.


And I see that I miss some language packs...
Installing this package will perform the following actions:
Type Action Description
1. Create Tree ./sis
2. Extract Tree ./sis
3. Execute Modification ./Sources/ModSettings.php Test successful
4. Execute Modification ./Sources/ManagePermissions.php Test successful
5. Execute Modification ./Themes/default/Post.template.php Test successful
6. Execute Modification ./Themes/default/languages/ModSettings.english.php Test successful
7. Execute Modification ./Themes/default/languages/Help.english.php Test successful
8. Execute Modification ./Themes/default/languages/ManagePermissions.english.php Test successful
9. Execute Modification ./Themes/default/languages/ModSettings.dutch.php Skipping file
10. Execute Modification ./Themes/default/languages/Help.dutch.php Skipping file
11. Execute Modification ./Themes/default/languages/ManagePermissions.dutch.php Skipping file
12. Execute Modification ./Themes/default/languages/ModSettings.portuguese_pt.php Skipping file
13. Execute Modification ./Themes/default/languages/Help.portuguese_pt.php Skipping file
14. Execute Modification ./Themes/default/languages/ManagePermissions.portuguese_pt.php Skipping file
15. Execute Modification ./Themes/default/languages/ModSettings.english-utf8.php File not found
16. Execute Modification ./Themes/default/languages/Help.english-utf8.php File not found
17. Execute Modification ./Themes/default/languages/ManagePermissions.english-utf8.php File not found
18. Execute Modification ./Themes/default/languages/ModSettings.dutch-utf8.php Skipping file
19. Execute Modification ./Themes/default/languages/Help.dutch-utf8.php Skipping file
20. Execute Modification ./Themes/default/languages/ManagePermissions.dutch-utf8.php Skipping file
21. Execute Modification ./Themes/default/languages/ModSettings.greek-utf8.php Skipping file
22. Execute Modification ./Themes/default/languages/Help.greek-utf8.php Skipping file
23. Execute Modification ./Themes/default/languages/ManagePermissions.greek-utf8.php Skipping file
24. Execute Modification ./Themes/default/languages/ModSettings.portuguese_pt-utf8.php Skipping file
25. Execute Modification ./Themes/default/languages/Help.portuguese_pt-utf8.php Skipping file
26. Execute Modification ./Themes/default/languages/ManagePermissions.portuguese_pt-utf8.php Skipping file
27. Execute Code SISv301_add_settings.php


How can this problem be solved ?

How can I integrate a new language ? Do i need to translate the whole thing or just the GUI seen by the members ?

Out of topic: If you can post some links on how to get started with smf programming & the release of mods, it'd be great, i'm learning php/mysql & don't know where to find the class diagrams & all what is needed that i don't know i need yet...etc  :).

Thanks millions for such a great mod & i'm waiting  for you to add the "auto insert URL" function to an already great mod !

Regards,
Vroum.

Rik©

Quote from: vroumBtw, there's a little error during the installation.

And I see that I miss some language packs...
How can this problem be solved ?
How can I integrate a new language ? Do i need to translate the whole thing or just the GUI seen by the members ?
I forgot to 'tell' the mod-package to 'skip' the 3 english-utf8 files if they're not installed.
And since you are using normal english the Package Manager will show an error.

You don't need to install or write any new language.
I will add the fix for this bug to SIS3.0.2 which i will release later today.

QuoteOut of topic: If you can post some links on how to get started with smf programming & the release of mods, it'd be great, i'm learning php/mysql & don't know where to find the class diagrams & all what is needed that i don't know i need yet...etc  :).
The first thing i did when i started coding for SMF was getting familiar with the way the Package Manager handles mod-packages.
-> Package SDK

Also read the SMF Online Manual. Especially the Into the Depths of SMF section.
And if you need help with customizing SMF you can always ask for help here @ the official SMF forum.
You will find out that the SMF staff and community is always willing to help and/or answer your questions.

-Rik©

vroum

February 21, 2010, 09:52:01 AM #409 Last Edit: February 21, 2010, 02:54:30 PM by vroum
Hi Rik© !

Thanks for the info, man, you've showed me the front door to the SMF coding world.

Regards,
Vroum.

FragaCampos

Rik©, I was finally able to install this mod, but i get a 500 error when opening the Imageshack window.
I set all the files and folders to 777, but the problem still persists. Do you have any clue about what's happening, maybe a server side problem?

Rik©

Quote from: FragaCampos on February 21, 2010, 09:09:38 PM
Rik©, I was finally able to install this mod, but i get a 500 error when opening the Imageshack window.
I set all the files and folders to 777, but the problem still persists. Do you have any clue about what's happening, maybe a server side problem?
Yes.
It's a permission issue.
Try setting the SIS folder to 755 or 655.

-Rik©

Rik©

SIS 3.0.2 is ready for release  ;D

It has a new $txt that needs to be translated:
$txt['SimpleImageShack_addops'] = 'Display Simple ImageShack inside the Additional Options';

Tonight i will release it, hope the translators can translate before release.
Otherwise i will use Google Translate.

-Rik©


FragaCampos

February 22, 2010, 12:47:59 PM #414 Last Edit: February 22, 2010, 01:31:30 PM by FragaCampos
Quote from: Rik© on February 22, 2010, 02:31:59 AM
Yes.
It's a permission issue.
Try setting the SIS folder to 755 or 655.

Thanks, it worked with 755 ;)

Quote from: Rik© on February 22, 2010, 04:53:26 AM
It has a new $txt that needs to be translated:
$txt['SimpleImageShack_addops'] = 'Display Simple ImageShack inside the Additional Options';

Portuguese:
$txt['SimpleImageShack_addops'] = 'Mostrar o Simple ImageShack no interior das Opções Adicionais';

Btw, there's an error in SIS.portuguese.php, where it reads <img src='image_add.png' alt='' /> it should read <img src='./img/image_add.png' alt='' />

Rik©

February 22, 2010, 10:12:10 PM #415 Last Edit: February 23, 2010, 11:47:13 AM by Rik©
Quote from: FragaCampos on February 22, 2010, 12:47:59 PM
Portuguese:
$txt['SimpleImageShack_addops'] = 'Mostrar o Simple ImageShack no interior das Op&ccedil;&otilde;es Adicionais';
Thanks. I'll add it to 3.0.2
Quote from: FragaCampos
Btw, there's an error in SIS.portuguese.php, where it reads <img src='image_add.png' alt='' /> it should read <img src='./img/image_add.png' alt='' />
Thanks again. :D
Will be fixed with 3.0.2 release.

-Rik©

Rik©

Added another $txt
$helptxt['SimpleImageShack_addops'] = 'This option allows you to put the mod inside the Additional Options';

-Rik©


aussieherps

Hey guys
Installed SIS301 on to my SMF1.1.11 board and under additional  Options I get this error message.
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@aussieherps.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at aussieherps.com Port 80

Get that in three text area boxes. Any help is appreciated.
Link to my site is aussieherps.com

Thanks
Todd
http://aussieherps.com">snakes lizards spiders turtles and much more

virtualband.ru

Quote from: aussieherps on February 24, 2010, 06:04:50 AM
Hey guys
Installed SIS301 on to my SMF1.1.11 board and under additional  Options I get this error message.
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@aussieherps.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at aussieherps.com [nofollow] Port 80

Get that in three text area boxes. Any help is appreciated.
Link to my site is aussieherps.com [nofollow]

Thanks
Todd

Set php files' permission in the Sis folder to 755

Advertisement: