• Welcome to Simple Machines Community Forum. Please login or sign up.

SMF 1.0.6 Released

Started by Grudge, January 28, 2006, 06:39:21 AM

Previous topic - Next topic

Grudge

January 28, 2006, 06:39:21 AM Last Edit: January 30, 2006, 06:46:03 PM by Daniel D.
Simple Machines is happy to release a new update to Simple Machines 1.0. This release addresses a cross-site scripting vulnerability in 1.0, as well as fixing a few bugs caught since the release of 1.0.5.

Important Note for Users of SMF 1.1
This release does not effect anyone currently running SMF 1.1 - do not run this update!


You can update to SMF 1.0.6 in one of three ways:
  • Use the package manager in your administration center - one click, and you're done.
  • Download the update archive file from the download page, and upload all of the files from it.
  • Download the modification file, attached to this message, and modify the files manually according to it.

    Please note, the patch file includes both the PHP 4.4.0 and MySQL 5.0.12 compatibility updates released over the last few months - and should install fine regardless of whether the compatibility patches have been installed previously.

    Regards,

    Simple Machines
I'm only a half geek really...

Tech o.O;

Awesome!

Would we lose our current installed mods when we upgrade?


Join my awesome forums!

Random userbar generator:


Owdy

January 28, 2006, 07:15:06 AM #3 Last Edit: January 30, 2006, 10:21:54 AM by Owdy
All 1.1 users, please read that part :)

QuoteImportant Note for Users of SMF 1.1
This release does not effect anyone currently running SMF 1.1 - do not run this update!
Former Lead Support Specialist

Tarvitsetko apua SMF foorumisi kanssa? Otan työtehtäviä vastaan, lue:http://www.simplemachines.org/community/index.php?topic=375918.0

Daniel15

I'm glad that I'm one of the first people to upgrade to SMF 1.0.6 :D
Keep up the good work SMF :)

Why is the SMF 1.0.5 released topic still pinned, and this one isn't?

<offtopic>Also, why isn't SMF 1.0.5 in my forum's change log?
Daniel15, former Customisation team member, resigned due to lack of time. I still love everyone here :D.
Go to smfshop.com for SMFshop support, do NOT email or PM me!

Tech o.O;

I can't seem to install it on my 1.0.5 board >:O

An Error Has Occurred!

The package you are trying to download or install is either corrupt or not compatible with this version of SMF. 


Join my awesome forums!

Random userbar generator:

Grudge

127.0.0.1, that's interesting. Is that the one you try install via package manager or one you downloaded from the first post here? It works fine for me, can you try downloading again?

daniel15 - 1.0.5 never made it into the changelog - I believe as it was only a security fix which we tend not to changelog.
I'm only a half geek really...

trikos

What is a cross-site scripting vulnerability?

Harzem

Please update the "news" above, it still says

"If you're not yet using the latest version, SMF 1.0.5, please upgrade as soon as possible." :)

Tech o.O;

I went to the admin panel, that red texted message showed up so I clicked the link to upgrade and then I got the error.

I already downloaded the 1.0.6 upgrade package, but I didn't want to upload it yet because in case I might lose some installed mods.  Better yet my custom smilies and skin.

Is there a way to install the package manually without losing custom smilies/skins?


Join my awesome forums!

Random userbar generator:

Owdy

Former Lead Support Specialist

Tarvitsetko apua SMF foorumisi kanssa? Otan työtehtäviä vastaan, lue:http://www.simplemachines.org/community/index.php?topic=375918.0

Dexy

i have installed 1.0.6 but it says that i use smf 1.0.5. all file    Description are Success. where is problem?

dtm.exe

Quote from: Dexy on January 28, 2006, 08:10:47 AM
i have installed 1.0.6 but it says that i use smf 1.0.5. all file    Description are Success. where is problem?

1.0.5 all file?  You should be OK.

Dexy

Why is then: "Forum version: SMF 1.0.5" and in bottom "Powered by SMF 1.0.5." ???

dtm.exe

Quote from: Dexy on January 28, 2006, 08:26:50 AM
Why is then: "Forum version: SMF 1.0.5" and in bottom "Powered by SMF 1.0.5." ???

OK, you didn't mention that in your original post.  Try running the upgrade again.

Dexy


dtm.exe

Quote from: Dexy on January 28, 2006, 08:40:33 AM
i tried 10 times!  :(

Could you please provide a link to your forum, and could you please PM or email me the login details of a test admin account?

Dexy


Grudge

Dexy,

You forgot to upload index.php in the root forum directory.
I'm only a half geek really...

Dexy

January 28, 2006, 09:25:58 AM #19 Last Edit: January 28, 2006, 09:28:02 AM by Dexy
Quote from: Grudge on January 28, 2006, 09:18:05 AM
Dexy,

You forgot to upload index.php in the root forum directory.

i don't understand... index.php is in root directory, and i don't install mode manual, i follow link in: " It is recommended that you update your forum"

Advertisement: