• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 09:40:35 PM

News:

Follow SMF on Twitter.


SMF 1.0.6 Released

Started by Grudge, January 28, 2006, 06:39:21 AM

Previous topic - Next topic

mrselnombre

January 28, 2006, 09:51:35 AM #20 Last Edit: January 28, 2006, 09:56:01 AM by mrselnombre
I did too, and mine is still telling me to upgrade. I even checked the files manually (due to a clash with the spider mod, i had to do ssi.php manually)

But it is still telling me to upgrade...

In fact it still tells me ssi.php has failed.. and  "FTP Information Required"
which goes in a constant loop.

But bizarrely enough in the Package Manager - Install Actions halfway down the list SSI.php is mentioned again as a success.
(\__/)
(='.'=)This is Bunny. Copy and paste bunny into your
(")_(")signature to help him gain world domination.
Total Twaddle.

Grudge

Well, the mod file most certainly should update index.php file in the root directory of your forum, so that this line:

$forum_version = 'SMF 1.0.5';


is changed to this line:

$forum_version = 'SMF 1.0.6';


Are you sure you hit "proceed" after clicking the link? When you click the "update" link it first takes you to a page with lots of:
"success" words listed - you *then* need to click proceed to actually install the patch.
I'm only a half geek really...

Mizery1

Quote from: Grudge on January 28, 2006, 09:58:12 AMAre you sure you hit "proceed" after clicking the link? When you click the "update" link it first takes you to a page with lots of:
"success" words listed - you *then* need to click proceed to actually install the patch.
In my list it showed SSI.php and Sources/Subs.php as Failures but doing Proceed seems to have worked ok. Everything shows as upgraded to 1.0.6.

Cheese-Burger

January 28, 2006, 10:12:46 AM #23 Last Edit: January 28, 2006, 10:14:41 AM by Cheese-Burger
I got a failure in SSI.php and changelog.txt, but procedded anyway, and it now shows up twice in my package manager. Should i just delete one of them?
Hate code. Love burgers

Cheese-Burger

Just uninstalled one of them and i revert to 1.0.5 so i applied mod again lol. Any help on the failures would be nice.
Hate code. Love burgers

RoarinRow

Quote from: Mizery1 on January 28, 2006, 10:02:23 AM
Quote from: Grudge on January 28, 2006, 09:58:12 AMAre you sure you hit "proceed" after clicking the link? When you click the "update" link it first takes you to a page with lots of:
"success" words listed - you *then* need to click proceed to actually install the patch.
In my list it showed SSI.php and Sources/Subs.php as Failures but doing Proceed seems to have worked ok. Everything shows as upgraded to 1.0.6.

I got a Failure for SSI.php and Subs.php as but did not click on Proceed.  What should I do to resolve before proceeding?

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

ivo2296

Hello,

Is anyone here who has installed the update without problems?


Thank you!

junglecat

I'll watch this topic for a while before I dare upgrade.

I deal with a number of scripts, not just SMF, and I've learned the hard way to hold back on upgrading a script until all the bugs are worked out.
PM me for affordable hosting. I will install your SMF forum with your choice of a theme for FREE.
~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~
Join us at Christian Discussions 
~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~

Daniel D.

January 28, 2006, 10:44:24 AM #28 Last Edit: January 28, 2006, 10:46:31 AM by Daniel D.
After selecting "click here to install" the package manager said "Successful" to all files. I didn't install it and went back to the admin centre, but the mod is listed in the package manager, even if I didn't install it.

The update went without problems. 1.0.6 is running.

Grudge

The mod will be listed in the package manager if you don't click proceed - but will not have a green dot next to it.

For people having failures in Subs.php - do you have mods installed? This replaced quite a bit of bbc parsing which other mods may have affected. Also - you must *already* be on 1.0.5 for the patch file to work.
I'm only a half geek really...

ivo2296

"Package Manager:

Latest packages
A bbc security issue has been identified in SMF 1.0.5. You can install this patch (click here to install) to easily update yourself to the latest version.

If you have any problems applying it, you can use the version posted on the downloads page - although, any modifications you have installed will need to be uninstalled. Please post on the forum if you need more help."

This sounds not good to me - i have done a lot of work to install some mods and modifications.
If i have to reinstall all, i won't run 1.0.6 update.

Daniel D.

Quote from: Grudge on January 28, 2006, 10:47:37 AM
The mod will be listed in the package manager if you don't click proceed - but will not have a green dot next to it.
Hehe, the other admin on the board I support changed some pics in the custom theme so that the dots are not displayed anymore. Hahaha!! Damn, I've to use SMF more than one time in a month ;D :P...

Quote from: ivo2296 on January 28, 2006, 10:53:01 AM
"Package Manager:

Latest packages
A bbc security issue has been identified in SMF 1.0.5. You can install this patch (click here to install) to easily update yourself to the latest version.

If you have any problems applying it, you can use the version posted on the downloads page - although, any modifications you have installed will need to be uninstalled. Please post on the forum if you need more help."

This sounds not good to me - i have done a lot of work to install some mods and modifications.
If i have to reinstall all, i won't run 1.0.6 update.
Try to change the files manually with the insctructions in the files.

RoarinRow

I noticed that subs.php and ssi.php is listed twice after attemping the install.

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

Luke

Quote from: ivo2296 on January 28, 2006, 10:32:22 AM
Hello,

Is anyone here who has installed the update without problems?


Thank you!

I've ran through the package manager on 7 different sites, that are also using Enigma 2, without any problems at all.


Cheese-Burger

Quote from: Grudge on January 28, 2006, 10:47:37 AM
The mod will be listed in the package manager if you don't click proceed - but will not have a green dot next to it.

For people having failures in Subs.php - do you have mods installed? This replaced quite a bit of bbc parsing which other mods may have affected. Also - you must *already* be on 1.0.5 for the patch file to work.


What about the SSI.php and changelog.txt failures?

Heres a list of my packages:--------------------------

Modification Packages
      Mod Name    Version     
1.    SMF 1.0.4 Update Package                1.0.4                     [ List Files ] [ Delete ]
2.    OnLine Users Today                             1.3                   [ Uninstall ] [ List Files ] [ Delete ]
3.    Member Color Link                              1.81                    [ Uninstall ] [ List Files ] [ Delete ]
4.    Jack's Phat Calendar Pack                  1.0.2                [ Uninstall ] [ List Files ] [ Delete ]
5.    Googlebot & Spiders Mod                 1.0.2                [ Uninstall ] [ List Files ] [ Delete ]
6.    SMF 1.0.5 Update Package                1.0.5                       [ List Files ] [ Delete ]
7.    PHP 4.4.0 Compatibility Update               1.0                               [ List Files ] [ Delete ]
8.    MySQL 5.0.12 Compatibility Update    1.0                           [ List Files ] [ Delete ]
9.    TinyPortal                                             0.75                           [ List Files ] [ Delete ]
10.    TinyPortal                                            0.82                          [ List Files ] [ Delete ]
11.    SMF 1.0.6 Update                              1.0                          [ Uninstall ] [ List Files ] [ Delete ]
12.    SMF 1.0.6 Update                              1.0                         [ Uninstall ] [ List Files ] [ Delete ]
Installed mods: current version older version
Hate code. Love burgers

Bitwiz44

Mine went ok... However the shout box quit displaying "Shouts"..  :-\

MuddHarryS

I tried to run the update and I get a list of successes prior to clicking the "proceed" button.

It tells me "Some of the files this package needs to modify are not writable. This needs to be changed by logging into FTP and chmoding the files."

I put in my ftp info, click Proceed and nothing happens. I do see the tar file in my packages directory on the server. But not showing any signs of update. So the one click doesn't seem to be doing it for me.

Any thoughts? This will be my first time upgrading an SMF forum so I am not sure what I should be seeing. (I used phpBB2 for a few years and SMF smokes it).

Thanks,
Mudd

Shaman

My upgrade went first time, no issues.

RoarinRow

Another member told me that googlebots and spiders will cause the update to fail in SSI.php.

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

dtm.exe

Quote from: RoarinRow on January 28, 2006, 11:25:00 AM
Another member told me that googlebots and spiders will cause the update to fail in SSI.php.

It's possible, depending on whether or not that mod has modified SSI.php in the past.  Try uninstalling that mod.  What other mods do you have installed?

Advertisement: