• Welcome to Simple Machines Community Forum. Please login or sign up.

SMF 1.0.6 Released

Started by Grudge, January 28, 2006, 06:39:21 AM

Previous topic - Next topic

RoarinRow

Quote from: dtm.exe on January 28, 2006, 11:29:25 AM
Quote from: RoarinRow on January 28, 2006, 11:25:00 AM
Another member told me that googlebots and spiders will cause the update to fail in SSI.php.

It's possible, depending on whether or not that mod has modified SSI.php in the past.  Try uninstalling that mod.  What other mods do you have installed?

Here's what's there now.  I deleted the 1.0.6 patch update mod before reading your reply.

1. SMF Arcade 1.2.1                      [ Uninstall ] [ List Files ] [ Delete ] 
2. Faster Parsecode 1.09             [ Uninstall ] [ List Files ] [ Delete ] 
3. Gmail Field 1.1                          [ Uninstall ] [ List Files ] [ Delete ] 
4. Integrated Chat 2.3                 [ Uninstall ] [ List Files ] [ Delete ] 
5. Ultimate Shoutbox 1.31            [ Uninstall ] [ List Files ] [ Delete ] 
6. OnLine Users Today 1.3            [ Uninstall ] [ List Files ] [ Delete ] 
7. Googlebot & Spiders Mod 1.0.4   [ Uninstall ] [ List Files ] [ Delete ] 
8. Board Notes 1.0.2                       [ Uninstall ] [ List Files ] [ Delete ] 
9. TinyPortal 0.75                            [ Uninstall ] [ List Files ] [ Delete ] 
10. Hide Post 1.0.4                          [ Uninstall ] [ List Files ] [ Delete ] 
11. Personal Message Auto Responder 0.2   [ Uninstall ] [ List Files ] [ Delete ] 

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

maddancer

Quote from: Grudge on January 28, 2006, 06:39:21 AM
  • Download the modification file, attached to this message, and modify the files manually according to it.
I've got a heavily modded version online and need the modification file to make the edits manually, but I don't see it here anywhere. Am I missing something?

dtm.exe

RoarinRow, why don't you try to upload the SSI.php from the 1.0.5 download archive?  If one of your mods stops working after you apply the 1.0.6 patch, reinstall it :).

dtm.exe

Quote from: maddancer on January 28, 2006, 11:32:43 AM
Quote from: Grudge on January 28, 2006, 06:39:21 AM
  • Download the modification file, attached to this message, and modify the files manually according to it.
I've got a heavily modded version online and need the modification file to make the edits manually, but I don't see it here anywhere. Am I missing something?

Here you are, maddancer :).

smf_1-0-6_package.tar.gz

RoarinRow

Quote from: dtm.exe on January 28, 2006, 11:39:39 AM
RoarinRow, why don't you try to upload the SSI.php from the 1.0.5 download archive?  If one of your mods stops working after you apply the 1.0.6 patch, reinstall it :).

Thanks dtm.  I thought about that, but at this point I'm just gonna wait and see.

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

dtm.exe

Quote from: RoarinRow on January 28, 2006, 11:45:03 AM
Thanks dtm.  I thought about that, but at this point I'm just gonna wait and see.

RoarinRow, you have absolutely nothing to lose.  Simply perform a backup and then upgrade :).  If things go wrong, simply revert to the backup :).

RoarinRow

Quote from: dtm.exe on January 28, 2006, 11:46:24 AM
Quote from: RoarinRow on January 28, 2006, 11:45:03 AM
Thanks dtm.  I thought about that, but at this point I'm just gonna wait and see.

RoarinRow, you have absolutely nothing to lose.  Simply perform a backup and then upgrade :).  If things go wrong, simply revert to the backup :).

I'll continue to test it out on my test forum.  Thanks for your confidence in the patch.

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

Cheese-Burger

The bots n spiders, tp and users online today still work ok.

So far as far as i can tell it all seems fine. Wierd that i have 2 lots in my pack m now though.
Hate code. Love burgers

dtm.exe

Quote from: Cheese-Burger on January 28, 2006, 11:55:09 AM
The bots n spiders, tp and users online today still work ok.

So far as far as i can tell it all seems fine. Wierd that i have 2 lots in my pack m now though.

Two lots in your pack m?

BigJacko

As ever, my thanks to the SMF-devs, for tending to our needs and issuing this patch. Good on ya! ;)

I have done my upgrade, and mostly all is well, but I have one question if someone can advise?

My forum usually doesn't like being patched using the package-manager, and this was no exception. I generally get a warning about certain chmod privs needing to be modified, and asking for the FTP server login details, which I dutifully enter, but it always seems to just refresh the page and ask for the same info again.

Not too bothered about that bit, because I am used to doing it via the back-end, from the days of YaBBSE, and if anything, the process is usually just as sweet as the package-manager route (which I have seen working on a 'local' forum, so I know it's sweet, see? ;))

This time, however, I did not select the option to mess with the 'Classic YaBBSE Theme', when running upgrade.php. Everything else finished ok, but when I check the version numbers, I am told that the 'Classic' version is out-of date, specifically the file recent.template.php which is 1.0 instead of 1.0.1.

Thing is, I looked in the distribution zip which I downloaded for the update, and THAT also has the theme\classic\recent.template.php showing up as v1.0 in the file, so I'm a little confused as to what to replace my 'live' copy with.

I tried various things (using that one, and using the one inside the 'default' theme, but in all cases, my forum's 'version-check' widget still shows up as v1.0 in red.

I notice I also have a theme called 'Converted', but which I'm not sure if it is in use or not, really!  :-[ I'm a little wary in case I mess something up, if I start twiddling with that one. I think it's probably the one I created when I first upgraded my YaBBSE board to one of the pre-1.0 SMF versions. I think also, at some point in the past (possibly the second SMF patch), I got confused by the 'Convert Theme' option in the upgrade.php process, and that's how I have developed this phobia about the 'Converted' theme bit. I've never really wanted to risk messing with it, in case it affected my users - most of whom have only ever known or used the old YaBBSE layouts, and haven't taken the opportunity to experience the forum in the new 'SMF-provided' ways! :D

Any advice appreciated - what file should I change, and with what?

Thanks
This area zoned for redevelopment. Apply City Planning Dept. Brown envelopes preferred if bringing bribes.

dtm.exe

BigJacko, overwriting your current Recent.template.php with the 1.0.6 version (if there is one) would not be a problem at all :).

When you change your theme to the "Converted" theme, what does it resemble?

RoarinRow

Quote from: RoarinRow on January 28, 2006, 11:52:05 AM
Quote from: dtm.exe on January 28, 2006, 11:46:24 AM
Quote from: RoarinRow on January 28, 2006, 11:45:03 AM
Thanks dtm.  I thought about that, but at this point I'm just gonna wait and see.

RoarinRow, you have absolutely nothing to lose.  Simply perform a backup and then upgrade :).  If things go wrong, simply revert to the backup :).

I'll continue to test it out on my test forum.  Thanks for your confidence in the patch.

I removed Googlebots and Spiders and the patch was successfully installed on my test site.  However, I can not re-install the same mod since it's not compatible with the update version 1.0.6.   I could probably try to manaully install mod.

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

dtm.exe

Quote from: RoarinRow on January 28, 2006, 12:09:07 PM
I could probably try to manaully install mod.

That would work :).

RoarinRow

Quote from: dtm.exe on January 28, 2006, 12:12:47 PM
Quote from: RoarinRow on January 28, 2006, 12:09:07 PM
I could probably try to manaully install mod.

That would work :).

On my main site, how can I resolve the Subs.php failure.   Removal of Googlebots resolved the SSI.php issue, just one more left.  :)

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

dtm.exe

Quote from: RoarinRow on January 28, 2006, 12:15:47 PM
On my main site, how can I resolve the Subs.php failure.   Removal of Googlebots resolved the SSI.php issue, just one more left.  :)

Try removing Faster Parsecode.

minstrel

Quote from: ivo2296 on January 28, 2006, 10:32:22 AM
Hello,

Is anyone here who has installed the update without problems?


Thank you!
Here  :) It took about 15 seconds and went without a hitch.

Now the only thing is that when I try to upload new packages (mods) using the Package manager I am getting errors. Everything else works as it should.

RoarinRow

Quote from: dtm.exe on January 28, 2006, 12:18:25 PM
Quote from: RoarinRow on January 28, 2006, 12:15:47 PM
On my main site, how can I resolve the Subs.php failure.   Removal of Googlebots resolved the SSI.php issue, just one more left.  :)

Try removing Faster Parsecode.

Alright, thanks!

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

Cool Surfer

www.xpindia.com ; www.onlinemedicalforum.com/smf 

Be Kind And courteous To People On Your Way Up
For You Might Meet Them On Your Way Down...

1MileCrash

update went good, but...

it modifies SSI.php. I made a copy of ssi.php, and modified it alot to use it on my site. Should i make them same changes that the update did to SSI.php, or is it not that big a deal?
The only thing php can't do is tell you how much milk is left in the fridge.



loudog

Grudge, can you update shoutbox for version 1.06?? If so I'll wait to install this update, thanks Lou

Advertisement: