• Welcome to Simple Machines Community Forum. Please login or sign up.
September 18, 2021, 03:24:55 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

Heartlander

Here is my issue-
Installed RSS Feed Poster on a clean version of SMF 1.15, and cannot get the cron to follow through.
I get this:
QuoteFatal error: Call to undefined function loadDatabase() in /usr/home/bassman/public_html/heartland/smf/SSI.php on line 73

Any help is greatly appreciated.

dark green

Hi all-

First: I did actually read the thread first to try to find a solution and even tried whatever seemed promising.

The Problem in summary:

A bunch of the RSS feeds I used to use were taken down so I went in and removed them and added a bunch more. This was Sunday. Since then, no updates will post. I have a cron job that had worked for a year and reports as running fine, and I've repeatedly tried running the cronrss.php manually. It seems to run fine, but no posts appear.

Details:

The forums is here: hxxp:ardentresearch.com/forum/index.php?board=24.0 [nonactive]

The cron job automatically mails me the results and seems to run fine (output - "Feed Poster Configuration"), same if I run the cronrss manually.

Some example feeds subscribed:

hxxp:www.nanotechwire.com/news.xml [nonactive]

hxxp:news.google.com/news?hl=en&rls=GGGL,GGGL:2006-35,GGGL:en&q=MEMS&um=1&ie=UTF-8&tab=wn&nolr=1&output=rss [nonactive]

Setting:
No fake cron, 10 items per update, Feed enabled, HTML enabled

Nothing really changed (permissions, paths) when I updated the feeds, so what would cause the feeds to no longer post?

hehe

Hello,

I am interested in translating the mod into greek, how can i do that?

Thanks alot for your help!!! It's a great mod!!!

vbgamer45

Translate I believe just any language files with the mod and the modifications it makes to modificaitons.english.php
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Angelotus

Hello, I use SMF 1.1.5 and get this error after adding a feed:
Table 'md73949db43637.kv_feedbot_log' doesn't exist
File: /storage/mijndomein/users/073949/public/sites/kv.nessekrekers.nl/Sources/Subs-RSS.php
Line: 255


HELP PLEASEEEE!!!!!!

vbgamer45

That means it did not install the tables. Uninstall and reinstall to see if it installs the database tables.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Angelotus

Done that. Somehow it doesn't install all the tables. Can you attach the installcode so I can do it manually?

berwynboris

RSS Feed poster had been working quite well for me for about the last year (version 1.0). Yesterday, I updated the forum to 1.1.6 and the feed poster to 1.1. Now, only 4 of my 10 or so feeds will update. I've tried "reloading" them by deleting and creating from scratch, with no luck.

Any ideas?

Michael D. Garcia

vbgamer:

First of all, this is a fantastic mod.  My members love replying to the news feed posts.

I've added some rather html-rich feeds at their request.  Is there any way to allow feed poster to use the html bbcode tags in certain places?  These newfeed posts are turning into markup-fest instead of readable news posts.

Thanks for any help you can provide and please keep up the great work!

MDg

jimbo007

Quote from: westis on October 08, 2007, 08:54:36 PM
It seems like the mod truncates the text from the blog and only posts the beginning of the text in the forum. How can I have the entire blog post be posted in the forum?

Btw, the feed doesn't truncate, it shows the entire blog post.

Thanks!
I've searched through this forum for a long time now and haven't found a reply to the question asked by westis.
Does anyone know how to fix this? The feed I'm trying to use doesn't truncate either, and shows in full using google reader...

Please help anybody!

J.

Michael D. Garcia

Quote from: jimbo007 on September 12, 2008, 01:10:17 PM
I've searched through this forum for a long time now and haven't found a reploy to the question asked by westis.
Does anyone know how to fix this? The feed I'm trying to use doesn't truncate either, and shows in full uning google reader...

Please help anybody!

J.

Modify the post.  If there's a lot html markup in it without the HTML BBC tags, sometimes it won't show the full post.  I have this problem on my board, except that it tends to show the fully marked up post in some (those without divs in the post), while other are almost completely blank save the URL redirect.

If I put an html tag underneath the title (after the closing bold BBC tag) and close it before the referring URL at the bottom, it tends to show the message as intended.

MDg

jimbo007

Quote from: jimbo007 on September 12, 2008, 01:10:17 PM
Quote from: westis on October 08, 2007, 08:54:36 PM
It seems like the mod truncates the text from the blog and only posts the beginning of the text in the forum. How can I have the entire blog post be posted in the forum?

Btw, the feed doesn't truncate, it shows the entire blog post.

Thanks!
I've searched through this forum for a long time now and haven't found a reply to the question asked by westis.
Does anyone know how to fix this? The feed I'm trying to use doesn't truncate either, and shows in full using google reader...

Please help anybody!

J.

Quote from: Michael D. Garcia on September 12, 2008, 01:18:20 PM

Modify the post.  If there's a lot html markup in it without the HTML BBC tags, sometimes it won't show the full post.  I have this problem on my board, except that it tends to show the fully marked up post in some (those without divs in the post), while other are almost completely blank save the URL redirect.

If I put an html tag underneath the title (after the closing bold BBC tag) and close it before the referring URL at the bottom, it tends to show the message as intended.

MDg

Thanks for answering so quickly, but it doesn't seem to work. This is the feed that I'm trying to use:
http://simio.biz/blog/feed/ [nofollow]

And this is the output:

QuoteJust Enough Agility
     

Agility is the capability to be flexible, responsive, and adaptive to the changes happening around you. When a stakeholder asks you to deliver something you had not planned on, your response is a measure of your agility. But how much agility is enough?
I was once part of an organization that was extremely agile. Whenever anyone [...]
         

http://simio.biz/blog/2008/07/13/just-enough-agility/ [nofollow]

You can see where it has the [...] it's truncated. There is no HTML tags to change.

In all other readers I use, it's in full and not truncated.
Is there any way to stop this from happening? Is there some code I can change?

Thanks for your time,
J.

Michael D. Garcia

Well, I go to the feed, using that link, and the output from the source is this:

Just Enough Agility
Sunday, July 13, 2008 5:56 PM
Agility is the capability to be flexible, responsive, and adaptive to the changes happening around you. When a stakeholder asks you to deliver something you had not planned on, your response is a measure of your agility. But how much agility is enough?
I was once part of an organization that was extremely agile. Whenever anyone [...]


So... the [...] is actually from the source.  The Feed Poster isn't malforming anything.

MDg

jimbo007

Quote from: Michael D. Garcia on September 12, 2008, 02:19:02 PM
Well, I go to the feed, using that link, and the output from the source is this:

Just Enough Agility
Sunday, July 13, 2008 5:56 PM
Agility is the capability to be flexible, responsive, and adaptive to the changes happening around you. When a stakeholder asks you to deliver something you had not planned on, your response is a measure of your agility. But how much agility is enough?
I was once part of an organization that was extremely agile. Whenever anyone [...]


So... the [...] is actually from the source.  The Feed Poster isn't malforming anything.

MDg

It's funny, google reader, feedburner and IE7 pull it in in full, but when I opened it in Firefox it's truncated like you said... so yeah it's not malforming... I wonder is there anything that can be done on the reader side to display it in full?

Thanks
J.

Michael D. Garcia

I don't think there is from the feed poster side.  It can only pull what it sees.  I'm sure Google Reader is more dynamic, being a fully-fledged, feature-rich reader, but I think RSS Feed Poster is simply a straight-up feed shipping mod.

MDg

jimbo007

Quote from: Michael D. Garcia on September 12, 2008, 02:31:04 PM
I don't think there is from the feed poster side.  It can only pull what it sees.  I'm sure Google Reader is more dynamic, being a fully-fledged, feature-rich reader, but I think RSS Feed Poster is simply a straight-up feed shipping mod.

MDg

Just as an update, I added the feed in bloglines, and it gave me the option of "summary if available" or "complete entry". So yeah, the bigger readers seem to have it but I'm not sure if there's anything that can be done. I might have a look around and see if there's some way of implementing this in this mod...

If anyone else has any ideas either?

Thanks MDg,
J.

Michael D. Garcia


Angelotus

Hi, I have installed the tables manually and now all things set. Added a feed and use fake cron jobs. Still the feedbot don't work. On any feed I use.

cmedic

This mod has great potential, but only if I can get it to work properly:)  I am running 1.16 in with a default theme. I currently have this mod installed and the only time that it works is if I put the cron job in the browser...Cron Job Url:  http://www.mysite.com/forum/cronrss.php [nofollow]. after I load the page all posts are updated via RSS feeder. is there a way to have this refresh on its own? I can't seem to find any information on a fix for this awesome mod.


Regards

cmedic

Angelotus

Even that doesn't work me at all...

Advertisement: