News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Optimus

Started by Bugo, February 15, 2011, 03:48:12 PM

Previous topic - Next topic

njtweb

Ok, that's what I did. I wasn't sure if there was a "suggested default config" for starters. Thanks

njtweb

How do you change the meta data open graph image link? I can't it's hard coded. I uploaded the image I want to use to my app on FB and it's not using that either.

njtweb

Couple Questions..... I would've edited my last comment but can't.


- How do you change the meta data open graph image link? I can't it's hard coded. I uploaded the image I want to use to my app on FB and it's not using that either.

- Under base settings/Forum Homepage title. I don't want "- Index" showing in web search results. If I leave it empty there's still a hyphen. Is there anyway to remove the hyphen so just my website title shows up without it in results, (image attached)?

- When I browse to my site in chrome the suffix is index.php?wwwRedirect<--- What is that? It doesn't show that in FF or IE

http://www.youthhockeyinfo.com/index.php?wwwRedirect

alexetgus

Off topic

On the mod page, you should indicate which languages ​​are supported. It would bring you more people. ;)

Kindred

Quote from: njtweb on April 26, 2018, 05:58:49 PM
- When I browse to my site in chrome the suffix is index.php?wwwRedirect<--- What is that? It doesn't show that in FF or IE

http://www.youthhockeyinfo.com/index.php?wwwRedirect

https://wiki.simplemachines.org/smf/WwwRedirect
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

njtweb

Hi @Bugo

What does the portal support do in your mod? I ask because I don't see EZ Portal listed.

Bugo

"Portal support" just means that Optimus can change page titles and/or $context['canonical_url'] on portal frontpages.
I didn't use the last versions of EZ Portal, so I don't know how it works, what is changed, etc.

BillLeeDee

I don't know if this is widespread or not, but when I upgraded from 1.9.6 to 1.9.7.2 or 1.9.7.3 I lost all the open graph tags, regardless of the settings. Reverting back to 1.9.6 returned them to the forum. I didn't check anything else to see what wasn't working with the 1.9.7.x version as when I noticed all my Twitter cards were broken until I reverted to the old version.

BillLeeDee

Anybody have any suggestions on this or doesn't anyone use this mod?

alexetgus

Sorry, i use another system, of my making, for social images.
I installed Optimus after i started a big SEO job on my site.
Optimus is a complement.

BillLeeDee

Thanks for the reply. Apparently there's some sort of bug or features have been removed, so I'll use the older version for now.

njtweb

Quote from: BillLeeDee on May 14, 2018, 01:14:25 PM
I don't know if this is widespread or not, but when I upgraded from 1.9.6 to 1.9.7.2 or 1.9.7.3 I lost all the open graph tags, regardless of the settings. Reverting back to 1.9.6 returned them to the forum. I didn't check anything else to see what wasn't working with the 1.9.7.x version as when I noticed all my Twitter cards were broken until I reverted to the old version.

Did you install optimus.zip or optimus_smf21.zip?

pocttopus

Hello,

I am receiving a lot of errors and I don't know how to fix this... I had noticed that this issue is related with optimus modificiation.
In this message I had uploaded Class-Optimus.php
Is there any fix!?

Thanks!


alexetgus

Hello

Use this file. I changed lines 475 to 478.
if (!empty($context['canonical_url'])) {
$open_graph .= '
<meta property="og:url" content="' . $context['canonical_url'] . '" />';
}


These errors are caused by the absence of canonical url on SMF privates pages (admin, PM, ...)

pocttopus

Quote from: alexetgus on July 20, 2018, 01:42:51 PM
Hello

Use this file. I changed lines 475 to 478.
if (!empty($context['canonical_url'])) {
$open_graph .= '
<meta property="og:url" content="' . $context['canonical_url'] . '" />';
}


These errors are caused by the absence of canonical url on SMF privates pages (admin, PM, ...)
Thanks, I had uploaded the file and see how it goes...

alexetgus

I'm not sure that Optimus is compatible with Pretty URL... :-\

pocttopus

Quote from: alexetgus on July 20, 2018, 03:03:45 PM
I'm not sure that Optimus is compatible with Pretty URL... :-\
Thanks for the advice... now I had removed PrettyUrl's and not to worry.

Bugo

Quote from: alexetgus on July 20, 2018, 03:03:45 PM
I'm not sure that Optimus is compatible with Pretty URL... :-\
It is compatible and works with the latest version very well.

pocttopus

Quote from: Bugo on July 21, 2018, 01:02:31 AM
Quote from: alexetgus on July 20, 2018, 03:03:45 PM
I'm not sure that Optimus is compatible with Pretty URL... :-\
It is compatible and works with the latest version very well.
Now I am able to return PrettyUrl's?  :o

Bugo


Advertisement: